aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-13 08:45:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-13 10:06:14 +0000
commitd41c16726cad652cc56320caef4216413abf08e7 (patch)
treea4502a6f92efd0f435df1b50a41e5e751c3f3e52 /games
parent9478f7bb95a4923e7535303bb7a6639791ccc27a (diff)
downloadports-d41c16726cad652cc56320caef4216413abf08e7.tar.gz
ports-d41c16726cad652cc56320caef4216413abf08e7.zip
games/slump: Fix build with llvm15
- Pet portclippy - Adopt port
Diffstat (limited to 'games')
-rw-r--r--games/slump/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/games/slump/Makefile b/games/slump/Makefile
index 8be6abc2dbd8..d3be126347a9 100644
--- a/games/slump/Makefile
+++ b/games/slump/Makefile
@@ -3,19 +3,26 @@ PORTVERSION= 0.003.02
CATEGORIES= games
MASTER_SITES= http://www.samiam.org/slump/old/slump/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Fork of SLIGE that is optimized for making FreeDoom maps
WWW= https://www.samiam.org/slump.html
LICENSE= GPLv2+
-OPTIONS_DEFINE= DOCS
-
USES= tar:bzip2
+
MAKE_ARGS= FLAGS="${CFLAGS}"
-PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${STAGEDIR}${PREFIX}/bin)