aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-04-27 05:01:11 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-04-27 05:01:11 +0000
commitd812e4329dffef27492f01e3b8e13f06af940d3d (patch)
tree160d9d2817cd5971d010e0fd6018b501a5c26f1b /games
parent921a32b9cd5e1f0da8898c1d73fd9fb582bfb958 (diff)
downloadports-d812e4329dffef27492f01e3b8e13f06af940d3d.tar.gz
ports-d812e4329dffef27492f01e3b8e13f06af940d3d.zip
Imports of xoids 1.5, an X11 Asteroids clone.
PR: 6048 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=10703
Diffstat (limited to 'games')
-rw-r--r--games/xoids/Makefile29
-rw-r--r--games/xoids/distinfo1
-rw-r--r--games/xoids/files/patch-aa11
-rw-r--r--games/xoids/pkg-comment1
-rw-r--r--games/xoids/pkg-descr16
-rw-r--r--games/xoids/pkg-plist4
6 files changed, 62 insertions, 0 deletions
diff --git a/games/xoids/Makefile b/games/xoids/Makefile
new file mode 100644
index 000000000000..517874f6947e
--- /dev/null
+++ b/games/xoids/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xoids
+# Version required: 1.5
+# Date created: 16 March 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= xoids-1.5
+CATEGORIES= games x11
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= games
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+MAN6= xoids.6
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xoids ${PREFIX}/bin
+ @ ${INSTALL_DATA} ${WRKSRC}/xoids.1x ${PREFIX}/man/man6/xoids.6
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/xoids
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xoids
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/xoids/distinfo b/games/xoids/distinfo
new file mode 100644
index 000000000000..3a5501e07a4b
--- /dev/null
+++ b/games/xoids/distinfo
@@ -0,0 +1 @@
+MD5 (xoids-1.5.tar.gz) = e620cbf2d3a4bdd5a817485c94e4a1b3
diff --git a/games/xoids/files/patch-aa b/games/xoids/files/patch-aa
new file mode 100644
index 000000000000..83aebbc056c8
--- /dev/null
+++ b/games/xoids/files/patch-aa
@@ -0,0 +1,11 @@
+--- Imakefile.orig Tue Jun 25 02:42:14 1996
++++ Imakefile Mon Apr 27 00:58:16 1998
+@@ -24,6 +24,8 @@
+ #endif
+
+ #if defined(FreeBSDArchitecture)
++XPM_INC_FLAGS = -I$(X11BASE)/include/X11
++XPM_LIB_FLAGS = -lXpm
+ #endif
+
+ SRCS = init.c oids.c oids_x.c
diff --git a/games/xoids/pkg-comment b/games/xoids/pkg-comment
new file mode 100644
index 000000000000..7793d26d683d
--- /dev/null
+++ b/games/xoids/pkg-comment
@@ -0,0 +1 @@
+X Window Asteroids style game with full color pixmaps.
diff --git a/games/xoids/pkg-descr b/games/xoids/pkg-descr
new file mode 100644
index 000000000000..9324f67fd550
--- /dev/null
+++ b/games/xoids/pkg-descr
@@ -0,0 +1,16 @@
+ Xoids is an asteroids-type game written for X in my (spare) time. The
+game was originally developed on a Sun4 system while on an oceanographic
+research cruise. It's by no means finished.
+
+ While Xoids is strikingly similar to the original Asteroids game,
+there are some differences:
+
+ o Full color pixmaps
+ o One or Two Player (duel and cooperative) modes
+ o Can bounce off asteroids instead of dying (if going slow)
+ o Shots have relative speed, and impart intertia to the ship
+ o Asteroids have appropriate "masses": realistic physics
+ o The alien (called the Slurb) tracks players rather than
+ flying around aimlessly
+ o Thrusting and using hyperspace can overheat your engines (boom!)
+ o Co-op mode links players together via a flexible space-cable
diff --git a/games/xoids/pkg-plist b/games/xoids/pkg-plist
new file mode 100644
index 000000000000..1f31cd5ebc2e
--- /dev/null
+++ b/games/xoids/pkg-plist
@@ -0,0 +1,4 @@
+bin/xoids
+man/man6/xoids.6.gz
+share/doc/xoids/README
+@dirrm share/doc/xoids