aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-25 02:05:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-01-25 02:05:57 +0000
commitea74af2f3a23641bc2ddb33f0a6147ec359bee0d (patch)
tree632d3af141956e9ab4ac19f7849a051d7970af21 /games
parent47d1179777b71fff7a9f33f865b7970c84920129 (diff)
downloadports-ea74af2f3a23641bc2ddb33f0a6147ec359bee0d.tar.gz
ports-ea74af2f3a23641bc2ddb33f0a6147ec359bee0d.zip
Remake of Bolder Dash from BK-0010 with INSTEAD engine
Notes
Notes: svn path=/head/; revision=377856
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/minerbold/Makefile39
-rw-r--r--games/minerbold/distinfo2
-rw-r--r--games/minerbold/pkg-descr3
4 files changed, 45 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 145cb10d6f9d..b277e28630ef 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -590,6 +590,7 @@
SUBDIR += mindguard
SUBDIR += minecraft-client
SUBDIR += minecraft-server
+ SUBDIR += minerbold
SUBDIR += minetest
SUBDIR += minetest_game
SUBDIR += mirrormagic
diff --git a/games/minerbold/Makefile b/games/minerbold/Makefile
new file mode 100644
index 000000000000..aa0efc66616e
--- /dev/null
+++ b/games/minerbold/Makefile
@@ -0,0 +1,39 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= minerbold
+PORTVERSION= git20150125
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Remake of Bolder Dash from BK-0010 with INSTEAD engine
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= instead:${PORTSDIR}/games/instead
+
+USE_GITHUB= yes
+GH_ACCOUNT= gl00my
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 49cbad1
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+DATADIR= ${PREFIX}/share/instead/games/${PORTNAME}
+
+PORTDATA= *
+
+DESKTOP_ENTRIES="minerbold" \
+ "" \
+ "${DATADIR}/gfx/04.png" \
+ "${LOCALBASE}/bin/instead ${DATADIR}" \
+ "Game;ArcadeGame;" \
+ ""
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "*.lua *.ini gfx snd" \
+ ${STAGEDIR}${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/games/minerbold/distinfo b/games/minerbold/distinfo
new file mode 100644
index 000000000000..88703f0b40b1
--- /dev/null
+++ b/games/minerbold/distinfo
@@ -0,0 +1,2 @@
+SHA256 (minerbold-git20150125.tar.gz) = c47380598153a45b266b1420b7d65c1d16f09aaafd382914ec00ffa9e4331d72
+SIZE (minerbold-git20150125.tar.gz) = 26654
diff --git a/games/minerbold/pkg-descr b/games/minerbold/pkg-descr
new file mode 100644
index 000000000000..de61a8bbc332
--- /dev/null
+++ b/games/minerbold/pkg-descr
@@ -0,0 +1,3 @@
+Remake of Bolder Dash from BK-0010 with INSTEAD engine
+
+WWW: https://github.com/gl00my/minerbold