aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:02:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:02:44 +0000
commitf7c0630cd25902e9d0299337f0075f1969f3c15c (patch)
treea943d8b41968bc02a35c01063aaf35f112a2ce09 /games
parent3e2fd4b788942461b3fbd53d7edac9a1abc3488e (diff)
downloadports-f7c0630cd25902e9d0299337f0075f1969f3c15c.tar.gz
ports-f7c0630cd25902e9d0299337f0075f1969f3c15c.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200772
Diffstat (limited to 'games')
-rw-r--r--games/alienblaster/Makefile8
-rw-r--r--games/asc/Makefile4
-rw-r--r--games/bitefusion/Makefile7
-rw-r--r--games/blokish/Makefile8
-rw-r--r--games/bloodfrontier/Makefile4
-rw-r--r--games/bsp/Makefile8
-rw-r--r--games/bzflag/Makefile8
-rw-r--r--games/ceferino/Makefile10
-rw-r--r--games/fgsd/Makefile8
-rw-r--r--games/flightgear/Makefile8
-rw-r--r--games/galaxyhack/Makefile4
-rw-r--r--games/gshisen/Makefile11
-rw-r--r--games/gtkradiant/Makefile9
-rw-r--r--games/kiki/Makefile8
-rw-r--r--games/kmastermind/Makefile8
-rw-r--r--games/lincity-ng/Makefile7
-rw-r--r--games/marsnomercy/Makefile4
-rw-r--r--games/mudmagic/Makefile8
-rw-r--r--games/qkmj/Makefile10
-rw-r--r--games/quake2forge/Makefile3
-rw-r--r--games/redeclipse/Makefile4
-rw-r--r--games/sauerbraten/Makefile4
-rw-r--r--games/stroq/Makefile8
-rw-r--r--games/timeseal/Makefile7
-rw-r--r--games/toppler/Makefile8
-rw-r--r--games/uqm/Makefile4
-rw-r--r--games/wop/Makefile12
-rw-r--r--games/xye/Makefile8
28 files changed, 25 insertions, 175 deletions
diff --git a/games/alienblaster/Makefile b/games/alienblaster/Makefile
index bb52606fafce..d000cdb92eeb 100644
--- a/games/alienblaster/Makefile
+++ b/games/alienblaster/Makefile
@@ -21,12 +21,6 @@ REINPLACE_ARGS= -i ''
WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "use atoll() interface"
-.endif
-
post-patch:
# Fix make command
@${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${WRKSRC}/${MAKEFILE}
@@ -57,4 +51,4 @@ do-install:
${CP} -R ${WRKSRC}/${d} ${DATADIR}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 0f8a74d4d17b..4f7351451cc6 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -65,8 +65,4 @@ pre-build:
post-install:
@${CAT} ${PKGMESSAGE}
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
.include <bsd.port.post.mk>
diff --git a/games/bitefusion/Makefile b/games/bitefusion/Makefile
index ea1a1e63d9ba..880df5537613 100644
--- a/games/bitefusion/Makefile
+++ b/games/bitefusion/Makefile
@@ -24,14 +24,9 @@ CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
PLIST_FILES= bin/bitefusion
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|-linux-gnu|-portbld-freebsd|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.in
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint.h|sys/inttypes.h|' ${WRKSRC}/image.c
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/blokish/Makefile b/games/blokish/Makefile
index 536421785f06..972f08b07030 100644
--- a/games/blokish/Makefile
+++ b/games/blokish/Makefile
@@ -32,13 +32,7 @@ WRKSRC= ${WRKDIR}/blokish
PLIST_FILES= bin/blokish
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-ai.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|' ${WRKSRC}/makefile.in ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index a4b1597961e5..49d786c07183 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -39,10 +39,6 @@ SAUDATDIR= packages data
IGNORE= needs at least one executable (CLIENT or DEDICATED)
.endif
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
.if !defined(WITHOUT_CLIENT)
USE_GL= yes
USE_SDL= image mixer sdl
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
index d372a01e0349..ae6266957e1f 100644
--- a/games/bsp/Makefile
+++ b/games/bsp/Makefile
@@ -30,10 +30,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/bzflag/Makefile b/games/bzflag/Makefile
index 6e15db668e49..7f400dbfe6a7 100644
--- a/games/bzflag/Makefile
+++ b/games/bzflag/Makefile
@@ -30,14 +30,8 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
MAN5= bzw.5
MAN6= bzadmin.6 bzflag.6 bzfquery.6 bzfs.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|@LINUX_TRUE@||g ; \
s|@LINUX_FALSE@|#|g' ${WRKSRC}/src/platform/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 1098f068feb7..da1088840b10 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -38,10 +38,6 @@ PLIST_SUB+= NLS=""
FLAG_NLS= true
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
post-extract:
@${REINPLACE_CMD} -e 's/-lSDL /`sdl-config --libs`/g' ${WRKSRC}/configure
@@ -55,9 +51,9 @@ do-install:
${FIND} ${CEFEDIRS} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E ${CEFEDIRS} -type f -iregex ".*\.(png|jpg|xm|map|wav)" -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
.if defined(FLAG_NLS)
-.for FILE in es ca fr
- ${MKDIR} ${PREFIX}/share/locale/${FILE}/LC_MESSAGES && \
- ${INSTALL_DATA} ${WRKSRC}/po/${FILE}.gmo ${PREFIX}/share/locale/${FILE}/LC_MESSAGES/${PORTNAME}.mo
+.for f in es ca fr
+ ${MKDIR} ${PREFIX}/share/locale/${f}/LC_MESSAGES && \
+ ${INSTALL_DATA} ${WRKSRC}/po/${f}.gmo ${PREFIX}/share/locale/${f}/LC_MESSAGES/${PORTNAME}.mo
.endfor
.endif
diff --git a/games/fgsd/Makefile b/games/fgsd/Makefile
index bea2611d9af2..fe7641129ab5 100644
--- a/games/fgsd/Makefile
+++ b/games/fgsd/Makefile
@@ -42,12 +42,6 @@ DESKTOP_ENTRIES="FlightGear Scenery Designer" \
"Application;Graphics;" \
false
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build on FreeBSD 4.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-lgif|-lungif|' ${WRKSRC}/configure
@@ -55,4 +49,4 @@ post-install:
${MKDIR} ${PREFIX}/share/pixmaps
${INSTALL_DATA} ${WRKSRC}/src/curves.xpm ${PREFIX}/share/pixmaps/fgsd.xpm
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 6da0372d5eb1..629fd676528f 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -39,12 +39,6 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= does not build on FreeBSD 4.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \
${WRKSRC}/configure
@@ -53,4 +47,4 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/galaxyhack/Makefile b/games/galaxyhack/Makefile
index a8e446ee520b..90a66a794bd8 100644
--- a/games/galaxyhack/Makefile
+++ b/games/galaxyhack/Makefile
@@ -34,10 +34,6 @@ FLEETS_FILE= gh_fleets_020906.zip
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= needs isspace() function in libc (FreeBSD >= 5.X)
-.endif
-
.if defined(WITH_FLEETS)
EXTRACT_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
DISTFILES+= ${FLEETS_FILE}
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
index 036051b992a6..28181519b468 100644
--- a/games/gshisen/Makefile
+++ b/games/gshisen/Makefile
@@ -25,13 +25,4 @@ post-patch:
${REINPLACE_CMD} -e 's|)/Makefiles|)/Library/Makefiles|' \
${WRKSRC}/GNUmakefile
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-# Fatal error 'longjmp()ing between thread contexts is undefined by POSIX 1003.1'
-# at line ? in file src/lib/libc_r/uthread/uthread_jmp.c (errno = ?)
-# Abort trap (core dumped)
-BROKEN= longjmp()ing between thread contexts in src/lib/libc_r/uthread/uthread_jmp.c
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/gtkradiant/Makefile b/games/gtkradiant/Makefile
index 8f5cafea37ff..e3844027b329 100644
--- a/games/gtkradiant/Makefile
+++ b/games/gtkradiant/Makefile
@@ -35,13 +35,6 @@ SCONS_ARGS= ${MAKE_ENV} BUILD=release PTHREAD_LIBS="${PTHREAD_LIBS}"
SUB_FILES= ${PORTNAME}
DATADIR= ${PREFIX}/lib/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libs__bytestreamutils.h \
- ${FILESDIR}/extra-patch-libs__math__vector.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/-ldl//' ${WRKSRC}/SConscript
@${GREP} -Rl 'defined[[:blank:]]*([[:blank:]]*__linux__[[:blank:]]*) || defined[[:blank:]]*([[:blank:]]*__APPLE__[[:blank:]]*)' ${WRKSRC} | \
@@ -57,4 +50,4 @@ do-install:
${CP} -R ${WRKSRC}/install/* ${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/kiki/Makefile b/games/kiki/Makefile
index 8cd8b2203368..d0c60da0435c 100644
--- a/games/kiki/Makefile
+++ b/games/kiki/Makefile
@@ -30,12 +30,6 @@ MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
WRKSRC= ${WRKDIR}/kiki
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-kodilib-src-types-kvector.h
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^CXXFLAGS/ s|.*|CXXFLAGS+=$$(KODI_INCLUDES) -I${X11BASE}/include `${SDL_CONFIG} --cflags`|' ${WRKSRC}/kodilib/linux/Makefile
@${REINPLACE_CMD} -e '/^X11_INCLUDES/ s|/.*/|${X11BASE}/include|' ${WRKSRC}/linux/Makefile
@@ -58,4 +52,4 @@ do-install:
${FIND} . -type f -exec ${INSTALL_DATA} {} ${DATADIR}/${d}/{} \;
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/kmastermind/Makefile b/games/kmastermind/Makefile
index 685dbf358079..d103d37cc060 100644
--- a/games/kmastermind/Makefile
+++ b/games/kmastermind/Makefile
@@ -22,12 +22,6 @@ USE_KDELIBS_VER= 3
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
pre-configure:
${LN} -sfh \
`cd ${PORTSDIR}/x11/kdelibs3 && ${MAKE} -V WRKSRC`/admin \
@@ -35,4 +29,4 @@ pre-configure:
${TOUCH} ${WRKSRC}/NEWS
cd ${WRKSRC}; ${MAKE} -f admin/Makefile.common cvs
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index b3fc09656a98..39e1763ee784 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -33,13 +33,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-pre-configure::
- @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
- ${WRKSRC}/src/gui/Filter.cpp ${WRKSRC}/src/gui/Gradient.hpp \
- ${WRKSRC}/src/gui/Color.hpp
-.endif
-
.if ${OSVERSION} < 504000
pre-configure::
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-src-gui-Gradient.cpp
diff --git a/games/marsnomercy/Makefile b/games/marsnomercy/Makefile
index 3311e4a7eec1..ead6bc5b1bd8 100644
--- a/games/marsnomercy/Makefile
+++ b/games/marsnomercy/Makefile
@@ -34,10 +34,6 @@ OPTIONS= DEBUG "With additional debug information" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not build on FreeBSD 4.x
-.endif
-
.if defined(WITH_DEBUG)
SCONS_ARGS+= debug=1
.else
diff --git a/games/mudmagic/Makefile b/games/mudmagic/Makefile
index 773b865354e2..478c0c39a3a5 100644
--- a/games/mudmagic/Makefile
+++ b/games/mudmagic/Makefile
@@ -30,10 +30,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= mudmagic.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/qkmj/Makefile b/games/qkmj/Makefile
index 9420b947696b..8d8edd188452 100644
--- a/games/qkmj/Makefile
+++ b/games/qkmj/Makefile
@@ -17,17 +17,13 @@ EXTRACT_ONLY=
MAINTAINER= clive@FreeBSD.org
COMMENT= QKMJ - QK Ma2Jong4 client
+RUN_DEPENDS= compat4x-i386>=0:${PORTSDIR}/misc/compat4x
+
ONLY_FOR_ARCHS= i386 amd64
IA32_BINARY_PORT= yes
PLIST_FILES= libexec/qkmj95p5-freebsd bin/qkmj
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-RUN_DEPENDS+= compat4x-i386>=0:${PORTSDIR}/misc/compat4x
-.endif
-
NO_WRKSUBDIR= yes
NO_BUILD= yes
NO_CDROM= 'Do not sell for profit.'
@@ -39,4 +35,4 @@ do-install:
@${CHMOD} +x ${PREFIX}/bin/${PORTNAME}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index 7434a734b087..379d85a64aeb 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -107,9 +107,6 @@ post-patch:
's|\($$(libdir)/\)@PACKAGE@|\1${PORTNAME}|'
@${REINPLACE_CMD} -e 's|\($$libdir/\)$$PACKAGE|\1${PORTNAME}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}.in
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's/%zu/%u/g' ${WRKSRC}/src/main.c
-.endif
.for f in ${Q2F_BADMODS}
@${REINPLACE_CMD} -i "" -e 's/${f}//' ${WRKSRC}/src/Makefile.in
.endfor
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index a4b1597961e5..49d786c07183 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -39,10 +39,6 @@ SAUDATDIR= packages data
IGNORE= needs at least one executable (CLIENT or DEDICATED)
.endif
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
.if !defined(WITHOUT_CLIENT)
USE_GL= yes
USE_SDL= image mixer sdl
diff --git a/games/sauerbraten/Makefile b/games/sauerbraten/Makefile
index a4b1597961e5..49d786c07183 100644
--- a/games/sauerbraten/Makefile
+++ b/games/sauerbraten/Makefile
@@ -39,10 +39,6 @@ SAUDATDIR= packages data
IGNORE= needs at least one executable (CLIENT or DEDICATED)
.endif
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
.if !defined(WITHOUT_CLIENT)
USE_GL= yes
USE_SDL= image mixer sdl
diff --git a/games/stroq/Makefile b/games/stroq/Makefile
index 296acb71daf1..13f9ea08e3ea 100644
--- a/games/stroq/Makefile
+++ b/games/stroq/Makefile
@@ -23,12 +23,6 @@ MAKE_ENV= QTDIR="${QT_PREFIX}"
QMAKE= qmake
QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|PlaySquare::||' ${WRKSRC}/playsquare.h
${REINPLACE_CMD} -e 's|Puzzle::||' ${WRKSRC}/puzzle.h
@@ -47,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/timeseal/Makefile b/games/timeseal/Makefile
index 9b9038509f8b..c022c4334d89 100644
--- a/games/timeseal/Makefile
+++ b/games/timeseal/Makefile
@@ -20,12 +20,7 @@ ONLY_FOR_ARCHS= i386 amd64
NO_BUILD= yes
STRIP= # strip(1) does not support a.out binaries
PLIST_FILES= bin/timeseal
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
PKGMESSAGE= pkg-message.aout
-.endif
do-install:
${INSTALL_PROGRAM} ${_DISTDIR}/${_DISTFILES} ${PREFIX}/bin/timeseal
@@ -35,4 +30,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index 88ebd8fe54bd..0ce677f49e94 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -26,16 +26,10 @@ CONFIGURE_ARGS= --program-transform-name= --localstatedir=/var/games
MAN6= toppler.6
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= can not be compiled because it requires mbrtowc() in libc
-.endif
-
post-install:
@${CHOWN} root:games ${PREFIX}/bin/toppler
@${CHMOD} g+s ${PREFIX}/bin/toppler
@${SETENV} "PKG_PREFIX=${PREFIX}" \
${SH} pkg-install ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/uqm/Makefile b/games/uqm/Makefile
index ed4dd0d31145..bc9cd943e13b 100644
--- a/games/uqm/Makefile
+++ b/games/uqm/Makefile
@@ -57,10 +57,6 @@ PLIST_SUB+= MUSICADDON="@comment "
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
.endif
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
post-extract:
${MKDIR} ${WRKSRC}/sc2/content/packages
${CP} ${DISTDIR}/${PORTNAME}-${DATAVERSION}-content.uqm ${WRKSRC}/sc2/content/packages/
diff --git a/games/wop/Makefile b/games/wop/Makefile
index 3a1774c161fd..26e880bfed1d 100644
--- a/games/wop/Makefile
+++ b/games/wop/Makefile
@@ -28,12 +28,6 @@ MAKE_ENV= "CXX=${CXX}"
DATAVERSION= 2005-12-21
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src-global.hpp
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|__va_copy|va_copy|g' ${WRKSRC}/src/string.cpp
@${REINPLACE_CMD} -e 's|; make|; ${GMAKE}|g' ${WRKSRC}/Makefile ${WRKSRC}/src/Makefile
@@ -57,9 +51,9 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for file in AUTHORS COPYING ChangeLog README README-COMMAND-LINE-OPTIONS.txt
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for f in AUTHORS COPYING ChangeLog README README-COMMAND-LINE-OPTIONS.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xye/Makefile b/games/xye/Makefile
index 88dace3602f9..bac23fb50912 100644
--- a/games/xye/Makefile
+++ b/games/xye/Makefile
@@ -20,10 +20,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-docdir=${PREFIX}/share/doc
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not build on FreeBSD 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>