aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2023-06-05 14:07:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2023-06-05 15:49:42 +0000
commitfc03e3da69931447e8bbdb0a6b515283b975a28c (patch)
tree00c9e857b73aefd709c36b705e00fa4fbc5f66ec /games
parent70d3f7f2a86f733b06a96b4e89c424a36a87602e (diff)
downloadports-fc03e3da69931447e8bbdb0a6b515283b975a28c.tar.gz
ports-fc03e3da69931447e8bbdb0a6b515283b975a28c.zip
games/wargus: fix build with recent c++ library
In recent c++ library (such as on 14.x), <experimental/filesystem> header would be removed in favor of standard <filesystem>. Remove check for the former and don't do weird stuff when experimental/filesystem is not present. This is similar to 092787dffe45ea6ee1c5ea3b8cede34eea142992 for games/stratagus Reported by: pkg-fallout
Diffstat (limited to 'games')
-rw-r--r--games/wargus/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/games/wargus/files/patch-CMakeLists.txt b/games/wargus/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..4711489c192c
--- /dev/null
+++ b/games/wargus/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2022-08-10 18:15:26 UTC
++++ CMakeLists.txt
+@@ -162,7 +162,7 @@ set(wartool_LIBS ${pudconvert_LIBS} ${PNG_LIBRARIES} $
+
+ if(WIN32 AND MSVC)
+ add_definitions(-D_CRT_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_DEPRECATE=1)
+-else()
++elseif(FALSE)
+ include(CheckCXXSourceCompiles)
+ set(FS_SRC "
+ #include <experimental/filesystem>