aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-04-05 08:50:40 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-04-05 08:50:40 +0000
commitfed3ef2f5f50d8d64c54d6fd33bbf3c08adb19d9 (patch)
tree85a015672d9ac7271900a68b285df2875ab90c02 /games
parent59e1e3ab82edf9602f83848873e585d58d03b44a (diff)
downloadports-fed3ef2f5f50d8d64c54d6fd33bbf3c08adb19d9.tar.gz
ports-fed3ef2f5f50d8d64c54d6fd33bbf3c08adb19d9.zip
New port: games/flightgear-terragear
TerraGear is a collection of tools for building scenery for the FlightGear project. Generally, the process is done in two steps: 1. Preprocess the original raw data. This chops up the data into the FG tiling scheme and saves it in a simple, intermediate format. 2. Collect all the different pieces of intermediate data and assemble them into a 3d model of the terrain. WWW: https://github.com/FlightGear/terragear PR: 223648 Submitted by: Michael Danilov <mike.d.ft402@gmail.com>
Notes
Notes: svn path=/head/; revision=466542
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/flightgear-terragear/Makefile32
-rw-r--r--games/flightgear-terragear/distinfo3
-rw-r--r--games/flightgear-terragear/files/patch-tg_misc.cxx20
-rw-r--r--games/flightgear-terragear/files/patch-tg_shapefile.cxx11
-rw-r--r--games/flightgear-terragear/pkg-descr11
-rw-r--r--games/flightgear-terragear/pkg-plist14
7 files changed, 92 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 62d3d867be39..2cc3a593507c 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -280,6 +280,7 @@
SUBDIR += flightgear-aircraft
SUBDIR += flightgear-data
SUBDIR += flightgear-mb339-pan
+ SUBDIR += flightgear-terragear
SUBDIR += flobopuyo
SUBDIR += flukz
SUBDIR += flyhard
diff --git a/games/flightgear-terragear/Makefile b/games/flightgear-terragear/Makefile
new file mode 100644
index 000000000000..450a5f8315d8
--- /dev/null
+++ b/games/flightgear-terragear/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= flightgear-terragear
+PORTVERSION= 20171007
+CATEGORIES= games
+
+MAINTAINER= mike.d.ft402@gmail.com
+COMMENT= Tools for building scenery for the FlightGear project
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+LIB_DEPENDS= libCGAL.so:math/cgal \
+ libgdal.so:graphics/gdal \
+ libmpfr.so:math/mpfr \
+ libgmp.so:math/gmp \
+ libboost_thread.so:devel/boost-libs \
+ libboost_system.so:devel/boost-libs \
+ libboost_chrono.so:devel/boost-libs \
+ libboost_date_time.so:devel/boost-libs \
+ libboost_atomic.so:devel/boost-libs \
+ libtiff.so:graphics/tiff
+RUN_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= flightgear
+GH_PROJECT= terragear
+GH_TAGNAME= 5b5e5fc
+
+.include <bsd.port.mk>
diff --git a/games/flightgear-terragear/distinfo b/games/flightgear-terragear/distinfo
new file mode 100644
index 000000000000..1bde07875dc7
--- /dev/null
+++ b/games/flightgear-terragear/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510318229
+SHA256 (flightgear-terragear-20171007-5b5e5fc_GH0.tar.gz) = c590cc233238ce1a85e2270fdaa1eaef753ba5b481f602790b676afb932e6d7d
+SIZE (flightgear-terragear-20171007-5b5e5fc_GH0.tar.gz) = 2615341
diff --git a/games/flightgear-terragear/files/patch-tg_misc.cxx b/games/flightgear-terragear/files/patch-tg_misc.cxx
new file mode 100644
index 000000000000..ae18bc309501
--- /dev/null
+++ b/games/flightgear-terragear/files/patch-tg_misc.cxx
@@ -0,0 +1,20 @@
+--- src/Lib/terragear/tg_misc.cxx.orig 2017-10-07 06:58:20 UTC
++++ src/Lib/terragear/tg_misc.cxx
+@@ -112,8 +112,8 @@
+ ClipperLib::IntPoint min_pt, max_pt;
+ SGGeod min, max;
+
+- min_pt.X = min_pt.Y = LONG_LONG_MAX;
+- max_pt.X = max_pt.Y = LONG_LONG_MIN;
++ min_pt.X = min_pt.Y = LLONG_MAX;
++ max_pt.X = max_pt.Y = LLONG_MIN;
+
+ // for each polygon, we need to check the orientation, to set the hole flag...
+ for (unsigned int i=0; i<subject.size(); i++)
+@@ -377,4 +377,4 @@
+ // handle the no intersection case.
+ return false;
+ }
+-}
+\ No newline at end of file
++}
diff --git a/games/flightgear-terragear/files/patch-tg_shapefile.cxx b/games/flightgear-terragear/files/patch-tg_shapefile.cxx
new file mode 100644
index 000000000000..46e249f09b51
--- /dev/null
+++ b/games/flightgear-terragear/files/patch-tg_shapefile.cxx
@@ -0,0 +1,11 @@
+--- src/Lib/terragear/tg_shapefile.cxx.orig 2017-10-07 06:58:20 UTC
++++ src/Lib/terragear/tg_shapefile.cxx
+@@ -152,7 +152,7 @@
+ }
+
+ // close after each write
+- if ( ds_id >= 0 ) {
++ if ( ds_id >= (void *)0 ) {
+ ds_id = tgShapefile::CloseDatasource( ds_id );
+ }
+ }
diff --git a/games/flightgear-terragear/pkg-descr b/games/flightgear-terragear/pkg-descr
new file mode 100644
index 000000000000..952c465787de
--- /dev/null
+++ b/games/flightgear-terragear/pkg-descr
@@ -0,0 +1,11 @@
+TerraGear is a collection of tools for building scenery for the
+FlightGear project. Generally, the process is done in two steps:
+
+ 1. Preprocess the original raw data. This chops up the data into
+ the FG tiling scheme and saves it in a simple, intermediate
+ format.
+
+ 2. Collect all the different pieces of intermediate data and
+ assemble them into a 3d model of the terrain.
+
+WWW: https://github.com/FlightGear/terragear
diff --git a/games/flightgear-terragear/pkg-plist b/games/flightgear-terragear/pkg-plist
new file mode 100644
index 000000000000..85aa63d3313c
--- /dev/null
+++ b/games/flightgear-terragear/pkg-plist
@@ -0,0 +1,14 @@
+bin/demchop
+bin/fillvoids
+bin/gdalchop
+bin/genapts850
+bin/hgtchop
+bin/ogr-decode
+bin/poly2ogr
+bin/srtmchop
+bin/terrafit
+bin/test_array
+bin/testassem
+bin/tg-construct
+share/TerraGear/default_priorities.txt
+share/TerraGear/usgsmap.txt