aboutsummaryrefslogtreecommitdiff
path: root/german
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 10:53:27 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 10:53:27 +0000
commitbc07afc1c299155a3451d285f1e3c862af0c8e83 (patch)
tree1fecad8c5762f1c1f723e927775d4b37b5a0f7d9 /german
parent5406488640c9d4292c7a5349facb9e09d7fb04dc (diff)
downloadports-bc07afc1c299155a3451d285f1e3c862af0c8e83.tar.gz
ports-bc07afc1c299155a3451d285f1e3c862af0c8e83.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Notes
Notes: svn path=/head/; revision=53954
Diffstat (limited to 'german')
-rw-r--r--german/BBBike/Makefile6
-rw-r--r--german/citrix_ica/Makefile4
-rw-r--r--german/citrix_xenapp/Makefile4
-rw-r--r--german/staroffice5/Makefile2
-rw-r--r--german/staroffice52/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/german/BBBike/Makefile b/german/BBBike/Makefile
index 7d18adb0d03d..fc28d96caaf0 100644
--- a/german/BBBike/Makefile
+++ b/german/BBBike/Makefile
@@ -30,7 +30,7 @@ do-build:
cd ${WRKSRC}/ext/VirtArray; ${PERL5} Makefile.PL; make all install clean; ${RM} Makefile.old
cd ${WRKSRC}; ${POD2MAN} --lax bbbike.pod > bbbike.1
${MV} ${WRKSRC}/bbbike ${WRKSRC}/bbbike.tmp
- ${ECHO} "#! ${PERL}" > ${WRKSRC}/bbbike
+ ${ECHO_CMD} "#! ${PERL}" > ${WRKSRC}/bbbike
${CAT} ${WRKSRC}/bbbike.tmp >> ${WRKSRC}/bbbike
${RM} -f ${WRKSRC}/bbbike.tmp
${CHMOD} 0755 ${WRKSRC}/bbbike
@@ -40,8 +40,8 @@ BBBIKEEXE= bbbike cbbbike bbbikeclient cmdbbbike
do-install:
-${RM} -rf ${MYDESTDIR}
${CP} -r ${WRKSRC} ${MYDESTDIR}
- find ${MYDESTDIR} -exec ${CHMOD} ugo+r {} \;
- find ${MYDESTDIR} -perm -u=x -exec ${CHMOD} go+x {} \;
+ ${FIND} ${MYDESTDIR} -exec ${CHMOD} ugo+r {} \;
+ ${FIND} ${MYDESTDIR} -perm -u=x -exec ${CHMOD} go+x {} \;
.for f in ${BBBIKEEXE}
-${RM} -f ${PREFIX}/bin/$f
${LN} -s ${MYDESTDIR}/$f ${PREFIX}/bin/$f
diff --git a/german/citrix_ica/Makefile b/german/citrix_ica/Makefile
index 26308f45817b..c2f45e5acc94 100644
--- a/german/citrix_ica/Makefile
+++ b/german/citrix_ica/Makefile
@@ -52,13 +52,13 @@ do-install:
${FALSE} ; \
fi
- @${ECHO} -e "1\n${CDIR}\nj\nj\nj\nj\n3" > ${WRKSRC}/response ;
+ @${ECHO_CMD} -e "1\n${CDIR}\nj\nj\nj\nj\n3" > ${WRKSRC}/response ;
@for dir in ${NSCP}; do \
if [ -e $${dir}/plugins/libnullplugin.so ]; then \
BIN=`${FILE} $${dir}/plugins/libnullplugin.so | ${AWK} '{print $$11}'` ; \
case $${BIN} in \
\(SYSV\),) \
- ${ECHO} -e "1\n${CDIR}\nj\nj\nj\n3" > ${WRKSRC}/response ; \
+ ${ECHO_CMD} -e "1\n${CDIR}\nj\nj\nj\n3" > ${WRKSRC}/response ; \
esac \
fi \
done
diff --git a/german/citrix_xenapp/Makefile b/german/citrix_xenapp/Makefile
index 26308f45817b..c2f45e5acc94 100644
--- a/german/citrix_xenapp/Makefile
+++ b/german/citrix_xenapp/Makefile
@@ -52,13 +52,13 @@ do-install:
${FALSE} ; \
fi
- @${ECHO} -e "1\n${CDIR}\nj\nj\nj\nj\n3" > ${WRKSRC}/response ;
+ @${ECHO_CMD} -e "1\n${CDIR}\nj\nj\nj\nj\n3" > ${WRKSRC}/response ;
@for dir in ${NSCP}; do \
if [ -e $${dir}/plugins/libnullplugin.so ]; then \
BIN=`${FILE} $${dir}/plugins/libnullplugin.so | ${AWK} '{print $$11}'` ; \
case $${BIN} in \
\(SYSV\),) \
- ${ECHO} -e "1\n${CDIR}\nj\nj\nj\n3" > ${WRKSRC}/response ; \
+ ${ECHO_CMD} -e "1\n${CDIR}\nj\nj\nj\n3" > ${WRKSRC}/response ; \
esac \
fi \
done
diff --git a/german/staroffice5/Makefile b/german/staroffice5/Makefile
index 615c9184d3a3..af260bf12a09 100644
--- a/german/staroffice5/Makefile
+++ b/german/staroffice5/Makefile
@@ -71,7 +71,7 @@ do-install:
@${LN} -fs /compat/linux/usr/local/Office51 ${PREFIX}/Office51
.endif
@${CP} /compat/linux/etc/ld.so.conf ${WRKDIR}/tmp/ld.so.conf.temp
- @${ECHO} "${WRKDIR}/tmp" >> ${WRKDIR}/tmp/ld.so.conf.temp
+ @${ECHO_CMD} "${WRKDIR}/tmp" >> ${WRKDIR}/tmp/ld.so.conf.temp
@PATH=${PATH}:${WRKDIR}/tmp
@LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${WRKDIR}/tmp:/usr/lib:/lib:/compat/linux/lib
@/compat/linux/sbin/ldconfig -f ${WRKDIR}/tmp/ld.so.conf.temp
diff --git a/german/staroffice52/Makefile b/german/staroffice52/Makefile
index 2a2a6b5a79c9..606940cd114a 100644
--- a/german/staroffice52/Makefile
+++ b/german/staroffice52/Makefile
@@ -43,8 +43,8 @@ LD_PATH= ${TMPDIR}:${WRKSRC}:${LINUXBASE}/lib:${LINUXBASE}/usr/lib
INSTDB.INS= ${PREFIX}/office52/program/instdb.ins
SUNSOLVE= ${WRKDIR}/109939-03
ADABAS_DIST= soa-5_2-ga-bin-linux-de.bin
-SIZE!= /bin/df -k . | /usr/bin/tail -n 1 | /usr/bin/awk '{print $$4}'
-LINPROCFS!= /sbin/mount | /usr/bin/grep linprocfs | /usr/bin/awk '{print $1}'
+SIZE!= /bin/df -k . | ${TAIL} -n 1 | ${AWK} '{print $$4}'
+LINPROCFS!= /sbin/mount | ${GREP} linprocfs | ${AWK} '{print $1}'
.include <bsd.port.pre.mk>