aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2007-11-02 14:50:52 +0000
committerMikhail Teterin <mi@FreeBSD.org>2007-11-02 14:50:52 +0000
commit7ae64abc401e74431f4a24ce0940d6304f8fb0cf (patch)
tree63933fbfefe546497893ab62c19eaeb40fdd395a /graphics/GraphicsMagick
parentbc25ade382f6d0273bd9340e6cc6f92c27d22267 (diff)
downloadports-7ae64abc401e74431f4a24ce0940d6304f8fb0cf.tar.gz
ports-7ae64abc401e74431f4a24ce0940d6304f8fb0cf.zip
Update from 1.1.7 to 1.1.10. FPX-support is now in (and no longer an
OPTION). Add support for running bundled self-tests after building. Do not run the self-tests by default, in order to be able to secure portmgr's approval, but advise the user to do so before installing. The self-tests will be turned on, when port-freeze is over. Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=202485
Diffstat (limited to 'graphics/GraphicsMagick')
-rw-r--r--graphics/GraphicsMagick/Makefile34
-rw-r--r--graphics/GraphicsMagick/distinfo6
-rw-r--r--graphics/GraphicsMagick/files/patch-Makefile.in24
-rw-r--r--graphics/GraphicsMagick/files/patch-coders-png.c22
-rw-r--r--graphics/GraphicsMagick/files/patch-newfpx20
-rw-r--r--graphics/GraphicsMagick/pkg-plist2
6 files changed, 56 insertions, 52 deletions
diff --git a/graphics/GraphicsMagick/Makefile b/graphics/GraphicsMagick/Makefile
index d58e5c521e30..ac88ab48cbb7 100644
--- a/graphics/GraphicsMagick/Makefile
+++ b/graphics/GraphicsMagick/Makefile
@@ -6,28 +6,27 @@
#
PORTNAME= GraphicsMagick
-PORTVERSION= 1.1.7
-PORTREVISION= 2
+PORTVERSION= 1.1.10
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
MASTER_SITE_SUBDIR= ${PORTNAME:L}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mi@aldan.algebra.com
COMMENT= Fast image processing tools based on ImageMagick
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ fpx.[2-9]:${PORTSDIR}/graphics/libfpx \
jbig:${PORTSDIR}/graphics/jbigkit \
- wmf:${PORTSDIR}/graphics/libwmf \
+ wmflite:${PORTSDIR}/graphics/libwmf \
xml2:${PORTSDIR}/textproc/libxml2
OTHERGRAPHICS= jasper jpeg lcms png tiff
LIB_DEPENDS+= ${OTHERGRAPHICS:C|(.+)|\1:${PORTSDIR}/graphics/\1|}
OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off
-# Use libfpx only on i386. On other systems it does not seem to work :-(
-OPTIONS+= FPX "Build FPX backend -- broken on non-i386 systems" \
- ${ARCH:S,i386,on,:C,^[^o].*,off,}
+OPTIONS+= TESTS "Run bundled self-tests after build" off
+USE_ICONV= yes
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GHOSTSCRIPT=yes
@@ -54,12 +53,17 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
.endif
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
+
.if !defined(NOPORTDOCS)
INSTALL_TARGET= install install-data-html
.endif
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+test check:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
+
.include <bsd.port.pre.mk>
# Perl and Tcl APIs will be installed by separate ports
@@ -70,12 +74,6 @@ PKGNAMESUFFIX+= -nox11
CONFIGURE_ARGS+=--without-x
.endif
-.if defined(WITH_FPX)
-LIB_DEPENDS+= fpx:${PORTSDIR}/graphics/libfpx
-.else
-CONFIGURE_ARGS+=--without-fpx
-.endif
-
.if defined(WITH_Q8BIT) || defined(WITHOUT_GRAPHICSMAGICK_16BIT_PIXEL)
CONFIGURE_ARGS+= --with-quantum-depth=8
PLIST_SUB+= Q=8
@@ -84,4 +82,14 @@ CONFIGURE_ARGS+= --with-quantum-depth=16
PLIST_SUB+= Q=16
.endif
+.if !defined(WITHOUT_TESTS)
+post-build:: test
+.else
+post-build::
+ #
+ # You are strongly advised to run ``make test'' now
+ # and report any failures to ${MAINTAINER}.
+ #
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/GraphicsMagick/distinfo b/graphics/GraphicsMagick/distinfo
index e95e45e200a3..d132917cb71e 100644
--- a/graphics/GraphicsMagick/distinfo
+++ b/graphics/GraphicsMagick/distinfo
@@ -1,3 +1,3 @@
-MD5 (GraphicsMagick-1.1.7.tar.bz2) = f75d830ca623bf10385b3ad62c48437a
-SHA256 (GraphicsMagick-1.1.7.tar.bz2) = 95f85e8bb84cc7ad05e84988f4cd93432ab2d4b300827fef34d1ada5e69196cc
-SIZE (GraphicsMagick-1.1.7.tar.bz2) = 4957394
+MD5 (GraphicsMagick-1.1.10.tar.bz2) = fb8a223ad7d7369970166b2266cb41e4
+SHA256 (GraphicsMagick-1.1.10.tar.bz2) = 7645438b6ef672c96777c39f3417f6dbbe6b1b80cce05e4b88e20b745f153c6b
+SIZE (GraphicsMagick-1.1.10.tar.bz2) = 4991117
diff --git a/graphics/GraphicsMagick/files/patch-Makefile.in b/graphics/GraphicsMagick/files/patch-Makefile.in
index 695f093c89fc..072c2e820395 100644
--- a/graphics/GraphicsMagick/files/patch-Makefile.in
+++ b/graphics/GraphicsMagick/files/patch-Makefile.in
@@ -19,22 +19,22 @@
@@ -1479,5 +1479,5 @@
install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
@$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z "$(pkg_LTLIBRARIES)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z "$(pkg_LTLIBRARIES)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
@list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
if test -f $$p; then \
@@ -1825,5 +1825,5 @@
install-pkgDATA: $(pkg_DATA)
@$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
@list='$(pkg_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
@@ -1842,5 +1842,5 @@
install-pkgdataDATA: $(pkgdata_DATA)
@$(NORMAL_INSTALL)
-- test -z "$(pkgdatadir)" || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
-+ test -z "$(pkgdatadir)" -o -z '$(pkgdata_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
+- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
++ test -z "$(pkgdatadir)" -o -z '$(pkgdata_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
@list='$(pkgdata_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
--- filters/Makefile.in Fri Mar 18 19:36:17 2005
@@ -42,15 +42,15 @@
@@ -522,5 +522,5 @@
install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
@$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_LTLIBRARIES)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_LTLIBRARIES)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
@list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
if test -f $$p; then \
@@ -592,5 +592,5 @@
install-pkgDATA: $(pkg_DATA)
@$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
@list='$(pkg_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
--- magick/Makefile.in Fri Mar 18 19:36:18 2005
@@ -65,8 +65,8 @@
@@ -930,5 +930,5 @@
install-pkgDATA: $(pkg_DATA)
@$(NORMAL_INSTALL)
-- test -z "$(pkgdir)" || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
-+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(mkdir_p) "$(DESTDIR)$(pkgdir)"
+- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
++ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
@list='$(pkg_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
--- Magick++/lib/Makefile.in Fri Mar 18 19:36:13 2005
diff --git a/graphics/GraphicsMagick/files/patch-coders-png.c b/graphics/GraphicsMagick/files/patch-coders-png.c
deleted file mode 100644
index 7a3b687f08cf..000000000000
--- a/graphics/GraphicsMagick/files/patch-coders-png.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- coders/png.c 2004/11/11 03:10:42 1.369.2.3
-+++ coders/png.c 2006/08/18 04:03:02 1.369.2.4
-@@ -1709,7 +1709,7 @@ static Image *ReadOnePNGImage(MngInfo *m
- #if defined(PNG_USE_PNGGCCRD) && defined(PNG_ASSEMBLER_CODE_SUPPORTED) \
- && (PNG_LIBPNG_VER >= 10200)
- /* Disable thread-unsafe features of pnggccrd */
-- if (png_access_version() >= 10200)
-+ if (png_access_version_number() >= 10200)
- {
- png_uint_32 mmx_disable_mask=0;
- png_uint_32 asm_flags;
-@@ -1718,8 +1718,8 @@ static Image *ReadOnePNGImage(MngInfo *m
- | PNG_ASM_FLAG_MMX_READ_FILTER_SUB \
- | PNG_ASM_FLAG_MMX_READ_FILTER_AVG \
- | PNG_ASM_FLAG_MMX_READ_FILTER_PAETH );
-- asm_flags=png_get_asm_flags(png_ptr);
-- png_set_asm_flags(png_ptr, asm_flags & ~mmx_disable_mask);
-+ asm_flags=png_get_asm_flags(ping);
-+ png_set_asm_flags(ping, asm_flags & ~mmx_disable_mask);
- }
- #endif
-
diff --git a/graphics/GraphicsMagick/files/patch-newfpx b/graphics/GraphicsMagick/files/patch-newfpx
new file mode 100644
index 000000000000..6aa24bf3dacc
--- /dev/null
+++ b/graphics/GraphicsMagick/files/patch-newfpx
@@ -0,0 +1,20 @@
+--- coders/fpx.c 2004-04-14 18:45:28.000000000 -0400
++++ coders/fpx.c 2007-11-01 23:30:18.000000000 -0500
+@@ -182,13 +182,13 @@
+ unsigned int
+ status,
+- subimage;
+-
+- unsigned long
++ subimage,
+ height,
+- memory_limit,
+ tile_width,
+ tile_height,
+ width;
+
++ size_t
++ memory_limit;
++
+ /*
+ Open image.
diff --git a/graphics/GraphicsMagick/pkg-plist b/graphics/GraphicsMagick/pkg-plist
index fb02ec662470..2a9cd0888e71 100644
--- a/graphics/GraphicsMagick/pkg-plist
+++ b/graphics/GraphicsMagick/pkg-plist
@@ -116,9 +116,7 @@ libdata/pkgconfig/GraphicsMagickWand.pc
%%PORTDOCS%%%%DOCSDIR%%/www/Copyright.html
%%PORTDOCS%%%%DOCSDIR%%/www/FAQ.html
%%PORTDOCS%%%%DOCSDIR%%/www/GraphicsMagick.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-mac.html
%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-unix.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-vms.html
%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-windows.html
%%PORTDOCS%%%%DOCSDIR%%/www/ImageMagickObject.html
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Blob.html