aboutsummaryrefslogtreecommitdiff
path: root/graphics/acidwarp-sdl
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-06-22 18:22:38 +0000
committerSteve Wills <swills@FreeBSD.org>2020-06-22 18:22:38 +0000
commit6b788b4ca2b05d6f06cd1ef7fa40a25e3bc29063 (patch)
tree1f13887463945be3d5608e3f7966262972c7588f /graphics/acidwarp-sdl
parentd18da177f7b7e4aa3281de5ca8382e13885fea53 (diff)
downloadports-6b788b4ca2b05d6f06cd1ef7fa40a25e3bc29063.tar.gz
ports-6b788b4ca2b05d6f06cd1ef7fa40a25e3bc29063.zip
graphics/acidwarp-sdl: create port
Acidwarp is an eye candy program which displays various patterns and animates them by changing the palette. WWW: https://github.com/dreamlayers/acidwarp
Notes
Notes: svn path=/head/; revision=539895
Diffstat (limited to 'graphics/acidwarp-sdl')
-rw-r--r--graphics/acidwarp-sdl/Makefile33
-rw-r--r--graphics/acidwarp-sdl/distinfo3
-rw-r--r--graphics/acidwarp-sdl/files/patch-acidwarp.desktop11
-rw-r--r--graphics/acidwarp-sdl/pkg-descr4
4 files changed, 51 insertions, 0 deletions
diff --git a/graphics/acidwarp-sdl/Makefile b/graphics/acidwarp-sdl/Makefile
new file mode 100644
index 000000000000..d2fa2936bced
--- /dev/null
+++ b/graphics/acidwarp-sdl/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= acidwarp-sdl
+PORTVERSION= g2020062101
+CATEGORIES= graphics
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Eye candy program which displays various patterns
+
+BUILD_DEPENDS= convert:graphics/ImageMagick7
+
+USES= cmake sdl
+USE_SDL= sdl2
+
+USE_GITHUB= yes
+GH_ACCOUNT= dreamlayers
+GH_PROJECT= acidwarp
+GH_TAGNAME= 698c4e1
+
+PLIST_FILES= bin/acidwarp \
+ share/applications/acidwarp.desktop \
+ share/pixmaps/acidwarp.png
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/acidwarp.desktop
+
+do-install:
+ ${STRIP_CMD} ${WRKSRC}/bin/acidwarp
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/acidwarp ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/acidwarp.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/acidwarp.png ${STAGEDIR}${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/graphics/acidwarp-sdl/distinfo b/graphics/acidwarp-sdl/distinfo
new file mode 100644
index 000000000000..4639ff12cf1b
--- /dev/null
+++ b/graphics/acidwarp-sdl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1592747088
+SHA256 (dreamlayers-acidwarp-g2020062101-698c4e1_GH0.tar.gz) = 0c8126a5a0367554e6cb2cd881a64cac886fb8fd051cbf4bf2b729a79191acf3
+SIZE (dreamlayers-acidwarp-g2020062101-698c4e1_GH0.tar.gz) = 65314
diff --git a/graphics/acidwarp-sdl/files/patch-acidwarp.desktop b/graphics/acidwarp-sdl/files/patch-acidwarp.desktop
new file mode 100644
index 000000000000..b99fb6741a82
--- /dev/null
+++ b/graphics/acidwarp-sdl/files/patch-acidwarp.desktop
@@ -0,0 +1,11 @@
+--- acidwarp.desktop.orig 2017-05-13 15:07:16 UTC
++++ acidwarp.desktop
+@@ -2,7 +2,7 @@
+ Encoding=UTF-8
+ Name=Acidwarp
+ GenericName=View color cycling patterns
+-Icon=acidwarp
++Icon=%%PREFIX%%/share/pixmaps/acidwarp.png
+ Exec=acidwarp
+ Terminal=false
+ Type=Application
diff --git a/graphics/acidwarp-sdl/pkg-descr b/graphics/acidwarp-sdl/pkg-descr
new file mode 100644
index 000000000000..5331776671d5
--- /dev/null
+++ b/graphics/acidwarp-sdl/pkg-descr
@@ -0,0 +1,4 @@
+Acidwarp is an eye candy program which displays various patterns and animates
+them by changing the palette.
+
+WWW: https://github.com/dreamlayers/acidwarp