aboutsummaryrefslogtreecommitdiff
path: root/graphics/aqsis
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-19 17:49:17 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-19 17:49:17 +0000
commit0bf61043f340c1c0ef488f0ac38e87df78d0e0d6 (patch)
treeef531e43b1fd5b3a64739d810ab2f485251c2296 /graphics/aqsis
parent813ceb98463ebf034036235326c4b23b2370cc51 (diff)
downloadports-0bf61043f340c1c0ef488f0ac38e87df78d0e0d6.tar.gz
ports-0bf61043f340c1c0ef488f0ac38e87df78d0e0d6.zip
- Unbreak build by removing patches added in the previous commit. The port
has been updated already and builds fine with boost-1.48.0 [1] - While here, add _build suffix for some Qt4 components to avoid run dependency on them. I've bumped PORTREVISION in the previous commit so no changes this time. Reported by: pav/pointyhat [1]
Notes
Notes: svn path=/head/; revision=296968
Diffstat (limited to 'graphics/aqsis')
-rw-r--r--graphics/aqsis/Makefile2
-rw-r--r--graphics/aqsis/files/patch-libs-core-api-ri.cpp44
-rw-r--r--graphics/aqsis/files/patch-libs-core-ddmanager-ddmanager.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-core-geometry-blobby.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-core-geometry-procedural.cpp20
-rw-r--r--graphics/aqsis/files/patch-libs-core-renderer.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-core-texturing_old-texturemap_old.cpp20
-rw-r--r--graphics/aqsis/files/patch-libs-shadervm-dsoshadeops.cpp18
-rw-r--r--graphics/aqsis/files/patch-libs-tex-io-exrinputfile.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-tex-io-magicnumber.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-tex-io-tiffdirhandle.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-tex-io-zinputfile.cpp11
-rw-r--r--graphics/aqsis/files/patch-libs-tex-maketexture-maketexture.cpp13
-rw-r--r--graphics/aqsis/files/patch-libs-utils_plugins.cpp11
-rw-r--r--graphics/aqsis/files/patch-tools-piqsl-displayserverimage.cpp13
-rw-r--r--graphics/aqsis/files/patch-tools-piqsl-piqslmainwindow.cpp11
16 files changed, 1 insertions, 228 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index 2a6518717827..fc13f9fb85b8 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -33,7 +33,7 @@ USE_CMAKE= yes
CMAKE_OUTSOURCE= yes
CMAKE_VERBOSE= yes
USE_QT_VER= 4
-QT_COMPONENTS= opengl qmake moc rcc uic
+QT_COMPONENTS= opengl qmake_build moc_build rcc_build uic_build
PLIST_SUB+= LIBVERS=${PORTVERSION:R}
INSTALLS_ICONS= yes
diff --git a/graphics/aqsis/files/patch-libs-core-api-ri.cpp b/graphics/aqsis/files/patch-libs-core-api-ri.cpp
deleted file mode 100644
index 7e77fcdc61a0..000000000000
--- a/graphics/aqsis/files/patch-libs-core-api-ri.cpp
+++ /dev/null
@@ -1,44 +0,0 @@
---- libs/core/api/ri.cpp.orig 2012-02-20 18:29:00.000000000 +0300
-+++ libs/core/api/ri.cpp 2012-02-20 18:29:35.000000000 +0300
-@@ -488,12 +488,12 @@
-
- // Read in the system configuration file.
- boost::filesystem::path systemRcPath = rootPath / AQSIS_XSTR(AQSIS_MAIN_CONFIG_NAME);
-- std::ifstream rcFile(systemRcPath.file_string().c_str(), std::ios::binary);
-+ std::ifstream rcFile(systemRcPath.string().c_str(), std::ios::binary);
- if(rcFile)
- {
- Aqsis::log() << info
- << "Reading system config \"" << systemRcPath << "\"\n";
-- QGetRenderContext()->parseRibStream(rcFile, systemRcPath.file_string());
-+ QGetRenderContext()->parseRibStream(rcFile, systemRcPath.string());
- rcFile.close();
- }
- else
-@@ -508,22 +508,22 @@
- boost::filesystem::path homeRcPath = homePath;
- homeRcPath /= ".aqsisrc";
-
-- std::ifstream rcFile(homeRcPath.file_string().c_str(), std::ios::binary);
-+ std::ifstream rcFile(homeRcPath.string().c_str(), std::ios::binary);
- if(rcFile)
- {
- Aqsis::log() << info << "Reading user config \"" << homeRcPath << "\"\n";
-- QGetRenderContext()->parseRibStream(rcFile, homeRcPath.file_string());
-+ QGetRenderContext()->parseRibStream(rcFile, homeRcPath.string());
- }
- else
- {
- boost::filesystem::path homeRcPath2 = homePath;
- homeRcPath2 /= "_aqsisrc";
-
-- std::ifstream rcFile(homeRcPath2.file_string().c_str(), std::ios::binary);
-+ std::ifstream rcFile(homeRcPath2.string().c_str(), std::ios::binary);
- if(rcFile)
- {
- Aqsis::log() << info << "Reading user config \"" << homeRcPath2 << "\"\n";
-- QGetRenderContext()->parseRibStream(rcFile, homeRcPath2.file_string());
-+ QGetRenderContext()->parseRibStream(rcFile, homeRcPath2.string());
- }
- else
- {
diff --git a/graphics/aqsis/files/patch-libs-core-ddmanager-ddmanager.cpp b/graphics/aqsis/files/patch-libs-core-ddmanager-ddmanager.cpp
deleted file mode 100644
index 585382b6fef5..000000000000
--- a/graphics/aqsis/files/patch-libs-core-ddmanager-ddmanager.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/core/ddmanager/ddmanager.cpp.orig 2012-02-20 18:31:11.000000000 +0300
-+++ libs/core/ddmanager/ddmanager.cpp 2012-02-20 18:31:27.000000000 +0300
-@@ -349,7 +349,7 @@
- }
-
- // Load the dynamic object and locate the relevant symbols.
-- CqString strDriverPathAndFile = displayPath.file_string();
-+ CqString strDriverPathAndFile = displayPath.string();
- m_DriverHandle = dspyPlugin.SimpleDLOpen( &strDriverPathAndFile );
- if ( m_DriverHandle != NULL )
- {
diff --git a/graphics/aqsis/files/patch-libs-core-geometry-blobby.cpp b/graphics/aqsis/files/patch-libs-core-geometry-blobby.cpp
deleted file mode 100644
index 62d44efd1342..000000000000
--- a/graphics/aqsis/files/patch-libs-core-geometry-blobby.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/core/geometry/blobby.cpp.orig 2012-02-20 18:32:53.000000000 +0300
-+++ libs/core/geometry/blobby.cpp 2012-02-20 18:33:07.000000000 +0300
-@@ -392,7 +392,7 @@
- try
- {
- CqString fullName = QGetRenderContext()->poptCurrent()
-- ->findRiFile(dboName, "procedural").file_string();
-+ ->findRiFile(dboName, "procedural").string();
- DBO_handle = DBO.SimpleDLOpen(&fullName);
- }
- catch(XqInvalidFile& /*e*/)
diff --git a/graphics/aqsis/files/patch-libs-core-geometry-procedural.cpp b/graphics/aqsis/files/patch-libs-core-geometry-procedural.cpp
deleted file mode 100644
index 5d70143a7823..000000000000
--- a/graphics/aqsis/files/patch-libs-core-geometry-procedural.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- libs/core/geometry/procedural.cpp.orig 2012-02-20 18:54:32.000000000 +0300
-+++ libs/core/geometry/procedural.cpp 2012-02-20 18:54:50.000000000 +0300
-@@ -155,7 +155,7 @@
- + CqString ("\" in current searchpath");
- return;
- }
-- CqString strRealName = dsoPath.file_string();
-+ CqString strRealName = dsoPath.string();
- void *handle = DLOpen( &strRealName );
-
- if ( ( m_ppvfcts = ( void * ( * ) ( char * ) ) DLSym(handle, &strConver) ) == NULL )
-@@ -315,7 +315,7 @@
- AQSIS_THROW_XQERROR(XqValidation, EqE_BadToken, "program name not present");
- // Attempt to find the program in the procedural path
- std::string progName = QGetRenderContext()->poptCurrent()
-- ->findRiFileNothrow(argv[0], "procedural").file_string();
-+ ->findRiFileNothrow(argv[0], "procedural").string();
- if(progName.empty())
- {
- progName = argv[0];
diff --git a/graphics/aqsis/files/patch-libs-core-renderer.cpp b/graphics/aqsis/files/patch-libs-core-renderer.cpp
deleted file mode 100644
index 0af18bd72764..000000000000
--- a/graphics/aqsis/files/patch-libs-core-renderer.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/core/renderer.cpp.orig 2012-02-20 18:46:39.000000000 +0300
-+++ libs/core/renderer.cpp 2012-02-20 18:46:49.000000000 +0300
-@@ -1195,7 +1195,7 @@
- if(shaderFile)
- {
- Aqsis::log() << info << "Loading shader \"" << strName
-- << "\" from file \"" << shaderPath.file_string()
-+ << "\" from file \"" << shaderPath.string()
- << "\"" << std::endl;
-
- std::string dsoPath;
diff --git a/graphics/aqsis/files/patch-libs-core-texturing_old-texturemap_old.cpp b/graphics/aqsis/files/patch-libs-core-texturing_old-texturemap_old.cpp
deleted file mode 100644
index f3c9748822e2..000000000000
--- a/graphics/aqsis/files/patch-libs-core-texturing_old-texturemap_old.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- libs/core/texturing_old/texturemap_old.cpp.orig 2012-02-20 18:39:35.000000000 +0300
-+++ libs/core/texturing_old/texturemap_old.cpp 2012-02-20 18:39:50.000000000 +0300
-@@ -578,7 +578,7 @@
- }
-
- // Now open it as a tiff file.
-- m_pImage = TIFFOpen( imagePath.file_string().c_str(), "r" );
-+ m_pImage = TIFFOpen( imagePath.string().c_str(), "r" );
- }
-
- if ( m_pImage )
-@@ -1090,7 +1090,7 @@
- Aqsis::log() << error << "Cannot open texture file \"" << m_strName.c_str() << "\"" << std::endl;
- return ;
- }
-- m_pImage = TIFFOpen(imagePath.file_string().c_str(), "r" );
-+ m_pImage = TIFFOpen(imagePath.string().c_str(), "r" );
-
- if ( m_pImage )
- {
diff --git a/graphics/aqsis/files/patch-libs-shadervm-dsoshadeops.cpp b/graphics/aqsis/files/patch-libs-shadervm-dsoshadeops.cpp
deleted file mode 100644
index 7f1dc8109749..000000000000
--- a/graphics/aqsis/files/patch-libs-shadervm-dsoshadeops.cpp
+++ /dev/null
@@ -1,18 +0,0 @@
---- libs/shadervm/dsoshadeops.cpp.orig 2012-02-20 18:12:04.000000000 +0300
-+++ libs/shadervm/dsoshadeops.cpp 2012-02-20 18:12:22.000000000 +0300
-@@ -101,13 +101,13 @@
- // If the path points to a directory, we add each library in the
- // named directory to the list of DSO candidates.
- std::vector<std::string> files = Glob(
-- ((*path)/"*" SHARED_LIBRARY_SUFFIX).file_string() );
-+ ((*path)/"*" SHARED_LIBRARY_SUFFIX).string() );
- m_DSOPathList.insert(m_DSOPathList.end(), files.begin(), files.end());
- }
- else
- {
- // else add the file itself.
-- m_DSOPathList.push_back(path->file_string());
-+ m_DSOPathList.push_back(path->string());
- }
- }
- catch(boost::filesystem::filesystem_error& /*e*/)
diff --git a/graphics/aqsis/files/patch-libs-tex-io-exrinputfile.cpp b/graphics/aqsis/files/patch-libs-tex-io-exrinputfile.cpp
deleted file mode 100644
index 20d50524e33a..000000000000
--- a/graphics/aqsis/files/patch-libs-tex-io-exrinputfile.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/tex/io/exrinputfile.cpp.orig 2012-02-20 18:09:25.000000000 +0300
-+++ libs/tex/io/exrinputfile.cpp 2012-02-20 18:09:41.000000000 +0300
-@@ -163,7 +163,7 @@
- {
- try
- {
-- m_exrFile.reset(new Imf::InputFile(fileName.file_string().c_str()));
-+ m_exrFile.reset(new Imf::InputFile(fileName.string().c_str()));
- }
- catch(Iex::BaseExc &e)
- {
diff --git a/graphics/aqsis/files/patch-libs-tex-io-magicnumber.cpp b/graphics/aqsis/files/patch-libs-tex-io-magicnumber.cpp
deleted file mode 100644
index 8e12c97d1fcf..000000000000
--- a/graphics/aqsis/files/patch-libs-tex-io-magicnumber.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/tex/io/magicnumber.cpp.orig 2012-02-20 18:01:58.000000000 +0300
-+++ libs/tex/io/magicnumber.cpp 2012-02-20 18:02:12.000000000 +0300
-@@ -59,7 +59,7 @@
-
- EqImageFileType guessFileType(const boostfs::path& fileName)
- {
-- std::ifstream inFile(fileName.file_string().c_str());
-+ std::ifstream inFile(fileName.string().c_str());
- if(!inFile)
- {
- AQSIS_THROW_XQERROR(XqInvalidFile, EqE_NoFile, "Cannot open file \""
diff --git a/graphics/aqsis/files/patch-libs-tex-io-tiffdirhandle.cpp b/graphics/aqsis/files/patch-libs-tex-io-tiffdirhandle.cpp
deleted file mode 100644
index 67a4e14c0f9d..000000000000
--- a/graphics/aqsis/files/patch-libs-tex-io-tiffdirhandle.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/tex/io/tiffdirhandle.cpp.orig 2012-02-20 18:04:48.000000000 +0300
-+++ libs/tex/io/tiffdirhandle.cpp 2012-02-20 18:05:02.000000000 +0300
-@@ -727,7 +727,7 @@
-
- CqTiffFileHandle::CqTiffFileHandle(const boostfs::path& fileName, const char* openMode)
- : m_fileName(fileName),
-- m_tiffPtr(TIFFOpen(fileName.file_string().c_str(), openMode), safeTiffClose),
-+ m_tiffPtr(TIFFOpen(fileName.string().c_str(), openMode), safeTiffClose),
- m_isInputFile(openMode[0] == 'r'),
- m_currDir(0)
- {
diff --git a/graphics/aqsis/files/patch-libs-tex-io-zinputfile.cpp b/graphics/aqsis/files/patch-libs-tex-io-zinputfile.cpp
deleted file mode 100644
index 3d89797ec5d2..000000000000
--- a/graphics/aqsis/files/patch-libs-tex-io-zinputfile.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/tex/io/zinputfile.cpp.orig 2012-02-20 18:08:03.000000000 +0300
-+++ libs/tex/io/zinputfile.cpp 2012-02-20 18:08:19.000000000 +0300
-@@ -41,7 +41,7 @@
- CqZInputFile::CqZInputFile(const boostfs::path& fileName)
- : m_header(),
- m_fileName(fileName),
-- m_fileStream(fileName.file_string().c_str(), std::ios::in | std::ios::binary),
-+ m_fileStream(fileName.string().c_str(), std::ios::in | std::ios::binary),
- m_dataBegin(0)
- {
- if(!m_fileStream.is_open())
diff --git a/graphics/aqsis/files/patch-libs-tex-maketexture-maketexture.cpp b/graphics/aqsis/files/patch-libs-tex-maketexture-maketexture.cpp
deleted file mode 100644
index 81450692f29d..000000000000
--- a/graphics/aqsis/files/patch-libs-tex-maketexture-maketexture.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- libs/tex/maketexture/maketexture.cpp.orig 2012-02-20 18:10:38.000000000 +0300
-+++ libs/tex/maketexture/maketexture.cpp 2012-02-20 18:10:56.000000000 +0300
-@@ -335,8 +335,8 @@
- {
- inFileRealName = inFileName.string() + ".tif";
- TqInt bakeRes = static_cast<TqInt>(paramList.find<TqFloat>("bake", 256));
-- bakeToTiff(inFileName.file_string().c_str(),
-- inFileRealName.file_string().c_str(), bakeRes);
-+ bakeToTiff(inFileName.string().c_str(),
-+ inFileRealName.string().c_str(), bakeRes);
- }
-
- // Open the input file
diff --git a/graphics/aqsis/files/patch-libs-utils_plugins.cpp b/graphics/aqsis/files/patch-libs-utils_plugins.cpp
deleted file mode 100644
index ddc9be101b45..000000000000
--- a/graphics/aqsis/files/patch-libs-utils_plugins.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/util/plugins.cpp.orig 2009-12-31 13:32:11.000000000 +0100
-+++ libs/util/plugins.cpp 2009-12-31 13:32:32.000000000 +0100
-@@ -170,7 +170,7 @@
- LocalFree( lpMsgBuf );
- #else //not defined AQSIS_SYSTEM_MACOSX
-
-- char* error = dlerror();
-+ const char* error = dlerror();
- if( error )
- errorlog = error;
- #endif
diff --git a/graphics/aqsis/files/patch-tools-piqsl-displayserverimage.cpp b/graphics/aqsis/files/patch-tools-piqsl-displayserverimage.cpp
deleted file mode 100644
index 217a3b4c6d30..000000000000
--- a/graphics/aqsis/files/patch-tools-piqsl-displayserverimage.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- tools/piqsl/displayserverimage.cpp.orig 2012-02-20 18:42:02.000000000 +0300
-+++ tools/piqsl/displayserverimage.cpp 2012-02-20 18:42:18.000000000 +0300
-@@ -98,8 +98,8 @@
- ++index;
- }
-
-- setFilename(uniquePath.file_string());
-- saveToFile(uniquePath.file_string());
-+ setFilename(uniquePath.string());
-+ saveToFile(uniquePath.string());
- }
-
-
diff --git a/graphics/aqsis/files/patch-tools-piqsl-piqslmainwindow.cpp b/graphics/aqsis/files/patch-tools-piqsl-piqslmainwindow.cpp
deleted file mode 100644
index 278e92a5aa83..000000000000
--- a/graphics/aqsis/files/patch-tools-piqsl-piqslmainwindow.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/piqsl/piqslmainwindow.cpp.orig 2012-02-20 18:43:33.000000000 +0300
-+++ tools/piqsl/piqslmainwindow.cpp 2012-02-20 18:44:04.000000000 +0300
-@@ -186,7 +186,7 @@
- char* filename = fl_file_chooser("Load Image", "All Supported Files (*.{tif,tiff,exr,env,tx,tex,shad,zfile,sm})\tTIFF Files (*.{tif,tiff})\tOpenEXR Files (*.exr)\tTeqser Files (*.{env,tx,tex})\tShadow Files (*.{shad,zfile,sm})", "");
- if(filename)
- {
-- std::string name = boost::filesystem::path(filename).leaf();
-+ std::string name = boost::filesystem::path(filename).leaf().string();
- loadImageToCurrentBook(name, filename);
- updateImageList();
- }