aboutsummaryrefslogtreecommitdiff
path: root/graphics/batik
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-02 03:11:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-02 03:11:39 +0000
commitc6b1453b2be2c41cb3785070bd42b22c5e81752f (patch)
tree7f1c605a8c974c317e5e4b696d42b75e7f998de7 /graphics/batik
parent8e70ae164427b60942874b8d2d41cf6afaba5cd6 (diff)
downloadports-c6b1453b2be2c41cb3785070bd42b22c5e81752f.tar.gz
ports-c6b1453b2be2c41cb3785070bd42b22c5e81752f.zip
add batik 1.5.1
SVG Toolkit
Notes
Notes: svn path=/head/; revision=102692
Diffstat (limited to 'graphics/batik')
-rw-r--r--graphics/batik/Makefile44
-rw-r--r--graphics/batik/distinfo2
-rw-r--r--graphics/batik/pkg-descr5
3 files changed, 51 insertions, 0 deletions
diff --git a/graphics/batik/Makefile b/graphics/batik/Makefile
new file mode 100644
index 000000000000..e855a1b30aa6
--- /dev/null
+++ b/graphics/batik/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# Ports collection makefile for: batik
+# Date created: Feb 25, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= batik
+PORTVERSION= 1.5.1
+CATEGORIES= graphics java
+MASTER_SITES= ${MASTER_SITE_APACHE_XML}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= SVG Toolkit
+
+BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
+
+USE_ZIP= yes
+USE_JAVA= 1.3+
+NEED_JAVAC= yes
+WRKSRC= ${WRKDIR}/xml-${PORTNAME}
+ANT?= /usr/local/bin/ant
+ANT_ALL_TARGET= jars
+BATIK_HOME= ${PREFIX}/batik
+
+.if !defined(NOPORTDOCS)
+ANT_ALL_TARGET+= html
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${ANT} ${ANT_ALL_TARGET}
+
+do-install:
+ @${MKDIR} ${BATIK_HOME}
+ @${CP} -R ${WRKSRC}/${PORTNAME}-${PORTVERSION} ${BATIK_HOME}
+ @${FIND} ${BATIK_HOME} -type f | \
+ ${SED} -e "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${BATIK_HOME} -type d | ${SORT} -r | \
+ ${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/graphics/batik/distinfo b/graphics/batik/distinfo
new file mode 100644
index 000000000000..eab3beffdcc7
--- /dev/null
+++ b/graphics/batik/distinfo
@@ -0,0 +1,2 @@
+MD5 (batik-src-1.5.1.zip) = 8a3ba8b76dcef9415216d6a5b9685a9c
+SIZE (batik-src-1.5.1.zip) = 11474737
diff --git a/graphics/batik/pkg-descr b/graphics/batik/pkg-descr
new file mode 100644
index 000000000000..f1506a92302b
--- /dev/null
+++ b/graphics/batik/pkg-descr
@@ -0,0 +1,5 @@
+Batik is a Java(tm) technology based toolkit for applications or applets that
+want to use images in the Scalable Vector Graphics (SVG) format for various
+purposes, such as viewing, generation or manipulation.
+
+WWW: http://xml.apache.org/batik/