aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-01-29 15:13:28 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-01-29 15:13:28 +0000
commit5db48535a5f3fc23541517e43ebc932dce7aaceb (patch)
tree7d2180072699231587ed8a6a6332749468667a14 /graphics/blender/Makefile
parent1744bfcaf03850fee748f642f911593b14f44b2f (diff)
downloadports-5db48535a5f3fc23541517e43ebc932dce7aaceb.tar.gz
ports-5db48535a5f3fc23541517e43ebc932dce7aaceb.zip
* Fix the Makefile header (blender-static -> blender)
* Add ONLY_FOR_ARCHS (i386) * Install sequence and texture plugins * Support PORTDOCS Reviewed by: will (I didn't switch to the dynamic blender version yet, because there are still some problems with Mesa library links)
Notes
Notes: svn path=/head/; revision=37751
Diffstat (limited to 'graphics/blender/Makefile')
-rw-r--r--graphics/blender/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 0cfb27fd1efc..1f107955debc 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: blender-static
+# New ports collection makefile for: blender
# Date created: 14 November 2000
# Whom: Jimmy Olgeni <olgeni@uli.it>
#
@@ -13,17 +13,28 @@ DISTNAME= blender${PORTVERSION}-freebsd-3.4-i386-static
MAINTAINER= olgeni@FreeBSD.org
-NO_CDROM= "Commercial distribution prohibited"
-
USE_X_PREFIX= YES
-
-do-build:
- @echo "This is an install only port."
+NO_CDROM= "Commercial distribution prohibited"
+NO_BUILD= YES
+ONLY_FOR_ARCHS= i386
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/blender ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/doc/blender
+ ${MKDIR} ${PREFIX}/lib/blender/plugins/texture \
+ ${PREFIX}/lib/blender/plugins/sequence
+.for SEQ in blur.so scatter.so showzbuf.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugins/sequence/${SEQ} \
+ ${PREFIX}/lib/blender/plugins/sequence
+.endfor
+.for TEXT in clouds2.so tiles.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugins/texture/${TEXT} \
+ ${PREFIX}/lib/blender/plugins/texture
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/blender
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/blender
${INSTALL_DATA} ${WRKSRC}/copyright.txt ${PREFIX}/share/doc/blender
+.endif
.include <bsd.port.mk>