aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-01-02 04:22:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-01-02 06:45:36 +0000
commit63ca7a89e7f0fc6caa9bd9e5129cf593195e1647 (patch)
treecd727be08e8db926d0987cc154bb094fb7f5abd4 /graphics/blender
parent97b56d65d31c499ee5e46280e98e016835b98c42 (diff)
downloadports-63ca7a89e7f0fc6caa9bd9e5129cf593195e1647.tar.gz
ports-63ca7a89e7f0fc6caa9bd9e5129cf593195e1647.zip
graphics/blender: convert WAYLAND deps to build-only due to dlopen(3)
PR: 268702 Approved by: Shane (maintainer)
Diffstat (limited to 'graphics/blender')
-rw-r--r--graphics/blender/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 60f671fe1d28..1c8c87ac6ebc 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -180,9 +180,10 @@ TRACE_LIB_DEPENDS= libpotrace.so:graphics/libpotrace
WAYLAND_CATEGORIES= wayland
WAYLAND_CMAKE_BOOL= WITH_GHOST_WAYLAND
WAYLAND_USES= pkgconfig
-WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.15:graphics/wayland-protocols
-WAYLAND_LIB_DEPENDS= libdecor-0.so:x11-toolkits/libdecor \
- libxkbcommon.so:x11/libxkbcommon
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.15:graphics/wayland-protocols \
+ wayland>=1.12:graphics/wayland \
+ libdecor>0:x11-toolkits/libdecor
+WAYLAND_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
WEBP_CMAKE_BOOL= WITH_IMAGE_WEBP
WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
XINPUT_CMAKE_BOOL= WITH_X11_XINPUT