aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-07-04 18:03:05 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-07-04 18:03:05 +0000
commit681a343fc244114631c8a003b786e75c8d6045c5 (patch)
tree6afaf904da5e782d446e23c8ffe0c44a552bd812 /graphics/cimg/Makefile
parent2a0b64c7341e1c013ce6958160a24e2452a4c6c9 (diff)
downloadports-681a343fc244114631c8a003b786e75c8d6045c5.tar.gz
ports-681a343fc244114631c8a003b786e75c8d6045c5.zip
Upgrade to 1.5.9.
Notes
Notes: svn path=/head/; revision=360643
Diffstat (limited to 'graphics/cimg/Makefile')
-rw-r--r--graphics/cimg/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 5657efb1e1e7..e91e75bc265e 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cimg
-PORTVERSION= 1.5.8
-PORTREVISION= 2
+PORTVERSION= 1.5.9
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -72,6 +71,10 @@ LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
USES+= fortran
. endif
+. if defined(WITH_XSHM)
+USE_XORG+= xext
+. endif
+
DOCBASE= README.txt
PROGS= CImg_demo captcha curve_editor2d dtmri_view3d \
edge_explorer2d fade_images gaussian_fit1d generate_loop_macros \
@@ -120,6 +123,11 @@ pre-configure:
-e 's|-lblas -llapack|${LAPACK_LIB}|' \
${BUILD_WRKSRC}/Makefile
. endif
+. if defined(WITH_XSHM)
+ ${REINPLACE_CMD} -e 's|CIMG_XSHM_CFLAGS = #|CIMG_XSHM_CFLAGS =|' \
+ -e 's|CIMG_XSHM_LDFLAGS = #|CIMG_XSHM_LDFLAGS =|' \
+ ${BUILD_WRKSRC}/Makefile
+. endif
${REINPLACE_CMD} -e 's|-pedantic|${CFLAGS}|' \
-e 's|-lpthread|${PTHREAD_LIBS}|' ${BUILD_WRKSRC}/Makefile