aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-05-15 20:34:14 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-05-15 20:34:14 +0000
commit91c51dc88886e360e8867a28545b4ef67a07d864 (patch)
tree16e12d0fae224230adeb42ec9d1f77f6d22133ab /graphics/cimg/Makefile
parent1db92475f59c5ef945fcf77a7a0adb80545eaab5 (diff)
downloadports-91c51dc88886e360e8867a28545b4ef67a07d864.tar.gz
ports-91c51dc88886e360e8867a28545b4ef67a07d864.zip
Previously `GraphicsMagick-config --ldflags' provided flags
-Wl,-rpath=/usr/local/lib/gcc47 -L/usr/local/lib/gcc47 but this has been removed. Force them by declaring USES=fortran.
Notes
Notes: svn path=/head/; revision=354173
Diffstat (limited to 'graphics/cimg/Makefile')
-rw-r--r--graphics/cimg/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 07c56e34c701..09ff95a8ebe4 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -63,6 +63,11 @@ RUN_DEPENDS+= medcon:${PORTSDIR}/graphics/xmedcon
LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
. endif
+. if !defined(WITHOUT_LAPACK)
+# Don't really need Fortran, but required to link with blas/lapack
+USES+= fortran
+. endif
+
DOCBASE= README.txt
PROGS= CImg_demo captcha curve_editor2d dtmri_view3d \
edge_explorer2d fade_images gaussian_fit1d generate_loop_macros \