aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 04:41:04 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:44 +0000
commit9afced56643d76c48d9fac24ede0e1e39f3478cd (patch)
tree10382b7f9da482358fa7dd9f05c456bece6abe45 /graphics/cimg/Makefile
parent6f771bd2f7b6d2bb78dc6cd35f74f5ad3b8808d1 (diff)
downloadports-9afced56643d76c48d9fac24ede0e1e39f3478cd.tar.gz
ports-9afced56643d76c48d9fac24ede0e1e39f3478cd.zip
graphics/cimg: make compatible with OpenEXR/Imath 3.0
Diffstat (limited to 'graphics/cimg/Makefile')
-rw-r--r--graphics/cimg/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 1934340d4a4e..3f084382634a 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cimg
DISTVERSIONPREFIX= v.
DISTVERSION= 2.9.7
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= graphics devel
@@ -49,9 +50,9 @@ LIB_DEPENDS+= libboard.so:graphics/libboard
LIB_DEPENDS+= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
- libHalf.so:graphics/ilmbase \
+ libImath.so:math/Imath \
libheif.so:graphics/libheif \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
libgimp-2.0.so:graphics/gimp-app \
libfftw3.so:math/fftw3 \
libopencv_core.so:graphics/opencv \
@@ -83,6 +84,7 @@ USE_XORG+= xext
. endif
DOCBASE= README.txt
+CFLAGS+= -I${LOCALBASE}/include/Imath -I${LOCALBASE}/include/OpenEXR
MAKE_ARGS+= CPPFLAGS="${CFLAGS}" FREEBSD_LDFLAGS="${LDFLAGS}"
PROGS= CImg_demo captcha curve_editor2d dtmri_view3d \
edge_explorer2d fade_images gaussian_fit1d generate_loop_macros \