aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg/files
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-04-19 12:09:16 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-04-19 12:09:16 +0000
commitcdec51299f056dc7bd5600e330c79149d95f2596 (patch)
tree187d1ded1f68e0576e2f7c82ab02530c9cbb88d6 /graphics/cimg/files
parentd74be40fae05d7954d0662e6e26e1bbb9aca82ed (diff)
downloadports-cdec51299f056dc7bd5600e330c79149d95f2596.tar.gz
ports-cdec51299f056dc7bd5600e330c79149d95f2596.zip
Upgrade to 1.2.8.
Notes
Notes: svn path=/head/; revision=211575
Diffstat (limited to 'graphics/cimg/files')
-rw-r--r--graphics/cimg/files/patch-examples::Makefile43
1 files changed, 24 insertions, 19 deletions
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 4e7cc60ace5b..9389b77108a0 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,21 +1,26 @@
---- ./examples/Makefile.orig 2008-01-04 11:24:33.000000000 +0100
-+++ ./examples/Makefile 2008-01-04 23:22:20.000000000 +0100
-@@ -42,10 +42,10 @@
+--- ./examples/Makefile.orig 2008-04-18 12:46:38.000000000 +0200
++++ ./examples/Makefile 2008-04-18 21:54:25.000000000 +0200
+@@ -73,15 +73,15 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.27
--CC = g++
+ CIMG_VERSION = 1.28
-X11PATH = /usr/X11R6
--CFLAGS = -Wall -W -ansi -pedantic -ffast-math
--LDFLAGS = -lm -lpthread
-+CC = $(CXX)
+-CC = g++
+#X11PATH = /usr/X11R6
-+#CFLAGS = -Wall -W -ansi -pedantic -ffast-math
++#CC = g++
+
+ ifeq ($(CC),icc)
+ CFLAGS = -ansi
+ LDFLAGS = -lpthread
+ else
+-CFLAGS = -Wall -W -ansi -pedantic
+-LDFLAGS = -lm -lpthread
++#CFLAGS = -Wall -W -ansi -pedantic
+#LDFLAGS = -lm -lpthread
+ endif
#--------------------------------------------------
- # Set compilation flags allowing to customize CImg
-@@ -80,7 +80,7 @@
+@@ -131,7 +131,7 @@
CIMG_FFTW3_FLAGS = -Dcimg_use_fftw3 -lfftw3
# Flags to enable the use of LAPACK routines for matrix computation
@@ -24,9 +29,9 @@
# Flags to enable the use of the Board library
CIMG_BOARD_FLAGS = -Dcimg_use_board -lboard
-@@ -88,6 +88,9 @@
- # Flags to compile on Solaris
- CIMG_SOLARIS_FLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
+@@ -142,6 +142,9 @@
+ # Flags to compile on MacOSX with Carbon-based display support
+ CIMG_CARBON_FLAGS = -Dcimg_display_type=3 -framework Carbon
+# Flags to compile on FreeBSD
+CIMG_FREEBSD_FLAGS = -ansi -ffast-math -I$(X11PATH)/include $(EXTRA_FLAGS) -lX11 -L$(X11PATH)/lib
@@ -34,18 +39,18 @@
# Set default compilation flags.
# Uncomment lines here, if you want to customize your default configuration
CIMG_DEFAULT_FLAGS = $(CIMG_X11_FLAGS) \
-@@ -144,7 +147,7 @@
+@@ -208,7 +211,7 @@
all: $(CIMG_FILES)
clean:
-- rm -f *.exe *~ jpeg_buffer greycstoration4gimp $(CIMG_FILES)
-+ rm -f *.exe *~ jpeg_buffer greycstoration4gimp $(CIMG_FILES) Makefile.orig
+- rm -rf *.app *.exe *~ jpeg_buffer greycstoration4gimp $(CIMG_FILES)
++ rm -rf *.app *.exe *~ jpeg_buffer greycstoration4gimp $(CIMG_FILES) Makefile.orig
greycstoration4gimp: greycstoration4gimp.cpp
@echo
-@@ -164,6 +167,12 @@
+@@ -228,6 +231,12 @@
Mlinux:
- make "ARCHFLAGS=-O3 $(CIMG_ALL_FLAGS)" all jpeg_buffer greycstoration4gimp
+ make "ARCHFLAGS=$(CIMG_ALL_FLAGS)" all jpeg_buffer greycstoration4gimp
+# FreeBSD targets
+dFreeBSD: