aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-03-14 21:10:22 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-03-14 21:10:22 +0000
commit16d3314c251af0668093b608538a1edc3288f6e0 (patch)
tree2eca13d9ad27b42fcd600b83d937d2460b8d3453 /graphics/cimg
parent285184c82d488255ecf6c51bc1da89ecf5357337 (diff)
downloadports-16d3314c251af0668093b608538a1edc3288f6e0.tar.gz
ports-16d3314c251af0668093b608538a1edc3288f6e0.zip
Upgrade to v.2.5.0.
Note: support of Eigen3 is not yet enabled for the examples.
Notes
Notes: svn path=/head/; revision=495737
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile2
-rw-r--r--graphics/cimg/distinfo6
-rw-r--r--graphics/cimg/files/patch-CImg.h10
-rw-r--r--graphics/cimg/files/patch-examples__Makefile14
4 files changed, 21 insertions, 11 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 85d9c102d51c..f7d8a0c9e9ed 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cimg
DISTVERSIONPREFIX= v.
-DISTVERSION= 2.4.5
+DISTVERSION= 2.5.0
PORTEPOCH= 3
CATEGORIES= graphics devel
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index dbc37bc0710a..541a01c44461 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1547381767
-SHA256 (dtschump-CImg-v.2.4.5_GH0.tar.gz) = 4c2e506fdd3ff9a1e741b3d321c68491b5f2e9282d8093cefbc4174ca8987d53
-SIZE (dtschump-CImg-v.2.4.5_GH0.tar.gz) = 11075045
+TIMESTAMP = 1552596120
+SHA256 (dtschump-CImg-v.2.5.0_GH0.tar.gz) = 4616b51d8657d66625fdc04e8bdb49e60b3c943ac6c2512abff566eae46b5cde
+SIZE (dtschump-CImg-v.2.5.0_GH0.tar.gz) = 11075897
diff --git a/graphics/cimg/files/patch-CImg.h b/graphics/cimg/files/patch-CImg.h
new file mode 100644
index 000000000000..fe37c718f861
--- /dev/null
+++ b/graphics/cimg/files/patch-CImg.h
@@ -0,0 +1,10 @@
+--- CImg.h.orig 2019-03-10 13:46:23 UTC
++++ CImg.h
+@@ -26529,7 +26529,6 @@ namespace cimg_library_suffixed {
+ cimg_forXY(vec,k,l) vec(k,l) = (T)(lapA[(N - 1 - k)*N + l]);
+ } else { val.fill(0); vec.fill(0); }
+ delete[] lapA; delete[] lapW; delete[] WORK;
+- sort_eigenvalues = false;
+ #else
+
+ val.assign(1,_width);
diff --git a/graphics/cimg/files/patch-examples__Makefile b/graphics/cimg/files/patch-examples__Makefile
index 92e8af046e0e..cff5e3f93f2a 100644
--- a/graphics/cimg/files/patch-examples__Makefile
+++ b/graphics/cimg/files/patch-examples__Makefile
@@ -1,4 +1,4 @@
---- examples/Makefile.orig 2019-01-07 12:08:23 UTC
+--- examples/Makefile.orig 2019-03-10 13:46:23 UTC
+++ examples/Makefile
@@ -89,7 +89,7 @@ VERSION2 = $(shell grep 'cimg_version\ ' ../CImg.h | t
VERSION3 = $(shell grep 'cimg_version\ ' ../CImg.h | tail -c2 | head -c1)
@@ -30,7 +30,7 @@
endif
ifdef IS_ICPC
OPT_CFLAGS = -fast
-@@ -217,7 +217,7 @@ JPEG_LIBS = -ljpeg
+@@ -222,7 +222,7 @@ JPEG_LIBS = -ljpeg
TIFF_DEFINE = -Dcimg_use_tiff
TIFF_INCDIR =
TIFF_CFLAGS = $(TIFF_DEFINE) $(TIFF_INCDIR)
@@ -39,7 +39,7 @@
# Flags to enable native support for MINC2 image files, using the MINC2 library.
# ( http://en.wikibooks.org/wiki/MINC/Reference/MINC2.0_Users_Guide )
-@@ -229,16 +229,16 @@ MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -
+@@ -234,16 +234,16 @@ MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
OPENEXR_DEFINE = -Dcimg_use_openexr
@@ -61,7 +61,7 @@
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
# ( http://www.zlib.net/ )
-@@ -274,15 +274,15 @@ endif
+@@ -279,15 +279,15 @@ endif
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -81,7 +81,7 @@
BOARD_CFLAGS = $(BOARD_DEFINE) $(BOARD_INCDIR)
BOARD_LIBS = -lboard
-@@ -361,6 +361,7 @@ $(X11_LIBS) \
+@@ -366,6 +366,7 @@ $(X11_LIBS) \
$(TIFF_LIBS) \
$(LAPACK_LIBS) \
$(XSHM_LIBS)" \
@@ -89,7 +89,7 @@
all $(EXTRA_FILES)
# Linux/BSD/Mac OSX targets, with X11 display.
-@@ -453,8 +454,11 @@ $(ZLIB_CFLAGS) \
+@@ -458,8 +459,11 @@ $(ZLIB_CFLAGS) \
$(CURL_CFLAGS) \
$(OPENCV_CFLAGS) \
$(MAGICK_CFLAGS) \
@@ -101,7 +101,7 @@
$(X11_LIBS) \
$(XSHM_LIBS) \
$(XRANDR_LIBS) \
-@@ -466,6 +470,8 @@ $(ZLIB_LIBS) \
+@@ -471,6 +475,8 @@ $(ZLIB_LIBS) \
$(CURL_LIBS) \
$(OPENCV_LIBS) \
$(MAGICK_LIBS) \