aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2013-09-04 19:24:12 +0000
committerThierry Thomas <thierry@FreeBSD.org>2013-09-04 19:24:12 +0000
commit4b842875ea2948eda84bd8103594cb2a73c6993d (patch)
tree3ff1503ce02bda2d4e98725ecf462b9caaa4b0ea /graphics/cimg
parente017935c92fe15c66a6706bb7a2be21e14c8b5f2 (diff)
downloadports-4b842875ea2948eda84bd8103594cb2a73c6993d.tar.gz
ports-4b842875ea2948eda84bd8103594cb2a73c6993d.zip
Re-add the missing CFLAGS and LDFLAGS.
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=326314
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile1
-rw-r--r--graphics/cimg/files/patch-examples::Makefile13
2 files changed, 13 insertions, 1 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 4fd570b18d7a..de5fdc757a5a 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cimg
PORTVERSION= 1.5.6
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 03306bba0904..249830213cfd 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,5 +1,5 @@
--- examples/Makefile.orig 2013-07-04 17:26:45.000000000 +0200
-+++ examples/Makefile 2013-07-04 23:45:47.000000000 +0200
++++ examples/Makefile 2013-09-04 21:02:00.000000000 +0200
@@ -84,8 +84,8 @@
# Set correct variables and paths
#---------------------------------
@@ -11,6 +11,17 @@
EXEPFX =
CCVER = $(CC)
ifeq ($(CC),g++)
+@@ -99,8 +99,8 @@
+ CFLAGS = -I..
+ LDFLAGS =
+ else
+-CFLAGS = -I.. -Wall -W
+-LDFLAGS = -lm
++CFLAGS = -I.. -Wall -W $(CPPFLAGS)
++LDFLAGS += -lm
+ endif
+
+ #--------------------------------------------------
@@ -125,7 +125,7 @@
ifeq ($(CC),icc)
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div