aboutsummaryrefslogtreecommitdiff
path: root/graphics/cimg
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-04-26 17:12:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-04-26 17:17:33 +0000
commit4c30f7f1c91fc6e500646edc84939404b0d59a20 (patch)
tree9331e3360530e64eeb17dbcc3d66ea77dc04d4ec /graphics/cimg
parent7dd73cf4355b3a17721dccc492575071ee8a2e84 (diff)
downloadports-4c30f7f1c91fc6e500646edc84939404b0d59a20.tar.gz
ports-4c30f7f1c91fc6e500646edc84939404b0d59a20.zip
graphics/cimg: upgrade to 3.1.0
Diffstat (limited to 'graphics/cimg')
-rw-r--r--graphics/cimg/Makefile3
-rw-r--r--graphics/cimg/distinfo6
-rw-r--r--graphics/cimg/files/patch-examples__Makefile25
3 files changed, 15 insertions, 19 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 83bbc9f4d06c..e9b3991df6c3 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -2,9 +2,8 @@
PORTNAME= cimg
DISTVERSIONPREFIX= v.
-DISTVERSION= 3.0.2
+DISTVERSION= 3.1.0
PORTEPOCH= 3
-PORTREVISION= 1
CATEGORIES= graphics devel
MAINTAINER= thierry@FreeBSD.org
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index f698fc3dc7b1..91885d2fb626 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642525146
-SHA256 (dtschump-CImg-v.3.0.2_GH0.tar.gz) = 0fd89c28f627192c7b67f7a6615bed278b1e0deb360f2e4598184df184fedc9f
-SIZE (dtschump-CImg-v.3.0.2_GH0.tar.gz) = 11276693
+TIMESTAMP = 1650992252
+SHA256 (dtschump-CImg-v.3.1.0_GH0.tar.gz) = 95fcba7687beed2b9cad74c01aa8f539e81775c54bab0c0ba469e2d968d25c67
+SIZE (dtschump-CImg-v.3.1.0_GH0.tar.gz) = 11951341
diff --git a/graphics/cimg/files/patch-examples__Makefile b/graphics/cimg/files/patch-examples__Makefile
index a681c8e1c8f7..6b7d18d0dfc9 100644
--- a/graphics/cimg/files/patch-examples__Makefile
+++ b/graphics/cimg/files/patch-examples__Makefile
@@ -1,4 +1,4 @@
---- examples/Makefile.orig 2021-04-02 13:11:36 UTC
+--- examples/Makefile.orig 2022-04-26 06:16:18 UTC
+++ examples/Makefile
@@ -89,7 +89,7 @@ VERSION2 = $(shell grep 'cimg_version\ ' ../CImg.h | t
VERSION3 = $(shell grep 'cimg_version\ ' ../CImg.h | tail -c2 | head -c1)
@@ -18,19 +18,16 @@
LIBS = -lm
ifdef IS_GCC
CXXVER = $(shell $(CXX) -v 2>&1 | tail -n 1)
-@@ -151,9 +151,9 @@ DEBUG_CFLAGS = -Dcimg_verbosity=3 -Dcimg_strict_warnin
+@@ -151,7 +151,7 @@ DEBUG_CFLAGS = -Dcimg_verbosity=3 -Dcimg_strict_warnin
VT100_CFLAGS = -Dcimg_use_vt100
# Flags to enable code optimization by the compiler.
-OPT_CFLAGS = -Ofast
+OPT_CFLAGS = # -Ofast - handled by the port CFLAGS
ifdef IS_GCC
--OPT_CFLAGS = -Ofast -mtune=generic
-+OPT_CFLAGS =
- endif
- ifdef IS_ICPC
- OPT_CFLAGS = -fast
-@@ -172,9 +172,9 @@ endif
+ # Add -mtune=generic for GCC if supported.
+ NO_MTUNE_GENERIC = $(shell $(CXX) -mtune=generic -E - < /dev/null > /dev/null 2>&1; echo $$?)
+@@ -176,9 +176,9 @@ endif
# Flags to enable OpenCV support.
OPENCV_DEFINE = -Dcimg_use_opencv
@@ -42,7 +39,7 @@
# Flags used to disable display capablities of CImg
NODISPLAY_CFLAGS = -Dcimg_display=0
-@@ -224,7 +224,7 @@ JPEG_LIBS = -ljpeg
+@@ -228,7 +228,7 @@ JPEG_LIBS = -ljpeg
TIFF_DEFINE = -Dcimg_use_tiff
TIFF_INCDIR =
TIFF_CFLAGS = $(TIFF_DEFINE) $(TIFF_INCDIR)
@@ -51,7 +48,7 @@
# Flags to enable native support for loading HEIF image files, using the libheif library.
# ( https://github.com/strukturag/libheif )
-@@ -243,16 +243,16 @@ MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -
+@@ -247,16 +247,16 @@ MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
OPENEXR_DEFINE = -Dcimg_use_openexr
@@ -74,7 +71,7 @@
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
# ( http://www.zlib.net/ )
-@@ -288,17 +288,17 @@ endif
+@@ -292,17 +292,17 @@ endif
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -98,7 +95,7 @@
# Flags to compile GIMP plug-ins.
ifeq ($(MSYSTEM),MINGW32)
-@@ -368,6 +368,7 @@ $(TIFF_LIBS) \
+@@ -372,6 +372,7 @@ $(TIFF_LIBS) \
$(HEIF_LIBS) \
$(LAPACK_LIBS) \
$(XSHM_LIBS)" \
@@ -106,7 +103,7 @@
all $(EXTRA_FILES)
# Linux/BSD/Mac OSX targets, with X11 display.
-@@ -461,8 +462,11 @@ $(ZLIB_CFLAGS) \
+@@ -465,8 +466,11 @@ $(ZLIB_CFLAGS) \
$(CURL_CFLAGS) \
$(OPENCV_CFLAGS) \
$(MAGICK_CFLAGS) \
@@ -118,7 +115,7 @@
$(X11_LIBS) \
$(XSHM_LIBS) \
$(XRANDR_LIBS) \
-@@ -475,6 +479,8 @@ $(ZLIB_LIBS) \
+@@ -479,6 +483,8 @@ $(ZLIB_LIBS) \
$(CURL_LIBS) \
$(OPENCV_LIBS) \
$(MAGICK_LIBS) \