aboutsummaryrefslogtreecommitdiff
path: root/graphics/clutter
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /graphics/clutter
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Notes
Notes: svn path=/head/; revision=264837
Diffstat (limited to 'graphics/clutter')
-rw-r--r--graphics/clutter/Makefile12
-rw-r--r--graphics/clutter/distinfo6
-rw-r--r--graphics/clutter/files/patch-clutter_cogl_cogl_Makefile.in10
-rw-r--r--graphics/clutter/files/patch-clutter_glx_clutter-stage-glx.c12
-rw-r--r--graphics/clutter/pkg-plist130
5 files changed, 139 insertions, 31 deletions
diff --git a/graphics/clutter/Makefile b/graphics/clutter/Makefile
index 19138147f06a..1cd758a06b73 100644
--- a/graphics/clutter/Makefile
+++ b/graphics/clutter/Makefile
@@ -3,11 +3,11 @@
# Whom: Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/clutter/Makefile,v 1.1 2010/07/15 14:48:21 kwm Exp $
+# $MCom: ports/graphics/clutter/Makefile,v 1.34 2010/09/24 16:35:42 kwm Exp $
#
PORTNAME= clutter
-PORTVERSION= 1.2.12
+PORTVERSION= 1.4.0
CATEGORIES= graphics
MASTER_SITES= GNOME \
http://www.clutter-project.org/sources/${PORTNAME}/${PORTVERSION:R}/
@@ -15,15 +15,19 @@ MASTER_SITES= GNOME \
MAINTAINER= gnome@FreeBSD.org
COMMENT= OpenGL based interactive canvas library
+LIB_DEPENDS= json-glib-1.0.0:${PORTSDIR}/devel/json-glib
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_GMAKE= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:22
-USE_GNOME= pkgconfig gtk20 gnomehack ltverhack gnomeprefix
+USE_GNOME= pkgconfig gdkpixbuf2 gnomehack ltverhack gnomeprefix atk pango
USE_GL= gl
USE_XORG= glproto x11 xfixes xdamage xcomposite xi
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-x --with-json=internal
+CONFIGURE_ARGS= --with-x --enable-conformance=no
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/graphics/clutter/distinfo b/graphics/clutter/distinfo
index 99cb48c39429..2f859197a3c4 100644
--- a/graphics/clutter/distinfo
+++ b/graphics/clutter/distinfo
@@ -1,3 +1,3 @@
-MD5 (clutter-1.2.12.tar.bz2) = 76f70e765adcf7146be1ceb50bafa14f
-SHA256 (clutter-1.2.12.tar.bz2) = 4582e6579897374d1f8ce51daa330311ebb90033fad95d5f076c1e9392b4ae68
-SIZE (clutter-1.2.12.tar.bz2) = 2396325
+MD5 (clutter-1.4.0.tar.bz2) = 329b6ac4e14b6f63b23297cfbb05af93
+SHA256 (clutter-1.4.0.tar.bz2) = bcdb2c55a083b8f18b0205e816c303605926b03e19f380294a203ae19ec02c96
+SIZE (clutter-1.4.0.tar.bz2) = 4476562
diff --git a/graphics/clutter/files/patch-clutter_cogl_cogl_Makefile.in b/graphics/clutter/files/patch-clutter_cogl_cogl_Makefile.in
new file mode 100644
index 000000000000..ec4a62547896
--- /dev/null
+++ b/graphics/clutter/files/patch-clutter_cogl_cogl_Makefile.in
@@ -0,0 +1,10 @@
+--- clutter/cogl/cogl/Makefile.in.orig 2010-11-20 14:38:12.000000000 +0100
++++ clutter/cogl/cogl/Makefile.in 2010-11-20 14:47:42.000000000 +0100
+@@ -582,6 +582,7 @@
+ -I$(srcdir)/winsys \
+ -I$(srcdir)/driver/$(COGL_DRIVER) \
+ -I$(top_builddir)/clutter/cogl \
++ `pkg-config --cflags gl` \
+ $(NULL)
+
+ AM_CPPFLAGS = \
diff --git a/graphics/clutter/files/patch-clutter_glx_clutter-stage-glx.c b/graphics/clutter/files/patch-clutter_glx_clutter-stage-glx.c
deleted file mode 100644
index fff439a43af2..000000000000
--- a/graphics/clutter/files/patch-clutter_glx_clutter-stage-glx.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- clutter/glx/clutter-stage-glx.c.orig 2010-07-15 15:58:02.000000000 +0000
-+++ clutter/glx/clutter-stage-glx.c 2010-07-15 15:58:25.000000000 +0000
-@@ -487,8 +487,8 @@
- (retraceCount + 1) % 2,
- &retraceCount);
- }
-- else
- #ifdef __linux__
-+ else
- {
- drm_wait_vblank_t blank;
-
diff --git a/graphics/clutter/pkg-plist b/graphics/clutter/pkg-plist
index 829bcbdc4edc..59a6dba2c5fc 100644
--- a/graphics/clutter/pkg-plist
+++ b/graphics/clutter/pkg-plist
@@ -1,4 +1,19 @@
+include/clutter-1.0/cally/cally-actor.h
+include/clutter-1.0/cally/cally-clone.h
+include/clutter-1.0/cally/cally-factory.h
+include/clutter-1.0/cally/cally-group.h
+include/clutter-1.0/cally/cally-main.h
+include/clutter-1.0/cally/cally-rectangle.h
+include/clutter-1.0/cally/cally-root.h
+include/clutter-1.0/cally/cally-stage.h
+include/clutter-1.0/cally/cally-text.h
+include/clutter-1.0/cally/cally-texture.h
+include/clutter-1.0/cally/cally-util.h
+include/clutter-1.0/cally/cally.h
+include/clutter-1.0/clutter/clutter-action.h
include/clutter-1.0/clutter/clutter-actor.h
+include/clutter-1.0/clutter/clutter-actor-meta.h
+include/clutter-1.0/clutter/clutter-align-constraint.h
include/clutter-1.0/clutter/clutter-alpha.h
include/clutter-1.0/clutter/clutter-animatable.h
include/clutter-1.0/clutter/clutter-animation.h
@@ -12,16 +27,25 @@ include/clutter-1.0/clutter/clutter-behaviour-rotate.h
include/clutter-1.0/clutter/clutter-behaviour-scale.h
include/clutter-1.0/clutter/clutter-behaviour.h
include/clutter-1.0/clutter/clutter-bin-layout.h
+include/clutter-1.0/clutter/clutter-bind-constraint.h
include/clutter-1.0/clutter/clutter-binding-pool.h
+include/clutter-1.0/clutter/clutter-blur-effect.h
include/clutter-1.0/clutter/clutter-box-layout.h
include/clutter-1.0/clutter/clutter-box.h
include/clutter-1.0/clutter/clutter-cairo-texture.h
include/clutter-1.0/clutter/clutter-child-meta.h
+include/clutter-1.0/clutter/clutter-click-action.h
include/clutter-1.0/clutter/clutter-clone.h
include/clutter-1.0/clutter/clutter-color.h
+include/clutter-1.0/clutter/clutter-colorize-effect.h
include/clutter-1.0/clutter/clutter-container.h
+include/clutter-1.0/clutter/clutter-constraint.h
+include/clutter-1.0/clutter/clutter-deform-effect.h
include/clutter-1.0/clutter/clutter-deprecated.h
+include/clutter-1.0/clutter/clutter-desaturate-effect.h
include/clutter-1.0/clutter/clutter-device-manager.h
+include/clutter-1.0/clutter/clutter-drag-action.h
+include/clutter-1.0/clutter/clutter-effect.h
include/clutter-1.0/clutter/clutter-enum-types.h
include/clutter-1.0/clutter/clutter-event.h
include/clutter-1.0/clutter/clutter-feature.h
@@ -33,23 +57,31 @@ include/clutter-1.0/clutter/clutter-group.h
include/clutter-1.0/clutter/clutter-input-device.h
include/clutter-1.0/clutter/clutter-interval.h
include/clutter-1.0/clutter/clutter-json.h
+include/clutter-1.0/clutter/clutter-keysyms-compat.h
include/clutter-1.0/clutter/clutter-keysyms.h
include/clutter-1.0/clutter/clutter-layout-manager.h
include/clutter-1.0/clutter/clutter-layout-meta.h
include/clutter-1.0/clutter/clutter-list-model.h
include/clutter-1.0/clutter/clutter-main.h
+include/clutter-1.0/clutter/clutter-marshal.h
include/clutter-1.0/clutter/clutter-media.h
include/clutter-1.0/clutter/clutter-model.h
+include/clutter-1.0/clutter/clutter-offscreen-effect.h
+include/clutter-1.0/clutter/clutter-page-turn-effect.h
include/clutter-1.0/clutter/clutter-path.h
include/clutter-1.0/clutter/clutter-rectangle.h
include/clutter-1.0/clutter/clutter-score.h
include/clutter-1.0/clutter/clutter-script.h
include/clutter-1.0/clutter/clutter-scriptable.h
+include/clutter-1.0/clutter/clutter-settings.h
+include/clutter-1.0/clutter/clutter-shader-effect.h
include/clutter-1.0/clutter/clutter-shader-types.h
include/clutter-1.0/clutter/clutter-shader.h
include/clutter-1.0/clutter/clutter-stage-manager.h
include/clutter-1.0/clutter/clutter-stage-window.h
include/clutter-1.0/clutter/clutter-stage.h
+include/clutter-1.0/clutter/clutter-state.h
+include/clutter-1.0/clutter/clutter-table-layout.h
include/clutter-1.0/clutter/clutter-text.h
include/clutter-1.0/clutter/clutter-texture.h
include/clutter-1.0/clutter/clutter-timeline.h
@@ -61,47 +93,80 @@ include/clutter-1.0/clutter/clutter-version.h
include/clutter-1.0/clutter/clutter.h
include/clutter-1.0/clutter/glx/clutter-glx-texture-pixmap.h
include/clutter-1.0/clutter/glx/clutter-glx.h
-include/clutter-1.0/clutter/json/json-generator.h
-include/clutter-1.0/clutter/json/json-glib.h
-include/clutter-1.0/clutter/json/json-marshal.h
-include/clutter-1.0/clutter/json/json-parser.h
-include/clutter-1.0/clutter/json/json-types.h
include/clutter-1.0/clutter/x11/clutter-x11-enum-types.h
include/clutter-1.0/clutter/x11/clutter-x11-texture-pixmap.h
include/clutter-1.0/clutter/x11/clutter-x11.h
include/clutter-1.0/cogl/cogl-bitmap.h
include/clutter-1.0/cogl/cogl-buffer.h
include/clutter-1.0/cogl/cogl-color.h
-include/clutter-1.0/cogl/cogl-debug.h
include/clutter-1.0/cogl/cogl-defines.h
include/clutter-1.0/cogl/cogl-deprecated.h
include/clutter-1.0/cogl/cogl-enum-types.h
include/clutter-1.0/cogl/cogl-fixed.h
include/clutter-1.0/cogl/cogl-material.h
include/clutter-1.0/cogl/cogl-matrix.h
+include/clutter-1.0/cogl/cogl-object.h
include/clutter-1.0/cogl/cogl-offscreen.h
include/clutter-1.0/cogl/cogl-pango.h
include/clutter-1.0/cogl/cogl-path.h
-include/clutter-1.0/cogl/cogl-pixel-buffer.h
+include/clutter-1.0/cogl/cogl-pixel-array.h
include/clutter-1.0/cogl/cogl-primitives.h
include/clutter-1.0/cogl/cogl-shader.h
+include/clutter-1.0/cogl/cogl-texture-3d.h
+include/clutter-1.0/cogl/cogl-texture-pixmap-x11.h
include/clutter-1.0/cogl/cogl-texture.h
include/clutter-1.0/cogl/cogl-types.h
+include/clutter-1.0/cogl/cogl-vector.h
include/clutter-1.0/cogl/cogl-vertex-buffer.h
include/clutter-1.0/cogl/cogl.h
+lib/girepository-1.0/Cally-1.0.typelib
lib/girepository-1.0/Clutter-1.0.typelib
+lib/girepository-1.0/ClutterX11-1.0.typelib
lib/girepository-1.0/Cogl-1.0.typelib
-lib/girepository-1.0/ClutterJson-1.0.typelib
lib/libclutter-glx-1.0.a
lib/libclutter-glx-1.0.la
lib/libclutter-glx-1.0.so
lib/libclutter-glx-1.0.so.0
+libdata/pkgconfig/cally-1.0.pc
libdata/pkgconfig/clutter-1.0.pc
libdata/pkgconfig/clutter-glx-1.0.pc
libdata/pkgconfig/clutter-x11-1.0.pc
libdata/pkgconfig/cogl-1.0.pc
libdata/pkgconfig/cogl-gl-1.0.pc
+share/doc/cally/CallyActor.html
+share/doc/cally/CallyClone.html
+share/doc/cally/CallyGroup.html
+share/doc/cally/CallyRectangle.html
+share/doc/cally/CallyRoot.html
+share/doc/cally/CallyStage.html
+share/doc/cally/CallyText.html
+share/doc/cally/CallyTexture.html
+share/doc/cally/CallyUtil.html
+share/doc/cally/cally-General-API.html
+share/doc/cally/cally.devhelp
+share/doc/cally/cally.devhelp2
+share/doc/cally/callybase.html
+share/doc/cally/callyobjecthierarchy.html
+share/doc/cally/callyobjectindex.html
+share/doc/cally/callyobjects.html
+share/doc/cally/ch01.html
+share/doc/cally/ch02.html
+share/doc/cally/clutter-overview.html
+share/doc/cally/home.png
+share/doc/cally/index.html
+share/doc/cally/index.sgml
+share/doc/cally/ix01.html
+share/doc/cally/ix02.html
+share/doc/cally/ix03.html
+share/doc/cally/left.png
+share/doc/cally/license.html
+share/doc/cally/right.png
+share/doc/cally/style.css
+share/doc/cally/up.png
+%%DOCSDIR%%/ClutterAction.html
%%DOCSDIR%%/ClutterActor.html
+%%DOCSDIR%%/ClutterActorMeta.html
+%%DOCSDIR%%/ClutterAlignConstraint.html
%%DOCSDIR%%/ClutterAlpha.html
%%DOCSDIR%%/ClutterAnimatable.html
%%DOCSDIR%%/ClutterAnimator.html
@@ -113,13 +178,22 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ClutterBehaviourRotate.html
%%DOCSDIR%%/ClutterBehaviourScale.html
%%DOCSDIR%%/ClutterBinLayout.html
+%%DOCSDIR%%/ClutterBindConstraint.html
+%%DOCSDIR%%/ClutterBlurEffect.html
%%DOCSDIR%%/ClutterBox.html
%%DOCSDIR%%/ClutterBoxLayout.html
%%DOCSDIR%%/ClutterCairoTexture.html
%%DOCSDIR%%/ClutterChildMeta.html
+%%DOCSDIR%%/ClutterClickAction.html
%%DOCSDIR%%/ClutterClone.html
+%%DOCSDIR%%/ClutterColorizeEffect.html
%%DOCSDIR%%/ClutterContainer.html
+%%DOCSDIR%%/ClutterConstraint.html
+%%DOCSDIR%%/ClutterDeformEffect.html
%%DOCSDIR%%/ClutterDeviceManager.html
+%%DOCSDIR%%/ClutterDesaturateEffect.html
+%%DOCSDIR%%/ClutterDragAction.html
+%%DOCSDIR%%/ClutterEffect.html
%%DOCSDIR%%/ClutterFixedLayout.html
%%DOCSDIR%%/ClutterFlowLayout.html
%%DOCSDIR%%/ClutterGroup.html
@@ -130,12 +204,18 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ClutterMedia.html
%%DOCSDIR%%/ClutterModel.html
%%DOCSDIR%%/ClutterModelIter.html
+%%DOCSDIR%%/ClutterOffscreenEffect.html
+%%DOCSDIR%%/ClutterPageTurnEffect.html
%%DOCSDIR%%/ClutterPath.html
%%DOCSDIR%%/ClutterRectangle.html
%%DOCSDIR%%/ClutterScore.html
%%DOCSDIR%%/ClutterScript.html
%%DOCSDIR%%/ClutterScriptable.html
+%%DOCSDIR%%/ClutterSettings.html
+%%DOCSDIR%%/ClutterShaderEffect.html
%%DOCSDIR%%/ClutterStage.html
+%%DOCSDIR%%/ClutterState.html
+%%DOCSDIR%%/ClutterTableLayout.html
%%DOCSDIR%%/ClutterText.html
%%DOCSDIR%%/ClutterTexture.html
%%DOCSDIR%%/ClutterTimeline.html
@@ -156,15 +236,17 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ch08.html
%%DOCSDIR%%/ch09.html
%%DOCSDIR%%/ch10.html
+%%DOCSDIR%%/ch11.html
%%DOCSDIR%%/clutter-ClutterBackend.html
+%%DOCSDIR%%/clutter-ClutterX11TexturePixmap.html
%%DOCSDIR%%/clutter-Colors.html
%%DOCSDIR%%/clutter-EGL-Specific-Support.html
-%%DOCSDIR%%/clutter-EGLX-Specific-Support.html
%%DOCSDIR%%/clutter-Events.html
%%DOCSDIR%%/clutter-Features.html
%%DOCSDIR%%/clutter-GLX-Specific-Support.html
%%DOCSDIR%%/clutter-General.html
%%DOCSDIR%%/clutter-Implicit-Animations.html
+%%DOCSDIR%%/clutter-Intel-CE3100-CE4100-Specific-Support.html
%%DOCSDIR%%/clutter-Key-Bindings.html
%%DOCSDIR%%/clutter-Shaders.html
%%DOCSDIR%%/clutter-Stage-Manager.html
@@ -209,6 +291,7 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/ix06.html
%%DOCSDIR%%/ix07.html
%%DOCSDIR%%/ix08.html
+%%DOCSDIR%%/ix09.html
%%DOCSDIR%%/left.png
%%DOCSDIR%%/license.html
%%DOCSDIR%%/migrating-ClutterEffect.html
@@ -223,22 +306,36 @@ libdata/pkgconfig/cogl-gl-1.0.pc
%%DOCSDIR%%/using-cairo.html
share/doc/cogl/ch01.html
share/doc/cogl/ch02.html
+share/doc/cogl/ch03.html
+share/doc/cogl/cogl-3D-textures.html
share/doc/cogl/cogl-Blend-Strings.html
share/doc/cogl/cogl-Buffers.html
+share/doc/cogl/cogl-Clipping-(Deprecated).html
share/doc/cogl/cogl-Clipping.html
share/doc/cogl/cogl-Color-Type.html
share/doc/cogl/cogl-Fixed-Point-API.html
+share/doc/cogl/cogl-General-API-(Deprecated).html
share/doc/cogl/cogl-General-API.html
+share/doc/cogl/cogl-Materials-(Deprecated).html
share/doc/cogl/cogl-Materials.html
share/doc/cogl/cogl-Matrices.html
+share/doc/cogl/cogl-Offscreen-Buffers-(Deprecated).html
share/doc/cogl/cogl-Offscreen-Buffers.html
+share/doc/cogl/cogl-Path-Primitives.html
share/doc/cogl/cogl-Primitives.html
+share/doc/cogl/cogl-Shaders-and-Programmable-Pipeline-(Deprecated).html
share/doc/cogl/cogl-Shaders-and-Programmable-Pipeline.html
+share/doc/cogl/cogl-Textures-(Deprecated).html
share/doc/cogl/cogl-Textures.html
+share/doc/cogl/cogl-Vectors.html
+share/doc/cogl/cogl-Vertex-Buffers-(Deprecated).html
share/doc/cogl/cogl-Vertex-Buffers.html
share/doc/cogl/cogl.devhelp
share/doc/cogl/cogl.devhelp2
-share/doc/cogl/fill-rule.png
+share/doc/cogl/cogl_ortho.png
+share/doc/cogl/coglglossary.html
+share/doc/cogl/fill-rule-even-odd.png
+share/doc/cogl/fill-rule-non-zero.png
share/doc/cogl/home.png
share/doc/cogl/index.html
share/doc/cogl/index.sgml
@@ -247,19 +344,28 @@ share/doc/cogl/ix02.html
share/doc/cogl/ix03.html
share/doc/cogl/ix04.html
share/doc/cogl/ix05.html
+share/doc/cogl/ix06.html
share/doc/cogl/left.png
share/doc/cogl/license.html
+share/doc/cogl/quad-indices-order.png
+share/doc/cogl/quad-indices-triangles.png
share/doc/cogl/right.png
share/doc/cogl/style.css
share/doc/cogl/up.png
+share/gir-1.0/Cally-1.0.gir
share/gir-1.0/Clutter-1.0.gir
-share/gir-1.0/ClutterJson-1.0.gir
+share/gir-1.0/ClutterX11-1.0.gir
share/gir-1.0/Cogl-1.0.gir
+share/locale/de/LC_MESSAGES/clutter-1.0.mo
+share/locale/it/LC_MESSAGES/clutter-1.0.mo
+share/locale/pl/LC_MESSAGES/clutter-1.0.mo
+share/locale/zh_CN/LC_MESSAGES/clutter-1.0.mo
@dirrm share/doc/cogl
+@dirrm share/doc/cally
@dirrm %%DOCSDIR%%
@dirrm include/clutter-1.0/clutter/x11
-@dirrm include/clutter-1.0/clutter/json
@dirrm include/clutter-1.0/clutter/glx
@dirrm include/clutter-1.0/clutter
@dirrm include/clutter-1.0/cogl
+@dirrm include/clutter-1.0/cally
@dirrm include/clutter-1.0