aboutsummaryrefslogtreecommitdiff
path: root/graphics/cuttlefish
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-02 00:26:00 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-02 00:26:00 +0000
commit403a9a2562bede9b9a03ee2eb5be58f2ef4cf787 (patch)
tree95fc93c6bef140edd98dd3ebc8eea7e493c4c0e9 /graphics/cuttlefish
parentb37bc068ed3f84fcd0a4523f6b8522f92e82cc02 (diff)
downloadports-403a9a2562bede9b9a03ee2eb5be58f2ef4cf787.tar.gz
ports-403a9a2562bede9b9a03ee2eb5be58f2ef4cf787.zip
Cuttlefish produces animated GIFs that reveal the interplay
between the diurnal and geographical patterns of displayed data. By showing how the Sun's shadow covers the world map, cuttlefish yields a direct feeling for the time of day at a given geographic region, while moving graphs illustrate the relationship between local time and the visualized events. WWW: http://www.caida.org/tools/visualization/cuttlefish/ PR: ports/94887 Submitted by: Matthew Luckie <mjl@luckie.org.nz>
Notes
Notes: svn path=/head/; revision=158611
Diffstat (limited to 'graphics/cuttlefish')
-rw-r--r--graphics/cuttlefish/Makefile54
-rw-r--r--graphics/cuttlefish/distinfo3
-rw-r--r--graphics/cuttlefish/pkg-descr9
-rw-r--r--graphics/cuttlefish/pkg-plist22
4 files changed, 88 insertions, 0 deletions
diff --git a/graphics/cuttlefish/Makefile b/graphics/cuttlefish/Makefile
new file mode 100644
index 000000000000..d41cc58e85aa
--- /dev/null
+++ b/graphics/cuttlefish/Makefile
@@ -0,0 +1,54 @@
+# Ports collection Makefile for: cuttlefish
+# Date created: 20 March 2006
+# Whom: Matthew Luckie <mjl@luckie.org.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cuttlefish
+PORTVERSION= 1.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.caida.org/tools/visualization/cuttlefish/code/
+
+MAINTAINER= mjl@luckie.org.nz
+COMMENT= Plots diurnal and geographical patterns of supplied data
+
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ gifsicle:${PORTSDIR}/graphics/gifsicle
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+IMAGES= caida_logo.gif caida_logo_gray.gif \
+ japan-water-okinawa.jpg japan-water.jpg \
+ world-day.jpg world-water.jpg
+
+EXAMPLES= japan-traces-small.config japan-traces.config \
+ nyxem-hosts-both.config \
+ witty-combined-small.config witty-combined.config
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|../lib|../lib/cuttlefish|" \
+ ${WRKSRC}/bin/cuttlefish.pl
+.for f in ${EXAMPLES}
+ @${REINPLACE_CMD} -e "s|images|${PREFIX}/share/cuttlefish|" \
+ ${WRKSRC}/configs/${f}
+.endfor
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/cuttlefish.pl ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib/cuttlefish
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in Canvas.pm Control.pm Histogram.pm Image.pm Legend.pm Map.pm Util.pm
+ @${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/cuttlefish/${f}
+.endfor
+.for f in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/configs/${f} ${EXAMPLESDIR}/${f}
+.endfor
+.for f in ${IMAGES}
+ @${INSTALL_DATA} ${WRKSRC}/images/${f} ${DATADIR}/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/cuttlefish/distinfo b/graphics/cuttlefish/distinfo
new file mode 100644
index 000000000000..85b10a0b2d67
--- /dev/null
+++ b/graphics/cuttlefish/distinfo
@@ -0,0 +1,3 @@
+MD5 (cuttlefish-1.2.tar.gz) = aaeb3d75cf85b16e572f6e7b228856aa
+SHA256 (cuttlefish-1.2.tar.gz) = e8596a7a460aec4afcda12a07a0e78720fe13b08924946df67a2232ba6f00da8
+SIZE (cuttlefish-1.2.tar.gz) = 1093455
diff --git a/graphics/cuttlefish/pkg-descr b/graphics/cuttlefish/pkg-descr
new file mode 100644
index 000000000000..163687b8fd70
--- /dev/null
+++ b/graphics/cuttlefish/pkg-descr
@@ -0,0 +1,9 @@
+Cuttlefish produces animated GIFs that reveal the interplay
+between the diurnal and geographical patterns of displayed
+data. By showing how the Sun's shadow covers the world map,
+cuttlefish yields a direct feeling for the time of day at
+a given geographic region, while moving graphs illustrate
+the relationship between local time and the visualized
+events.
+
+WWW: http://www.caida.org/tools/visualization/cuttlefish/
diff --git a/graphics/cuttlefish/pkg-plist b/graphics/cuttlefish/pkg-plist
new file mode 100644
index 000000000000..3718ddc28933
--- /dev/null
+++ b/graphics/cuttlefish/pkg-plist
@@ -0,0 +1,22 @@
+bin/cuttlefish.pl
+lib/cuttlefish/Canvas.pm
+lib/cuttlefish/Control.pm
+lib/cuttlefish/Histogram.pm
+lib/cuttlefish/Image.pm
+lib/cuttlefish/Legend.pm
+lib/cuttlefish/Map.pm
+lib/cuttlefish/Util.pm
+%%DATADIR%%/caida_logo.gif
+%%DATADIR%%/caida_logo_gray.gif
+%%DATADIR%%/japan-water-okinawa.jpg
+%%DATADIR%%/japan-water.jpg
+%%DATADIR%%/world-day.jpg
+%%DATADIR%%/world-water.jpg
+%%EXAMPLESDIR%%/japan-traces-small.config
+%%EXAMPLESDIR%%/japan-traces.config
+%%EXAMPLESDIR%%/nyxem-hosts-both.config
+%%EXAMPLESDIR%%/witty-combined-small.config
+%%EXAMPLESDIR%%/witty-combined.config
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%
+@dirrm lib/cuttlefish