aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable/files
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-11-11 13:16:02 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-11-11 13:16:02 +0000
commit5863b442491a086cb701cfc5c7e8e8bdeab3fc47 (patch)
treedd125442fd8bbdd0346868fa198f5fd56106b06b /graphics/darktable/files
parent48a607f2b5bdbeed4720dff6492cf743b9942426 (diff)
downloadports-5863b442491a086cb701cfc5c7e8e8bdeab3fc47.tar.gz
ports-5863b442491a086cb701cfc5c7e8e8bdeab3fc47.zip
graphics/darktable: Update to 1.6.9
Use Clang 3.7 from Ports to enable OpenMP. This brings a major performance boost for people using FreeBSD 10.x and -CURRENT. `patch-src_CMakeLists.txt` is a new patch to disable `-ffast-math` when Clang is used. Without this, isnan() always returns false, even if `-fno-finite-math-only` is set. According to `clang --help`, this flag provides no optimization anyway so we don't loose anything. darktable 2.0, which is almost ready, needs this patch too otherwise it crashes during startup because of the isnan() misbehavior. The patch is not committed upstream yet because I would prefer to understand what's wrong. Reviewed by: kwm Approved by: kwm Differential Revision: https://reviews.freebsd.org/D3922
Notes
Notes: svn path=/head/; revision=401243
Diffstat (limited to 'graphics/darktable/files')
-rw-r--r--graphics/darktable/files/patch-src_CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/graphics/darktable/files/patch-src_CMakeLists.txt b/graphics/darktable/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..7527e329d814
--- /dev/null
+++ b/graphics/darktable/files/patch-src_CMakeLists.txt
@@ -0,0 +1,24 @@
+--- src/CMakeLists.txt.orig 2015-10-15 12:59:51 UTC
++++ src/CMakeLists.txt
+@@ -419,8 +419,9 @@ if(NOT CUSTOM_CFLAGS)
+ #-g MUST be set for ALL builds, or there will be no support for them when bugs happen
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${MARCH} ${DT_REQ_INSTRUCTIONS} -g")
+ set(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_RELWITHDEBINFO} -O2")
+- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -ffast-math -fno-finite-math-only")
++ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3")
+ if(CMAKE_COMPILER_IS_GNUCC)
++ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -ffast-math -fno-finite-math-only")
+ execute_process(COMMAND ${CMAKE_C_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpmath=sse")
+@@ -436,8 +437,9 @@ if(NOT CUSTOM_CFLAGS)
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${MARCH} ${DT_REQ_INSTRUCTIONS} -g")
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -O2")
+- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3 -ffast-math -fno-finite-math-only")
++ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3")
+ if(CMAKE_COMPILER_IS_GNUCXX)
++ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -ffast-math -fno-finite-math-only")
+ execute_process(COMMAND ${CMAKE_CXX_COMPILER} -dumpversion OUTPUT_VARIABLE GCC_VERSION)
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpmath=sse")