aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-igeoportal/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:18:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:18:57 +0000
commit48777d6973790ebe72953c3031e247dfd2fb45c4 (patch)
treee90eca5d845a8b6e747df383c5f477a2e427c489 /graphics/deegree-igeoportal/Makefile
parentb4b07a8bb2c91f8aea228c646e1d69037f91acc0 (diff)
downloadports-48777d6973790ebe72953c3031e247dfd2fb45c4.tar.gz
ports-48777d6973790ebe72953c3031e247dfd2fb45c4.zip
Deegree iGeoPortal is the web-based portal framework of deegree. It
offers visualization of geodata through a standard web browser like Mozilla, Firefox or MSIE. WWW: http://www.deegree.org/ PR: ports/133804 Submitted by: wenheping at gmail.com
Notes
Notes: svn path=/head/; revision=232564
Diffstat (limited to 'graphics/deegree-igeoportal/Makefile')
-rw-r--r--graphics/deegree-igeoportal/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
new file mode 100644
index 000000000000..9be45d8783cd
--- /dev/null
+++ b/graphics/deegree-igeoportal/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: deegree-igeoportal
+# Date created: 17 April, 2009
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= igeoportal
+PORTVERSION= 2.2
+CATEGORIES= graphics java
+MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
+PKGNAMEPREFIX= deegree-
+DISTNAME= ${PORTNAME}-std_v${PORTVERSION:S/./_/}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Browserbased Client Handling WMS, WFS and Proxy Service
+
+RUN_DEPENDS= ${TOMCATDIR}:${PORTSDIR}/www/tomcat55
+
+USE_ZIP= yes
+USE_JAVA= 1.5+
+
+NO_BUILD= yes
+TOMCATVER= tomcat5.5
+TOMCATDIR= ${PREFIX}/${TOMCATVER}
+TOMCATOWN= www
+TOMCATGRP= www
+WEBAPPDIR= ${TOMCATDIR}/webapps
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/deegree-igeoportal
+PLIST_FILES= ${TOMCATVER}/webapps/igeoportal-std.war
+
+do-install:
+ cd ${WRKDIR} && \
+ ${INSTALL} -g ${TOMCATGRP} -o ${TOMCATOWN} -m 444 igeoportal-std.war ${WEBAPPDIR};
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README_igeoportal.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/deegree_igeoportal_documentation_en.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>