aboutsummaryrefslogtreecommitdiff
path: root/graphics/devil/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-28 17:50:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-28 17:50:54 +0000
commit94347041e395524ef5ef477f626444932a1dc472 (patch)
treed8166fa52c7207479f4d702f8c5fa1c31d56904d /graphics/devil/Makefile
parent6a20da26fe5be5726310656f93b911da5f3776a4 (diff)
downloadports-94347041e395524ef5ef477f626444932a1dc472.tar.gz
ports-94347041e395524ef5ef477f626444932a1dc472.zip
- Add DevIL Imaging Library.
PR: ports/70176 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Notes
Notes: svn path=/head/; revision=120412
Diffstat (limited to 'graphics/devil/Makefile')
-rw-r--r--graphics/devil/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
new file mode 100644
index 000000000000..e7d2f1d3c097
--- /dev/null
+++ b/graphics/devil/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devil
+# Date created: 8 August 2004
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= devil
+PORTVERSION= 1.6.7
+CATEGORIES= devel graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openil
+DISTNAME= DevIL-${PORTVERSION}
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= A full featured cross-platform image library
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ mng.1:${PORTSDIR}/graphics/libmng \
+ lcms.1:${PORTSDIR}/graphics/lcms
+
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+
+.include <bsd.port.mk>