aboutsummaryrefslogtreecommitdiff
path: root/graphics/dia
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-08-28 12:04:42 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-08-28 12:04:42 +0000
commitbf8c25233c270311ba422f93df9bd74aa4ee61bb (patch)
tree2a731b3867db5ad75df83e4faaec29fa04b83df1 /graphics/dia
parent4844a5b160e5a65a7663350b273bf598ef4ff582 (diff)
downloadports-bf8c25233c270311ba422f93df9bd74aa4ee61bb.tar.gz
ports-bf8c25233c270311ba422f93df9bd74aa4ee61bb.zip
- Rework optional GNOME dependency, so it would not confuse bento;
- enable gnomeprint support in Gnome case; - use "@*" to pass arguments from the helper script to the binary instead of $*. Submitted by: bento
Notes
Notes: svn path=/head/; revision=47018
Diffstat (limited to 'graphics/dia')
-rw-r--r--graphics/dia/Makefile18
-rw-r--r--graphics/dia/files/dia.sh2
2 files changed, 13 insertions, 7 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index 940792b2a83e..a83294e92590 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -7,18 +7,19 @@
PORTNAME= dia
PORTVERSION= 0.88.1
+PORTREVISION= 1
CATEGORIES+= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/dia
MAINTAINER?= gnome@FreeBSD.org
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMELIBS= yes
-WANT_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
@@ -27,13 +28,18 @@ MAN1= dia.1
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
+.if exists(${X11BASE}/bin/panel) || defined(WITH_GNOME)
USE_GNOME= yes
-CONFIGURE_ARGS= --enable-gnome
-PLIST_SUB+= DIAHELP="help/dia"
+PKGNAMESUFFIX= -gnome
+CONFIGURE_ARGS= --enable-gnome \
+ --enable-gnome-print
+PLIST_SUB+= DIAHELP="help/dia" \
+ GNOME:=""
+MAKE_ENV= HAVE_GNOME="yes"
.else
CONFIGURE_ARGS= --disable-gnome
-PLIST_SUB+= DIAHELP="dia/help"
+PLIST_SUB+= DIAHELP="dia/help" \
+ GNOME:="@comment "
.endif
pre-patch:
diff --git a/graphics/dia/files/dia.sh b/graphics/dia/files/dia.sh
index 5d9473f4e89c..a41d856d67b4 100644
--- a/graphics/dia/files/dia.sh
+++ b/graphics/dia/files/dia.sh
@@ -4,4 +4,4 @@ DIA_SHAPE_PATH=%%PREFIX%%/share/gnome/dia/shapes
DIA_SHEET_PATH=%%PREFIX%%/share/gnome/dia/sheets
export DIA_LIB_PATH DIA_SHAPE_PATH DIA_INT_SHAPE_PATH DIA_SHEET_PATH
-exec %%PREFIX%%/bin/dia-bin $*
+exec %%PREFIX%%/bin/dia-bin "$@"