aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam-kde4/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 11:14:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-12 11:14:49 +0000
commitc706f7f3440734871fa53b3918c1e99eb287898c (patch)
tree0460d125ade9bf9b94b7daecf24b65257facfc3b /graphics/digikam-kde4/Makefile
parent96ec3df0612618019b94f6fd1c41e003d61ffabd (diff)
downloadports-c706f7f3440734871fa53b3918c1e99eb287898c.tar.gz
ports-c706f7f3440734871fa53b3918c1e99eb287898c.zip
Convert LIB_DEPENDS for ports depending on boost
Notes
Notes: svn path=/head/; revision=336255
Diffstat (limited to 'graphics/digikam-kde4/Makefile')
-rw-r--r--graphics/digikam-kde4/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 236ed635fee5..2997fa4a8229 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -14,16 +14,16 @@ NO_STAGE= yes
.include "${.CURDIR}/Makefile.common"
BUILD_DEPENDS= ${LOCALBASE}/include/eigen3/Eigen/Eigen:${PORTSDIR}/math/eigen3
-LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
- lcms:${PORTSDIR}/graphics/lcms \
- png15:${PORTSDIR}/graphics/png \
- jasper:${PORTSDIR}/graphics/jasper \
- lensfun:${PORTSDIR}/graphics/lensfun \
- lqr-1:${PORTSDIR}/graphics/liblqr-1 \
- kface:${PORTSDIR}/graphics/libkface \
- pgf:${PORTSDIR}/graphics/libpgf \
- kgeomap:${PORTSDIR}/astro/libkgeomap \
- boost_graph:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjasper.so:${PORTSDIR}/graphics/jasper \
+ liblensfun.so:${PORTSDIR}/graphics/lensfun \
+ liblqr-1.so:${PORTSDIR}/graphics/liblqr-1 \
+ libkface.so:${PORTSDIR}/graphics/libkface \
+ libpgf.so:${PORTSDIR}/graphics/libpgf \
+ libkgeomap.so:${PORTSDIR}/astro/libkgeomap \
+ libboost_graph.so:${PORTSDIR}/devel/boost-libs
LATEST_LINK= ${PORTNAME}-kde4
@@ -56,7 +56,7 @@ RUN_DEPENDS+= digikam-doc>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-doc
.endif
.if ${PORT_OPTIONS:MGPHOTO2}
-LIB_DEPENDS+= gphoto2:${PORTSDIR}/graphics/libgphoto2
+LIB_DEPENDS+= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
.else
CMAKE_ARGS+= -DWITH_Gphoto2:BOOL=OFF
.endif