aboutsummaryrefslogtreecommitdiff
path: root/graphics/digikam-kde4
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:05:39 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:05:39 +0000
commit069eb5d63d5e4b6bf5f627b99250eefcee25b759 (patch)
treef856b089e9a3ec600c7c2951efca3b6237d9f466 /graphics/digikam-kde4
parentb3a7fcbada27616a9478958476078073a9e20e71 (diff)
downloadports-069eb5d63d5e4b6bf5f627b99250eefcee25b759.tar.gz
ports-069eb5d63d5e4b6bf5f627b99250eefcee25b759.zip
Unbreak kipi-plugin-* after r436971.
The kipi-plugin-* ports are all built from the same tarball, which is also used to build kipi-plugins-kde4 as well. Upstream does not expect this to happen, and refers to libkipiplugins.so as the "kipiplugins" target in CMake. Since we build everything separately, each plugin's build system code does not know this target, which results in -lkipiplugins (without -L/path/to) being passed to the linker instead of /path/to/libkipiplugins.so. Fix it by looking for libkipiplugins.so via CMake and using that result in each port. kipi-plugin-ipodexport needs an additional but similar fix, in that it should look for libgpod using CMake instead of using pkg-config's results directly, as the latter do not contain full paths. Reviewed by: tcberner
Notes
Notes: svn path=/head/; revision=437106
Diffstat (limited to 'graphics/digikam-kde4')
-rw-r--r--graphics/digikam-kde4/Makefile.common15
1 files changed, 15 insertions, 0 deletions
diff --git a/graphics/digikam-kde4/Makefile.common b/graphics/digikam-kde4/Makefile.common
index 5f3d00ff5c04..a2b2d0d40136 100644
--- a/graphics/digikam-kde4/Makefile.common
+++ b/graphics/digikam-kde4/Makefile.common
@@ -144,5 +144,20 @@ BUILD_WRKSRC= ${WRKSRC}/${${KIPI_PLUGIN}_DIR}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
${KIPI_PLUGIN}_DIR?= ${KIPI_PLUGIN}
+
+.if ${KIPI_PLUGIN} != "libkipiplugins"
+# Each plugin is built separately from the same tarball. The upstream build
+# process expects a single build for all plugins, which includes building
+# libkipiplugins itself.
+# Adjust it (together with extrapatch-CMakeLists.txt in
+# graphics/kipi-plugins-kde4) by actually looking for libkipiplugins with
+# find_library() and linking against it instead of ending up just passing
+# "-lkipiplugins" to the linker because of the way we build these ports.
+post-patch: kipi-plugin-post-patch
+kipi-plugin-post-patch:
+ ${FIND} ${BUILD_WRKSRC} -name CMakeLists.txt | ${XARGS} ${REINPLACE_CMD} -e \
+ 's, kipiplugins, $${LIBKIPIPLUGINS_LIBRARIES},' \
+ ${BUILD_WRKSRC}/CMakeLists.txt
+.endif
. endif # defined(KIPI_PLUGIN)
.endif # !defined(NO_BUILD)