aboutsummaryrefslogtreecommitdiff
path: root/graphics/drm-devel-kmod/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-07-14 08:16:55 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-07-14 08:16:55 +0000
commitd4a4adf9c7ab91f7137fd3e918e439106b5f5cda (patch)
tree8c56ebf12924a9b4ba8c2ff760081e6a5399be03 /graphics/drm-devel-kmod/Makefile
parentb653669e14092f55402ef0f33a5b4ca7e0448ae4 (diff)
downloadports-d4a4adf9c7ab91f7137fd3e918e439106b5f5cda.tar.gz
ports-d4a4adf9c7ab91f7137fd3e918e439106b5f5cda.zip
Add new port: graphics/drm-devel-kmod.
Add new port: graphics/drm-devel-kmod. This is a development version of the drm kmod ports. It is currently on par with Linux version 4.15, which includes amongs others support for AMD Vega. This version is currently only supported on recent versions of FreeBSD CURRENT. Be aware that since this is a development version, there might be bugs and regressions. If you find any issues, please report them to us. Approved by: jmd (maintainer) Obtained from: https://github.com/FreeBSDDesktop/freebsd-ports/tree/feature/drm-kmod
Notes
Notes: svn path=/head/; revision=474624
Diffstat (limited to 'graphics/drm-devel-kmod/Makefile')
-rw-r--r--graphics/drm-devel-kmod/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/drm-devel-kmod/Makefile b/graphics/drm-devel-kmod/Makefile
new file mode 100644
index 000000000000..cc3adb0b9522
--- /dev/null
+++ b/graphics/drm-devel-kmod/Makefile
@@ -0,0 +1,39 @@
+# Created by: Johannes Dieterich <jmd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= drm-devel-kmod
+PORTVERSION= 4.15.g20180713
+CATEGORIES= graphics kld
+
+MAINTAINER= jmd@FreeBSD.org
+COMMENT= DRM modules for the linuxkpi-based KMS components (development version)
+
+LICENSE= BSD2CLAUSE MIT GPLv2
+LICENSE_COMB= multi
+
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= the new KMS components are only supported on amd64
+
+RUN_DEPENDS= gpu-firmware-kmod>=g20180319:graphics/gpu-firmware-kmod
+
+CONFLICTS_INSTALL= drm-next-kmod drm-stable-kmod
+
+OPTIONS_DEFINE= DEBUG
+
+USES= kmod uidfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= FreeBSDDesktop
+GH_PROJECT= kms-drm
+GH_TAGNAME= 224e101
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200067
+IGNORE= not supported on older CURRENT, no kernel support
+.endif
+.if ${OPSYS} != FreeBSD
+IGNORE= not supported on anything but FreeBSD (missing linuxkpi functionality)
+.endif
+
+.include <bsd.port.mk>