aboutsummaryrefslogtreecommitdiff
path: root/graphics/engauge-digitizer/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-20 05:26:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-20 05:26:56 +0000
commitd0faab8f357ccd41e38d18f8e60ed7ed2070a115 (patch)
tree1c3e01f3e67149ff41264af8a665d1395952d195 /graphics/engauge-digitizer/Makefile
parent338fc6d6cca7bf17c48671c9640827f41cc9f00c (diff)
downloadports-d0faab8f357ccd41e38d18f8e60ed7ed2070a115.tar.gz
ports-d0faab8f357ccd41e38d18f8e60ed7ed2070a115.zip
New port: graphics/engauge-digitizer: Extract data points from images of graphs
Notes
Notes: svn path=/head/; revision=472845
Diffstat (limited to 'graphics/engauge-digitizer/Makefile')
-rw-r--r--graphics/engauge-digitizer/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/graphics/engauge-digitizer/Makefile b/graphics/engauge-digitizer/Makefile
new file mode 100644
index 000000000000..f5f5f136c3d9
--- /dev/null
+++ b/graphics/engauge-digitizer/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+PORTNAME= engauge-digitizer
+DISTVERSIONPREFIX= v
+DISTVERSION= 10.7.6-2
+DISTVERSIONSUFFIX= -g7ce911c2
+CATEGORIES= graphics math science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Extract data points from images of graphs
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfftw3.so:math/fftw3 \
+ liblog4cpp.so:devel/log4cpp \
+ libopenjp2.so:graphics/openjpeg \
+ libpoppler-qt5.so:graphics/poppler-qt5
+
+USES= desktop-file-utils qmake
+USE_GITHUB= yes
+GH_ACCOUNT= markummitchell
+USE_QT5= core gui help printsupport sql xml widgets buildtools_build linguist_build
+USE_GL= gl
+CONFIGURE_ENV= OPENJPEG_INCLUDE=${PREFIX}/include/openjpeg-2.3 OPENJPEG_LIB=${PREFIX}/lib \
+ POPPLER_INCLUDE=${PREFIX}/include/poppler/qt5 POPPLER_LIB=${PREFIX}/lib
+QMAKE_ARGS= "CONFIG+=jpeg2000 pdf"
+
+OPTIONS_DEFINE= DOCS
+
+post-build:
+ @cd ${WRKSRC}/help && ./build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/engauge ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${GZIP_CMD} < ${WRKSRC}/src/img/${PORTNAME}.svg > ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svgz
+ ${INSTALL_DATA} ${WRKSRC}/dev/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/${PORTNAME}.desktop
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/documentation/engauge.qch ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/documentation/engauge.qhc ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>