aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-pmaps
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /graphics/evas-loader-pmaps
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
- Update e17 applications suite to the recent snapshot.
Thanks to Grzegorz Blach <magik@roorback.net> for doing the hard work preparing the initial version of the update! PR: ports/148038 Submitted by: Grzegorz Blach <magik@roorback.net> (based on)
Notes
Notes: svn path=/head/; revision=266276
Diffstat (limited to 'graphics/evas-loader-pmaps')
-rw-r--r--graphics/evas-loader-pmaps/Makefile46
-rw-r--r--graphics/evas-loader-pmaps/distinfo2
-rw-r--r--graphics/evas-loader-pmaps/pkg-descr6
-rw-r--r--graphics/evas-loader-pmaps/pkg-plist6
4 files changed, 60 insertions, 0 deletions
diff --git a/graphics/evas-loader-pmaps/Makefile b/graphics/evas-loader-pmaps/Makefile
new file mode 100644
index 000000000000..38a79c34e611
--- /dev/null
+++ b/graphics/evas-loader-pmaps/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: evas-loader-pmaps
+# Date created: 15 May 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= loader-pmaps
+DISTVERSION= 1.0.0.beta
+CATEGORIES= graphics enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= evas-
+DISTNAME= evas-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A hardware accelerated canvas API (PMAPS loader)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= evas librt_hack libtool_hack
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+
+MAKEDIRS= ${WRKSRC}/src/modules/loaders/pmaps
+
+.include "../evas-core/Makefile.inc"
+CONFIGURE_ARGS+= --enable-image-loader-pmaps
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
+ -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
+ ${MAKEDIRS:S,$,/Makefile.in,}
+
+do-build:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
+
+do-install:
+ @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
+
+.include <bsd.port.mk>
diff --git a/graphics/evas-loader-pmaps/distinfo b/graphics/evas-loader-pmaps/distinfo
new file mode 100644
index 000000000000..252e7b0fa992
--- /dev/null
+++ b/graphics/evas-loader-pmaps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/evas-1.0.0.beta.tar.bz2) = 7ff9a3015e5c5a0bee3c1a13b65358905fb6c81386bc22bf98bd7f73a893be1d
+SIZE (e17/evas-1.0.0.beta.tar.bz2) = 1054215
diff --git a/graphics/evas-loader-pmaps/pkg-descr b/graphics/evas-loader-pmaps/pkg-descr
new file mode 100644
index 000000000000..e525449b6c61
--- /dev/null
+++ b/graphics/evas-loader-pmaps/pkg-descr
@@ -0,0 +1,6 @@
+A hardware-accelerated canvas API for X-Windows that can draw anti-aliased
+text, smooth super and sub-sampled images, alpha-blend, as well as drop down to
+using normal X11 primitives such as pixmaps, lines and rectangles for speed if
+your CPU or graphics hardware is too slow.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Evas/
diff --git a/graphics/evas-loader-pmaps/pkg-plist b/graphics/evas-loader-pmaps/pkg-plist
new file mode 100644
index 000000000000..6f67e6a0d0e1
--- /dev/null
+++ b/graphics/evas-loader-pmaps/pkg-plist
@@ -0,0 +1,6 @@
+lib/evas/modules/loaders/pmaps/%%E17_ARCH%%/module.so
+@dirrm lib/evas/modules/loaders/pmaps/%%E17_ARCH%%
+@dirrm lib/evas/modules/loaders/pmaps
+@dirrmtry lib/evas/modules/loaders
+@dirrmtry lib/evas/modules
+@dirrmtry lib/evas