aboutsummaryrefslogtreecommitdiff
path: root/graphics/evolvotron
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 05:07:36 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 05:07:36 +0000
commitc545d87f456250e67f60cbb0835805a5ffbf5e14 (patch)
treeaa9c91bffeae9122febeb6e7bed992197cd55ba2 /graphics/evolvotron
parent020cd998029533b2188adeb43fcaea70649cf8be (diff)
downloadports-c545d87f456250e67f60cbb0835805a5ffbf5e14.tar.gz
ports-c545d87f456250e67f60cbb0835805a5ffbf5e14.zip
Upgrade to 0.3.1 to unbreak with recent GCC.
Reported by: kris Approved by: portmgr (krion, will), fjoe (mentor, implicit)
Notes
Notes: svn path=/head/; revision=118561
Diffstat (limited to 'graphics/evolvotron')
-rw-r--r--graphics/evolvotron/Makefile11
-rw-r--r--graphics/evolvotron/distinfo4
-rw-r--r--graphics/evolvotron/files/patch-common.pro19
-rw-r--r--graphics/evolvotron/files/patch-dialog_mutation_parameters.h10
-rw-r--r--graphics/evolvotron/files/patch-matrix.cpp10
5 files changed, 10 insertions, 44 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 7927c3c7761b..6cb4b29048a1 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= evolvotron
-PORTVERSION= 0.2.3
+PORTVERSION= 0.3.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,14 +28,9 @@ MAKE_ENV= QTDIR="${QT_PREFIX}" \
CONFIGURE_ENV= QTDIR="${QT_PREFIX}" \
QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' ${WRKSRC}/common.pro
+ @${REINPLACE_CMD} -e 's,bin/bash,bin/sh,' ${WRKSRC}/configure
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron/evolvotron ${PREFIX}/bin
@@ -46,4 +41,4 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/evolvotron.html ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/evolvotron/distinfo b/graphics/evolvotron/distinfo
index abd07c121f9f..f187ad7565c9 100644
--- a/graphics/evolvotron/distinfo
+++ b/graphics/evolvotron/distinfo
@@ -1,2 +1,2 @@
-MD5 (evolvotron-0.2.3.tar.gz) = 515461d06f247a54d810ed4178eed26c
-SIZE (evolvotron-0.2.3.tar.gz) = 152602
+MD5 (evolvotron-0.3.1.tar.gz) = e6c8404d7c454283fb5d8f00ec0c2761
+SIZE (evolvotron-0.3.1.tar.gz) = 129201
diff --git a/graphics/evolvotron/files/patch-common.pro b/graphics/evolvotron/files/patch-common.pro
index f7338521594a..a906227347f0 100644
--- a/graphics/evolvotron/files/patch-common.pro
+++ b/graphics/evolvotron/files/patch-common.pro
@@ -1,18 +1,18 @@
--- common.pro.orig Mon Nov 3 09:40:15 2003
+++ common.pro Mon Dec 1 03:16:47 2003
-@@ -29,8 +29,6 @@
+@@ -29,32 +29,12 @@
# Now leaving these ON for general distribution as they DO have SOME effect
# (or at least they have in the past... see the README), and should be portable.
-
+ # NB Switching on -funroll-loops causes some versions of gcc to segv
-QMAKE_CXXFLAGS_RELEASE -= -O2
--QMAKE_CXXFLAGS_RELEASE += -O3 -fomit-frame-pointer -funroll-loops -ffast-math
+-QMAKE_CXXFLAGS_RELEASE += -O3 -fomit-frame-pointer -ffast-math
##################
# Architecture specific optimisations
-@@ -38,23 +36,6 @@
+ # The following architecture options make the compiled executables less portable.
# (On a different setup you may need to change what's subtracted out of the flags.)
# NB -march=X implies -mcpu=X... no need to specify both the same
-
+-
-contains(CONFIG_OPTS, p4 ){
- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
- QMAKE_CXXFLAGS_RELEASE += -march=pentium4 -mfpmath=sse -msse2
@@ -33,12 +33,3 @@
##################
# Optimisation insanity
-@@ -67,7 +48,7 @@
- #######################################
- # Version numbering. This is ENTIRELY controlled by what is echoed by the VERSION script
-
--VERSION_NUMBER = $${system(../VERSION)}
-+VERSION_NUMBER = $${system(./VERSION)}
- QMAKE_CXXFLAGS_RELEASE += '-DEVOLVOTRON_VERSION="$$VERSION_NUMBER"'
- QMAKE_CXXFLAGS_DEBUG += '-DEVOLVOTRON_VERSION="$$VERSION_NUMBER"'
- QMAKE_CXXFLAGS_RELEASE += '-DEVOLVOTRON_BUILD="$$VERSION_NUMBER (Build options: $$BUILD_INFO Release)"'
diff --git a/graphics/evolvotron/files/patch-dialog_mutation_parameters.h b/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
deleted file mode 100644
index 37e5b3df4ed4..000000000000
--- a/graphics/evolvotron/files/patch-dialog_mutation_parameters.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libevolvotron/dialog_mutation_parameters.h.orig Mon Dec 1 03:09:32 2003
-+++ libevolvotron/dialog_mutation_parameters.h Mon Dec 1 03:10:15 2003
-@@ -23,6 +23,7 @@
- #ifndef _dialog_mutation_parameters_h_
- #define _dialog_mutation_parameters_h_
-
-+#include <time.h>
- #include <qdialog.h>
- #include <qvbox.h>
- #include <qgrid.h>
diff --git a/graphics/evolvotron/files/patch-matrix.cpp b/graphics/evolvotron/files/patch-matrix.cpp
deleted file mode 100644
index 9fcb6dd809f7..000000000000
--- a/graphics/evolvotron/files/patch-matrix.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- libevolvotron/matrix.cpp.orig Mon Dec 1 03:12:54 2003
-+++ libevolvotron/matrix.cpp Mon Dec 1 03:13:12 2003
-@@ -26,6 +26,7 @@
- #include "random.h"
-
- #include <iostream>
-+#include <time.h>
-
- //! Test code
- void testmatrix_extract_runtime(Matrix<2,2,float>& m_out,const Matrix<3,3,float>& m_in)