aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-09 16:46:32 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-09 16:46:32 +0000
commitd7d153bc58e2aa5e473c032b29d7b8487aca596e (patch)
tree95742a54da568a626317cbc82e7789def26c59f1 /graphics/freeimage
parent40277eeeb670629fa8491a54cc49659355aaed97 (diff)
downloadports-d7d153bc58e2aa5e473c032b29d7b8487aca596e.tar.gz
ports-d7d153bc58e2aa5e473c032b29d7b8487aca596e.zip
- Install the C++ wrapper FreeImagePlus as well
- Fix COMMENT and pkg-descr - Bump PORTREVISION PR: 178450 Submitted by: thierry
Notes
Notes: svn path=/head/; revision=317740
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile22
-rw-r--r--graphics/freeimage/pkg-descr3
2 files changed, 20 insertions, 5 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 8e4cfc44c396..46f1c0fddf0f 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -3,12 +3,13 @@
PORTNAME= freeimage
PORTVERSION= 3.15.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Source%20Distribution/${PORTVERSION}
DISTNAME= FreeImage${PORTVERSION:S/.//g}
MAINTAINER= gahr@FreeBSD.org
-COMMENT= An open source graphics library
+COMMENT= Simple C/C++ bitmap graphics library
USE_ZIP= yes
USE_DOS2UNIX= Source/LibOpenJPEG/opj_malloc.h
@@ -16,13 +17,18 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/FreeImage
-CFLAGS+= -fexceptions -fvisibility=hidden
+CFLAGS+= -fexceptions -fvisibility=hidden
PLIST_FILES= include/FreeImage.h \
+ include/FreeImagePlus.h \
lib/libfreeimage.a \
lib/libfreeimage-${PORTVERSION}.so \
lib/libfreeimage.so.3 \
- lib/libfreeimage.so
+ lib/libfreeimage.so \
+ lib/libfreeimageplus.a \
+ lib/libfreeimageplus-${PORTVERSION}.so \
+ lib/libfreeimageplus.so.3 \
+ lib/libfreeimageplus.so
.include <bsd.port.pre.mk>
@@ -32,6 +38,14 @@ CFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}| ; s|-g root|-g wheel|' \
- ${WRKSRC}/Makefile.gnu
+ ${WRKSRC}/Makefile.gnu ${WRKSRC}/Makefile.fip
+
+post-build:
+ cd ${WRKSRC} && ${GMAKE} -f Makefile.fip
+
+post-install:
+ cd ${WRKSRC} && ${GMAKE} -f Makefile.fip ${INSTALL_TARGET}
+ ${LN} -s libfreeimageplus-${PORTVERSION} ${PREFIX}/lib/libfreeimageplus.so.3
+ ${LN} -s libfreeimageplus-${PORTVERSION} ${PREFIX}/lib/libfreeimageplus.so
.include <bsd.port.post.mk>
diff --git a/graphics/freeimage/pkg-descr b/graphics/freeimage/pkg-descr
index 298af5220d20..afcd77e7f55a 100644
--- a/graphics/freeimage/pkg-descr
+++ b/graphics/freeimage/pkg-descr
@@ -1,6 +1,7 @@
FreeImage is an open source library project for developers who would like to
support popular graphics image formats like PNG, BMP, JPEG, TIFF, and others
as needed by today's multimedia applications. FreeImage is easy to use,
-fast, multithreading safe, and cross-platform.
+fast, multithreading safe, and cross-platform. This port includes both the
+original C interface and the C++ wrapper FreeImagePlus.
WWW: http://freeimage.sourceforge.net/