aboutsummaryrefslogtreecommitdiff
path: root/graphics/frei0r
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 08:31:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-06 08:31:29 +0000
commitcda59ea3e25f7188d5070e5a9ee5d0af11627402 (patch)
tree933a79805e8e74784ee3f4b8399955b260e7b423 /graphics/frei0r
parent381250fd12c0b35545d8073b16e86cf0e561e9be (diff)
downloadports-cda59ea3e25f7188d5070e5a9ee5d0af11627402.tar.gz
ports-cda59ea3e25f7188d5070e5a9ee5d0af11627402.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=317482
Diffstat (limited to 'graphics/frei0r')
-rw-r--r--graphics/frei0r/Makefile26
1 files changed, 9 insertions, 17 deletions
diff --git a/graphics/frei0r/Makefile b/graphics/frei0r/Makefile
index 13ab9c31c55d..3102a571c56c 100644
--- a/graphics/frei0r/Makefile
+++ b/graphics/frei0r/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: frei0r
-# Date created: 17 November 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= frei0r
PORTVERSION= 1.3
@@ -47,12 +43,14 @@ FREI0R_PLUGINS= rgbparade scale0tilt vectorscope
PORTDOCS= *
-OPTIONS= APIDOC "Install full documentation (requires doxygen)" off \
- MMX "Enable MMX CPU instructions" off
+OPTIONS_DEFINE= APIDOC
+OPTIONS_DEFINE_amd64= MMX
+APIDOC_DESC= Install full documentation (requires doxygen)
+MMX_DESC= MMX CPU instructions
.include <bsd.port.options.mk>
-. if !defined(NOPORTDOCS) && defined(WITH_APIDOC)
+. if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MAPIDOC}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
. endif
@@ -70,12 +68,6 @@ PLIST_FILES+= lib/frei0r-1/${FILE}.so
PLIST_FILES+= "@dirrmtry lib/frei0r-1"
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(WITH_MMX) && ${ARCH} != "amd64"
-CONFIGURE_ARGS+=--disable-cpuflags
-.endif
-
post-patch:
.if !defined(BUILDING_FREI0R_GAVL)
@${REINPLACE_CMD} -e 's/HAVE_GAVL=true/HAVE_GAVL=false/g' \
@@ -86,10 +78,10 @@ post-patch:
${WRKSRC}/configure
.endif
.if !defined(FREI0R_PLUGINS)
-. if !defined(NOPORTDOCS) && defined(WITH_APIDOC)
+. if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MAPIDOC}
@${REINPLACE_CMD} -e '/^SUBDIRS/s|include|include doc|' ${WRKSRC}/Makefile.in
. endif
-. if defined(NOPORTDOCS)
+. if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/^install-data-am/s| install-docsDATA||' \
${WRKSRC}/Makefile.in
. endif
@@ -110,6 +102,6 @@ pre-build:
@${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in \
${WRKSRC}/configure ${WRKSRC}/config.h.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif # !defined(BUILDING_FREI0R_METAPORT)