aboutsummaryrefslogtreecommitdiff
path: root/graphics/fv
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-24 21:53:51 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-24 21:53:51 +0000
commitb49222aeda34871a1ddd6759e977cee8dca6b6e9 (patch)
treeb02dcc288d7d639cbec84a1697fa9602c8c232a2 /graphics/fv
parent69558f6d80b2a6553008688c6acd94a9328b2fa7 (diff)
downloadports-b49222aeda34871a1ddd6759e977cee8dca6b6e9.tar.gz
ports-b49222aeda34871a1ddd6759e977cee8dca6b6e9.zip
Properly support png 1.5
Notes
Notes: svn path=/head/; revision=375488
Diffstat (limited to 'graphics/fv')
-rw-r--r--graphics/fv/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 341c1c13043a..ca097426ad56 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -13,15 +13,15 @@ COMMENT= Viewer of hdr/pfm images
LICENSE= GPLv2
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USES= gmake pkgconfig zip
USE_GL= glut
ALL_TARGET= ${PORTNAME}
-CXXFLAGS+= $$(pkg-config --cflags libpng15) \
+CXXFLAGS+= $$(pkg-config --cflags libpng) \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= $$(pkg-config --libs libpng15) \
+LDFLAGS+= $$(pkg-config --libs libpng) \
-L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm -lz -llzma \
${PTHREAD_LIBS}