aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2019-09-22 17:55:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2019-09-22 17:55:02 +0000
commit8e3a192fe34042975a42daa08cc6f68d9480af87 (patch)
tree952922d1dc64ef281734afbd0a6556fa08f5386e /graphics/gd/Makefile
parent30d163dd045b367970bc5c40554a9d11ef7196a3 (diff)
downloadports-8e3a192fe34042975a42daa08cc6f68d9480af87.tar.gz
ports-8e3a192fe34042975a42daa08cc6f68d9480af87.zip
- fix missing include path if all options are off
PR: 240752 - new option PNG JPEG FREETYPE - enable option ICONV by default
Notes
Notes: svn path=/head/; revision=512598
Diffstat (limited to 'graphics/gd/Makefile')
-rw-r--r--graphics/gd/Makefile37
1 files changed, 24 insertions, 13 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 91393c6cf93c..f36771c93f19 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgd
PORTVERSION= 2.2.5
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/gd-${PORTVERSION}/
@@ -14,31 +14,42 @@ COMMENT?= Graphics library for fast creation of images
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpng.so:graphics/png \
- libfreetype.so:print/freetype2
-
CONFLICTS= bazaar-1.*
-USES= tar:xz pkgconfig pathfix libtool:keepla shebangfix jpeg
+USES= tar:xz pkgconfig pathfix libtool:keepla shebangfix
SHEBANG_FILES= ${WRKSRC}/src/bdftogd
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
TEST_TARGET= check
-OPTIONS_DEFINE= FONTCONFIG ICONV XPM WEBP TIFF
-OPTIONS_DEFAULT=FONTCONFIG WEBP TIFF
+OPTIONS_DEFINE= PNG JPEG WEBP TIFF FREETYPE FONTCONFIG XPM ICONV
+OPTIONS_DEFAULT=PNG JPEG WEBP TIFF FREETYPE FONTCONFIG ICONV
NO_OPTIONS_SORT=yes
+OPTIONS_SUB= yes
+PNG_LIB_DEPENDS= libpng.so:graphics/png
+PNG_CONFIGURE_OFF= --without-png
+PNG_CPPFLAGS= -I${LOCALBASE}/include
+JPEG_USES= jpeg
+JPEG_CONFIGURE_OFF= --without-jpeg
+JPEG_CPPFLAGS= -I${LOCALBASE}/include
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_CONFIGURE_OFF= --without-webp
+WEBP_CPPFLAGS= -I${LOCALBASE}/include
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_CONFIGURE_OFF= --without-tiff
+TIFF_CPPFLAGS= -I${LOCALBASE}/include
+FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
+FREETYPE_CONFIGURE_OFF= --without-freetype
+FREETYPE_CPPFLAGS= -I${LOCALBASE}/include
FONTCONFIG_LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
FONTCONFIG_CONFIGURE_OFF= --with-fontconfig=no
-ICONV_USES= iconv
-ICONV_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
+FONTCONFIG_CPPFLAGS= -I${LOCALBASE}/include
XPM_USE= xorg=xpm,x11
XPM_CONFIGURE_ON= --with-x
XPM_CONFIGURE_OFF= --with-xpm=no
-WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
-WEBP_CONFIGURE_OFF= --without-webp
-TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
-TIFF_CONFIGURE_OFF= --without-tiff
+ICONV_USES= iconv
+ICONV_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
.include <bsd.port.options.mk>