aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-01-16 20:49:42 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-01-16 20:49:42 +0000
commit2ec98a8fc30027325470e6c849145d6c66f435e1 (patch)
treeead58f88921636d1d42eed6751c64c01ee97e776 /graphics/gdal/Makefile
parent1820fb01b50293b402077a3f2daa1908c766909c (diff)
downloadports-2ec98a8fc30027325470e6c849145d6c66f435e1.tar.gz
ports-2ec98a8fc30027325470e6c849145d6c66f435e1.zip
- Add -flax-vector-conversions to CFLAGS only on FreeBSD 9
Notes
Notes: svn path=/head/; revision=406274
Diffstat (limited to 'graphics/gdal/Makefile')
-rw-r--r--graphics/gdal/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 405a2d36993b..58c192271e23 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -30,7 +30,7 @@ OPTIONS_RADIO_PDF= PODOFO POPPLER
PCRE_DESC= Regular expression support for SQLite
SPATIALITE_DESC=SpatiaLite support
-CFLAGS+= -fPIC -flax-vector-conversions
+CFLAGS+= -fPIC
CONFIGURE_ARGS= --datadir=${DATADIR} \
--enable-static=yes \
--with-geotiff=${LOCALBASE} \
@@ -151,4 +151,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/GDALmake.opt ${STAGEDIR}${DATADIR}/
-${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libgdal.so.${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+CFLAGS+= -flax-vector-conversions
+.endif
+
+.include <bsd.port.post.mk>