aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-04 20:07:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-04 20:07:06 +0000
commit5b3992e1ba6b971014b078aa54ef5334535dbda8 (patch)
treebacb8cc6c875816790d5f2514295d7309a1055ca /graphics/gdal/Makefile
parent5e60eaff7c894334d350281d1fdc2ca8b8faccf9 (diff)
downloadports-5b3992e1ba6b971014b078aa54ef5334535dbda8.tar.gz
ports-5b3992e1ba6b971014b078aa54ef5334535dbda8.zip
Use REINPLACE_CMD instead of patch files
Notes
Notes: svn path=/head/; revision=492159
Diffstat (limited to 'graphics/gdal/Makefile')
-rw-r--r--graphics/gdal/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 21949f9f40bb..e99f6f2b07ec 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -137,6 +137,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^#GDAL_SLIB_SONAME/ s|^#||' ${WRKSRC}/GDALmake.opt.in
@${REINPLACE_CMD} -e 's|$$(INST_LIB)/pkgconfig|${PREFIX}/libdata/pkgconfig|; s| LICENSE.TXT||' ${WRKSRC}/GNUmakefile
@${REINPLACE_CMD} -e 's|-lminizip|-lkmlminizip|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|getCString()|c_str()|' ${WRKSRC}/frmts/pdf/pdfdataset.cpp ${WRKSRC}/frmts/pdf/pdfobject.cpp
# Clean up bundled libraries
@${RM} -r ${WRKSRC}/frmts/gif/giflib/
@${RM} -r ${WRKSRC}/frmts/gtiff/libgeotiff/