aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-08-01 02:26:57 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-08-01 02:26:57 +0000
commitd752fd0364de3d1f0a7eedb04183870209fbf94b (patch)
tree4212983c237f7f55fbf340fe72cdf22dad45e9d5 /graphics/gdal
parent9ccdf092b7b5105f6a3e4501c4c4a6a88e279889 (diff)
downloadports-d752fd0364de3d1f0a7eedb04183870209fbf94b.tar.gz
ports-d752fd0364de3d1f0a7eedb04183870209fbf94b.zip
Use libtiff from the port rather than the version bundled with gdal
software (thus avoiding libtiff BitsPerSample vulnerability). Bump PORTREVISION. Security: VuXML: 68222076-010b-11da-bc08-0001020eed82
Notes
Notes: svn path=/head/; revision=140599
Diffstat (limited to 'graphics/gdal')
-rw-r--r--graphics/gdal/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index cc04a83b8985..0cde436adebb 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdal
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/gdal/
@@ -16,7 +16,8 @@ COMMENT= A translator library for raster geospatial data formats
BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
LIB_DEPENDS= jasper.4:${PORTSDIR}/graphics/jasper \
- png.5:${PORTSDIR}/graphics/png
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
USE_PYTHON= yes
USE_GMAKE= yes
@@ -24,7 +25,7 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libz=internal \
--with-png=${LOCALBASE} \
- --with-libtiff=internal \
+ --with-libtiff=${LOCALBASE} \
--with-libgeotiff=internal \
--with-libjpeg=internal \
--with-libgif=internal \
@@ -32,6 +33,7 @@ CONFIGURE_ARGS= --with-libz=internal \
--with-python
MAKEFILE= GNUmakefile
INSTALLS_SHLIB= yes
+CFLAGS+= -I${LOCALBASE}/include
MAN1= gdaladdo.1 gdalinfo.1 gdaltindex.1 gdalwarp.1 \
gdal-config.1 gdal_translate.1 ogrinfo.1 \
@@ -39,5 +41,6 @@ MAN1= gdaladdo.1 gdalinfo.1 gdaltindex.1 gdalwarp.1 \
post-patch:
@${REINPLACE_CMD} -e 's|6LIBZ|6|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|"tiffio.h"|<tiffio.h>|' ${WRKSRC}/frmts/gtiff/libgeotiff/xtiffio.h
.include <bsd.port.mk>