aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-07-01 10:36:59 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-07-01 10:38:06 +0000
commit09da9cfa444f688ca70ab0a1b17f6ff11e23b1fc (patch)
treec12ed54243f9fba97f417b78dec53e70c4cbc182 /graphics/gegl
parenta29022d17449d8f3ffd88d46752f60fd67ec496e (diff)
downloadports-09da9cfa444f688ca70ab0a1b17f6ff11e23b1fc.tar.gz
ports-09da9cfa444f688ca70ab0a1b17f6ff11e23b1fc.zip
graphics/gegl: Fix packaging on aarch64
PR: 264972
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile8
-rw-r--r--graphics/gegl/pkg-plist10
2 files changed, 9 insertions, 9 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index e678b899ab72..d5165a494cf0 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -132,11 +132,11 @@ LDFLAGS+= -lexecinfo
.endif
.if ${ARCH} == "amd64"
-PLIST_SUB+= AMD64="" AARCH64="@comment "
-.elif ${ARCH} == "aarch64"
-PLIST_SUB+= AMD64="@comment " AARCH64=""
+PLIST_SUB+= AMD64="" ARM="@comment "
+.elif ${ARCH} == "armv6" || ${ARCH} == "armv7"
+PLIST_SUB+= AMD64="@comment " ARM=""
.else
-PLIST_SUB+= AMD64="@comment " AARCH64="@comment "
+PLIST_SUB+= AMD64="@comment " ARM="@comment "
.endif
post-patch:
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index 816b3bf3b88e..ec0a267f75ac 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -89,23 +89,23 @@ include/gegl-%%GEGL_VER%%/sc/sc-sample.h
%%FFMPEG%%lib/gegl-%%GEGL_VER%%/ff-save.so
lib/gegl-%%GEGL_VER%%/dropshadow2.json
lib/gegl-%%GEGL_VER%%/gegl-common-cxx.so
-%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-arm-neon.so
+%%ARM%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-arm-neon.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-x86_64-v2.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-cxx-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gegl-common-gpl3.so
-%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-arm-neon.so
+%%ARM%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-arm-neon.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-x86_64-v2.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-gpl3-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gegl-common.so
-%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-common-arm-neon.so
+%%ARM%%lib/gegl-%%GEGL_VER%%/gegl-common-arm-neon.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-x86_64-v2.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-common-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gegl-core.so
lib/gegl-%%GEGL_VER%%/gegl-generated.so
-%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-generated-arm-neon.so
+%%ARM%%lib/gegl-%%GEGL_VER%%/gegl-generated-arm-neon.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-generated-x86_64-v2.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-generated-x86_64-v3.so
-%%AARCH64%%lib/gegl-%%GEGL_VER%%/gegl-transformops-arm-neon.so
+%%ARM%%lib/gegl-%%GEGL_VER%%/gegl-transformops-arm-neon.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-transformops-x86_64-v2.so
%%AMD64%%lib/gegl-%%GEGL_VER%%/gegl-transformops-x86_64-v3.so
lib/gegl-%%GEGL_VER%%/gif-load.so