aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
commit13fb0b92a29536c74fd1cea5b5e8e7fb8705be98 (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /graphics/gegl
parent52a39feebd3a360c0a4633697006081ae2024197 (diff)
downloadports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.tar.gz
ports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=472160
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index c6515d273e21..2c5e0507d290 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -15,10 +15,10 @@ LICENSE_COMB= multi
LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING
LICENSE_FILE_LGPL3+ = ${WRKSRC}/COPYING.LESSER
-LIB_DEPENDS= libbabl-0.1.so:x11/babl
-
BROKEN_aarch64= fails to build: gmake index.html: Segmentation fault in docs/gallery/
+LIB_DEPENDS= libbabl-0.1.so:x11/babl
+
# ignore new versions until we can replace this version with gegl 3.x
PORTSCOUT= ignore:1
@@ -41,7 +41,7 @@ CONFIGURE_ARGS= --without-vala --disable-docs
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lintl
+LDFLAGS+= -L${LOCALBASE}/lib -lintl -lm
GEGL_MINOR= 199
GEGL_VER= 0.2