aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos/pkg-plist
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-10 17:09:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-10 17:09:11 +0000
commit5c0f12364a83d167ef7ed82c4301a7167bcf014c (patch)
tree94ddb7b6ee19eccfb18f57502b580335758d5628 /graphics/geos/pkg-plist
parentca32862006e4f30675e3511c9a3bae6e78b1d96e (diff)
downloadports-5c0f12364a83d167ef7ed82c4301a7167bcf014c.tar.gz
ports-5c0f12364a83d167ef7ed82c4301a7167bcf014c.zip
Update to 3.8.0
Notes
Notes: svn path=/head/; revision=519679
Diffstat (limited to 'graphics/geos/pkg-plist')
-rw-r--r--graphics/geos/pkg-plist57
1 files changed, 42 insertions, 15 deletions
diff --git a/graphics/geos/pkg-plist b/graphics/geos/pkg-plist
index 92161101380b..f11310cbe3dc 100644
--- a/graphics/geos/pkg-plist
+++ b/graphics/geos/pkg-plist
@@ -1,29 +1,30 @@
bin/geos-config
include/geos.h
include/geos/algorithm/Angle.h
+include/geos/algorithm/Area.h
include/geos/algorithm/BoundaryNodeRule.h
-include/geos/algorithm/CGAlgorithms.h
+include/geos/algorithm/CGAlgorithmsDD.h
include/geos/algorithm/CentralEndpointIntersector.h
include/geos/algorithm/Centroid.h
-include/geos/algorithm/CentroidArea.h
-include/geos/algorithm/CentroidLine.h
-include/geos/algorithm/CentroidPoint.h
include/geos/algorithm/ConvexHull.h
include/geos/algorithm/ConvexHull.inl
+include/geos/algorithm/Distance.h
include/geos/algorithm/HCoordinate.h
include/geos/algorithm/InteriorPointArea.h
include/geos/algorithm/InteriorPointLine.h
include/geos/algorithm/InteriorPointPoint.h
+include/geos/algorithm/Intersection.h
+include/geos/algorithm/Length.h
include/geos/algorithm/LineIntersector.h
-include/geos/algorithm/MCPointInRing.h
+include/geos/algorithm/MinimumBoundingCircle.h
include/geos/algorithm/MinimumDiameter.h
include/geos/algorithm/NotRepresentableException.h
-include/geos/algorithm/PointInRing.h
+include/geos/algorithm/Orientation.h
+include/geos/algorithm/PointLocation.h
include/geos/algorithm/PointLocator.h
include/geos/algorithm/RayCrossingCounter.h
+include/geos/algorithm/RayCrossingCounterDD.h
include/geos/algorithm/RobustDeterminant.h
-include/geos/algorithm/SIRtreePointInRing.h
-include/geos/algorithm/SimplePointInRing.h
include/geos/algorithm/distance/DiscreteFrechetDistance.h
include/geos/algorithm/distance/DiscreteHausdorffDistance.h
include/geos/algorithm/distance/DistanceToPoint.h
@@ -31,6 +32,21 @@ include/geos/algorithm/distance/PointPairDistance.h
include/geos/algorithm/locate/IndexedPointInAreaLocator.h
include/geos/algorithm/locate/PointOnGeometryLocator.h
include/geos/algorithm/locate/SimplePointInAreaLocator.h
+include/geos/algorithm/ttmath/ttmath.h
+include/geos/algorithm/ttmath/ttmathbig.h
+include/geos/algorithm/ttmath/ttmathdec.h
+include/geos/algorithm/ttmath/ttmathint.h
+include/geos/algorithm/ttmath/ttmathmisc.h
+include/geos/algorithm/ttmath/ttmathobjects.h
+include/geos/algorithm/ttmath/ttmathparser.h
+include/geos/algorithm/ttmath/ttmaththreads.h
+include/geos/algorithm/ttmath/ttmathtypes.h
+include/geos/algorithm/ttmath/ttmathuint.h
+include/geos/algorithm/ttmath/ttmathuint_noasm.h
+include/geos/algorithm/ttmath/ttmathuint_x86.h
+include/geos/algorithm/ttmath/ttmathuint_x86_64.h
+include/geos/algorithm/ttmath/ttmathuint_x86_64_msvc.asm
+include/geos/constants.h
include/geos/export.h
include/geos/geom.h
include/geos/geom/BinaryOp.h
@@ -44,9 +60,11 @@ include/geos/geom/CoordinateList.h
include/geos/geom/CoordinateSequence.h
include/geos/geom/CoordinateSequenceFactory.h
include/geos/geom/CoordinateSequenceFilter.h
+include/geos/geom/DefaultCoordinateSequenceFactory.h
include/geos/geom/Dimension.h
include/geos/geom/Envelope.h
include/geos/geom/Envelope.inl
+include/geos/geom/FixedSizeCoordinateSequence.h
include/geos/geom/Geometry.h
include/geos/geom/GeometryCollection.h
include/geos/geom/GeometryCollection.inl
@@ -58,7 +76,6 @@ include/geos/geom/IntersectionMatrix.h
include/geos/geom/LineSegment.h
include/geos/geom/LineSegment.inl
include/geos/geom/LineString.h
-include/geos/geom/Lineal.h
include/geos/geom/LinearRing.h
include/geos/geom/Location.h
include/geos/geom/MultiLineString.h
@@ -68,10 +85,8 @@ include/geos/geom/MultiPolygon.h
include/geos/geom/MultiPolygon.inl
include/geos/geom/Point.h
include/geos/geom/Polygon.h
-include/geos/geom/Polygonal.h
include/geos/geom/PrecisionModel.h
include/geos/geom/PrecisionModel.inl
-include/geos/geom/Puntal.h
include/geos/geom/Triangle.h
include/geos/geom/prep/AbstractPreparedPolygonContains.h
include/geos/geom/prep/BasicPreparedGeometry.h
@@ -88,6 +103,7 @@ include/geos/geom/prep/PreparedPolygonIntersects.h
include/geos/geom/prep/PreparedPolygonPredicate.h
include/geos/geom/util/ComponentCoordinateExtracter.h
include/geos/geom/util/CoordinateOperation.h
+include/geos/geom/util/Densifier.h
include/geos/geom/util/GeometryCombiner.h
include/geos/geom/util/GeometryEditor.h
include/geos/geom/util/GeometryEditorOperation.h
@@ -101,6 +117,7 @@ include/geos/geom/util/SineStarFactory.h
include/geos/geomUtil.h
include/geos/geomgraph.h
include/geos/geomgraph/Depth.h
+include/geos/geomgraph/Depth.inl
include/geos/geomgraph/DirectedEdge.h
include/geos/geomgraph/DirectedEdge.inl
include/geos/geomgraph/DirectedEdgeStar.h
@@ -116,18 +133,22 @@ include/geos/geomgraph/GeometryGraph.h
include/geos/geomgraph/GeometryGraph.inl
include/geos/geomgraph/GraphComponent.h
include/geos/geomgraph/Label.h
+include/geos/geomgraph/Label.inl
include/geos/geomgraph/Node.h
include/geos/geomgraph/NodeFactory.h
include/geos/geomgraph/NodeMap.h
include/geos/geomgraph/PlanarGraph.h
include/geos/geomgraph/Position.h
include/geos/geomgraph/Quadrant.h
+include/geos/geomgraph/Quadrant.inl
include/geos/geomgraph/TopologyLocation.h
+include/geos/geomgraph/TopologyLocation.inl
include/geos/geomgraph/index/EdgeSetIntersector.h
include/geos/geomgraph/index/MonotoneChain.h
include/geos/geomgraph/index/MonotoneChainEdge.h
include/geos/geomgraph/index/MonotoneChainIndexer.h
include/geos/geomgraph/index/SegmentIntersector.h
+include/geos/geomgraph/index/SegmentIntersector.inl
include/geos/geomgraph/index/SimpleEdgeSetIntersector.h
include/geos/geomgraph/index/SimpleMCSweepLineIntersector.h
include/geos/geomgraph/index/SimpleSweepLineIntersector.h
@@ -163,6 +184,7 @@ include/geos/index/strtree/AbstractNode.h
include/geos/index/strtree/AbstractSTRtree.h
include/geos/index/strtree/Boundable.h
include/geos/index/strtree/BoundablePair.h
+include/geos/index/strtree/EnvelopeUtil.h
include/geos/index/strtree/GeometryItemDistance.h
include/geos/index/strtree/Interval.h
include/geos/index/strtree/ItemBoundable.h
@@ -205,6 +227,7 @@ include/geos/linearref/LocationIndexOfPoint.h
include/geos/linearref/LocationIndexedLine.h
include/geos/noding.h
include/geos/noding/BasicSegmentString.h
+include/geos/noding/BasicSegmentString.inl
include/geos/noding/FastNodingValidator.h
include/geos/noding/FastSegmentSetIntersectionFinder.h
include/geos/noding/GeometryNoder.h
@@ -217,6 +240,7 @@ include/geos/noding/MCIndexSegmentSetMutualIntersector.h
include/geos/noding/NodableSegmentString.h
include/geos/noding/NodedSegmentString.h
include/geos/noding/Noder.h
+include/geos/noding/NodingIntersectionFinder.h
include/geos/noding/NodingValidator.h
include/geos/noding/Octant.h
include/geos/noding/OrientedCoordinateArray.h
@@ -230,7 +254,6 @@ include/geos/noding/SegmentSetMutualIntersector.h
include/geos/noding/SegmentString.h
include/geos/noding/SegmentStringUtil.h
include/geos/noding/SimpleNoder.h
-include/geos/noding/SingleInteriorIntersectionFinder.h
include/geos/noding/SinglePassNoder.h
include/geos/noding/snapround/HotPixel.h
include/geos/noding/snapround/HotPixel.inl
@@ -294,7 +317,9 @@ include/geos/operation/overlay/snap/GeometrySnapper.h
include/geos/operation/overlay/snap/LineStringSnapper.h
include/geos/operation/overlay/snap/SnapIfNeededOverlayOp.h
include/geos/operation/overlay/snap/SnapOverlayOp.h
+include/geos/operation/polygonize/BuildArea.h
include/geos/operation/polygonize/EdgeRing.h
+include/geos/operation/polygonize/HoleAssigner.h
include/geos/operation/polygonize/PolygonizeDirectedEdge.h
include/geos/operation/polygonize/PolygonizeEdge.h
include/geos/operation/polygonize/PolygonizeGraph.h
@@ -313,13 +338,17 @@ include/geos/operation/relate/RelateOp.h
include/geos/operation/sharedpaths/SharedPathsOp.h
include/geos/operation/union/CascadedPolygonUnion.h
include/geos/operation/union/CascadedUnion.h
+include/geos/operation/union/CoverageUnion.h
include/geos/operation/union/GeometryListHolder.h
+include/geos/operation/union/OverlapUnion.h
include/geos/operation/union/PointGeometryUnion.h
include/geos/operation/union/UnaryUnionOp.h
include/geos/operation/valid/ConnectedInteriorTester.h
include/geos/operation/valid/ConsistentAreaTester.h
include/geos/operation/valid/IsValidOp.h
+include/geos/operation/valid/MakeValid.h
include/geos/operation/valid/QuadtreeNestedRingTester.h
+include/geos/operation/valid/RepeatedPointRemover.h
include/geos/operation/valid/RepeatedPointTester.h
include/geos/operation/valid/SimpleNestedRingTester.h
include/geos/operation/valid/SweeplineNestedRingTester.h
@@ -334,7 +363,6 @@ include/geos/planargraph/NodeMap.h
include/geos/planargraph/PlanarGraph.h
include/geos/planargraph/Subgraph.h
include/geos/planargraph/algorithm/ConnectedSubgraphFinder.h
-include/geos/platform.h
include/geos/precision.h
include/geos/precision/CommonBits.h
include/geos/precision/CommonBitsOp.h
@@ -354,7 +382,6 @@ include/geos/simplify/TaggedLineStringSimplifier.h
include/geos/simplify/TaggedLinesSimplifier.h
include/geos/simplify/TopologyPreservingSimplifier.h
include/geos/spatialIndex.h
-include/geos/timeval.h
include/geos/triangulate/DelaunayTriangulationBuilder.h
include/geos/triangulate/IncrementalDelaunayTriangulator.h
include/geos/triangulate/VoronoiDiagramBuilder.h
@@ -389,6 +416,6 @@ lib/libgeos.so
lib/libgeos_c.a
lib/libgeos_c.so
lib/libgeos_c.so.1
-lib/libgeos_c.so.1.11.2
+lib/libgeos_c.so.1.13.1
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.a
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.so