aboutsummaryrefslogtreecommitdiff
path: root/graphics/gexiv2/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-09-07 02:49:13 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2010-09-07 02:49:13 +0000
commit28639fc6290df4c3f627ca17c9722dd89ea28369 (patch)
tree8094c9e61bc36057855f07601da3cde3542984c2 /graphics/gexiv2/Makefile
parent02fd646f9ec931cbed9680abfbed390b3b96bf38 (diff)
downloadports-28639fc6290df4c3f627ca17c9722dd89ea28369.tar.gz
ports-28639fc6290df4c3f627ca17c9722dd89ea28369.zip
New port gexiv2 version 0.2.0: GObject-based wrapper around the
Exiv2 library
Notes
Notes: svn path=/head/; revision=260670
Diffstat (limited to 'graphics/gexiv2/Makefile')
-rw-r--r--graphics/gexiv2/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
new file mode 100644
index 000000000000..47fc009867c8
--- /dev/null
+++ b/graphics/gexiv2/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gexiv2
+# Date created: Tue Sep 7 02:00:03 UTC 2010
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gexiv2
+PORTVERSION= 0.2.0
+CATEGORIES= graphics
+MASTER_SITES= http://yorba.org/download/gexiv2/${PORTVERSION:R}/
+DISTNAME= libgexiv2-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GObject-based wrapper around the Exiv2 library
+
+BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool22 \
+ gm4:${PORTSDIR}/devel/m4 \
+ pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2
+
+USE_BZIP2= yes
+USE_GNOME= glib20
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|^([[:space:]]+)m4[[:space:]]|\1gm4 |' \
+ -e 's|\$$\(LIB\)/pkgconfig|libdata/pkgconfig|g' \
+ ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>