aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-beautify-plugin
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-08 08:14:54 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-08 08:14:54 +0000
commit6246733770ce414ed35181eccf00593dfb2daf0b (patch)
treec387dbcf541c450bdf30e2868ef5754a4540c27f /graphics/gimp-beautify-plugin
parent3b09753032f009a5032421ca203613bdfa96b15e (diff)
downloadports-6246733770ce414ed35181eccf00593dfb2daf0b.tar.gz
ports-6246733770ce414ed35181eccf00593dfb2daf0b.zip
graphics/gimp-beautify-plugin: fix build with GCC-based architectures
Respect CFLAGS and LDFLAGS to fix build when using GCC. Also add USES=gnome. Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D20180
Notes
Notes: svn path=/head/; revision=501005
Diffstat (limited to 'graphics/gimp-beautify-plugin')
-rw-r--r--graphics/gimp-beautify-plugin/Makefile2
-rw-r--r--graphics/gimp-beautify-plugin/files/patch-Makefile53
2 files changed, 52 insertions, 3 deletions
diff --git a/graphics/gimp-beautify-plugin/Makefile b/graphics/gimp-beautify-plugin/Makefile
index 6d33509e29c2..764d421ff314 100644
--- a/graphics/gimp-beautify-plugin/Makefile
+++ b/graphics/gimp-beautify-plugin/Makefile
@@ -24,7 +24,7 @@ USE_GITHUB= yes
GH_ACCOUNT= hejiann
GH_TAGNAME= e209c8d
-USES= gettext gmake pkgconfig
+USES= gettext gmake gnome pkgconfig
USE_GCC= yes
USE_GNOME= atk cairo gdkpixbuf2 gtk20
USE_XORG= x11 xcomposite xcursor xdamage xext xfixes xi xinerama xrandr xrender
diff --git a/graphics/gimp-beautify-plugin/files/patch-Makefile b/graphics/gimp-beautify-plugin/files/patch-Makefile
index f411cb0732a0..5e81554c36bb 100644
--- a/graphics/gimp-beautify-plugin/files/patch-Makefile
+++ b/graphics/gimp-beautify-plugin/files/patch-Makefile
@@ -1,10 +1,59 @@
--- Makefile.orig 2012-08-12 09:23:45 UTC
+++ Makefile
-@@ -13,7 +13,6 @@
+@@ -13,17 +13,16 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-CC = gcc
- GIMPTOOL = gimptool-2.0
+-GIMPTOOL = gimptool-2.0
++GIMPTOOL = /usr/local/bin/gimptool-2.0
+ GIMP_LIBS = `$(GIMPTOOL) --libs`
+ GIMP_CFLAGS = `$(GIMPTOOL) --cflags`
+
+ LIBS = $(GIMP_LIBS) -lm
+-CFLAGS = $(GIMP_CFLAGS)
++CFLAGS += $(GIMP_CFLAGS)
+
+-GDK_PIXBUF_CSOURCE = gdk-pixbuf-csource
++GDK_PIXBUF_CSOURCE = /usr/local/bin/gdk-pixbuf-csource
+
+ all: beautify skin-whitening simple-border border
+
+@@ -71,7 +70,7 @@ useruninstall:
+ $(GIMPTOOL) --uninstall-bin texture-border
+
+ beautify: beautify.o beautify-effect.o
+- $(CC) -o $@ $^ $(LIBS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ beautify.o: beautify.c
+ $(CC) $(CFLAGS) -c beautify.c -o beautify.o
+@@ -83,7 +82,7 @@ beautify-textures.h: beautify-textures.list
+ $(GDK_PIXBUF_CSOURCE) --raw --build-list `cat beautify-textures.list` > $(@F)
+
+ skin-whitening: skin-whitening.o skin-whitening-effect.o
+- $(CC) -o $@ $^ $(LIBS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ skin-whitening.o: skin-whitening.c skin-whitening-images.h
+ $(CC) $(CFLAGS) -c skin-whitening.c -o skin-whitening.o
+@@ -95,7 +94,7 @@ skin-whitening-effect.o: skin-whitening-effect.c skin-
+ $(CC) $(CFLAGS) -c skin-whitening-effect.c -o skin-whitening-effect.o
+
+ simple-border: simple-border.o
+- $(CC) -o $@ $^ $(LIBS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ simple-border.o: simple-border.c simple-border-textures.h
+ $(CC) $(CFLAGS) -c simple-border.c -o simple-border.o
+@@ -104,7 +103,7 @@ simple-border-textures.h: simple-border-textures.list
+ $(GDK_PIXBUF_CSOURCE) --raw --build-list `cat simple-border-textures.list` > $(@F)
+
+ border: border.o
+- $(CC) -o $@ $^ $(LIBS)
++ $(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ border.o: border.c border-textures.h
+ $(CC) $(CFLAGS) -c border.c -o border.o