aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-resynthesizer/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-27 00:02:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-27 00:02:04 +0000
commitb26b1c46f9a6408df5d9dc05d77d793648b3425e (patch)
treebfcf1dca1a7fc206e66b9b5aec82c7a2e49ba81d /graphics/gimp-resynthesizer/Makefile
parent74654a4da40f043cb9399c08d416b447924b7b8f (diff)
downloadports-b26b1c46f9a6408df5d9dc05d77d793648b3425e.tar.gz
ports-b26b1c46f9a6408df5d9dc05d77d793648b3425e.zip
- Switch to USES=autoreconf
- Add LICENSE - Improve gimp plugin dir handling - Add missing localization file to plist
Notes
Notes: svn path=/head/; revision=387526
Diffstat (limited to 'graphics/gimp-resynthesizer/Makefile')
-rw-r--r--graphics/gimp-resynthesizer/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
index 23bc49c64df2..58d5dca19df2 100644
--- a/graphics/gimp-resynthesizer/Makefile
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -4,13 +4,15 @@
PORTNAME= resynthesizer
PORTVERSION= 2.0
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
PKGNAMEPREFIX= gimp-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Gimp plug-in for texture synthesis
+LICENSE= GPLv2 # or later (COPYING has GPLv3)
+
RUN_DEPENDS= ${LOCALBASE}/libexec/gimp/2.2/python/gimpfu.py:${PORTSDIR}/graphics/py-gimp
BUILD_DEPENDS= intltool-extract:${PORTSDIR}/textproc/intltool
LIB_DEPENDS= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
@@ -18,11 +20,13 @@ LIB_DEPENDS= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
USE_GITHUB= yes
GH_ACCOUNT= bootchk
+USES= autoreconf compiler:nestedfct gettext gmake pkgconfig
GNU_CONFIGURE= yes
+
LIBS+= -L${LOCALBASE}/lib -lintl
-USES= gettext gmake pkgconfig compiler:nestedfct
-USE_AUTOTOOLS= aclocal automake
-AUTOMAKE_ARGS= --add-missing
+
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
+PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
OPTIONS_DEFINE= THREADS
THREADS_DESC= Threading support (produces nondeterministic results)
@@ -30,8 +34,8 @@ THREADS_DESC= Threading support (produces nondeterministic results)
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|^\(gimpplugindir=\).*|\1"$$GIMP_LIBDIR"|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^\(GIMP_LIBDIR=\).*|\1"$${prefix}/${PLUGIN_DIR:H}"|; \
+ s|^\(gimpplugindir=\).*|\1"$$GIMP_LIBDIR"|' ${WRKSRC}/configure.in
.if ! ${PORT_OPTIONS:MTHREADS}
@${REINPLACE_CMD} -e '/^#define SYNTH_THREADED/ d' \
${WRKSRC}/src/buildSwitches.h