aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-12-09 09:37:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-12-09 09:37:39 +0000
commit406aca99967d9b88aed03e125c0ac40606edc61e (patch)
tree0f09587d5e33274a2301bfe5b6470c1b00cd83bd /graphics/glfw2
parent6ae5db56c6c128330dbdf0ef2cd2c8baa8b6474d (diff)
downloadports-406aca99967d9b88aed03e125c0ac40606edc61e.tar.gz
ports-406aca99967d9b88aed03e125c0ac40606edc61e.zip
- Simplify docs and examples installation
- Fix absolute symlink to the library - Add LICENSE_FILE - Update WWW
Notes
Notes: svn path=/head/; revision=557359
Diffstat (limited to 'graphics/glfw2')
-rw-r--r--graphics/glfw2/Makefile54
-rw-r--r--graphics/glfw2/pkg-descr2
2 files changed, 21 insertions, 35 deletions
diff --git a/graphics/glfw2/Makefile b/graphics/glfw2/Makefile
index 0c6d1eae8ee2..b54802f615e6 100644
--- a/graphics/glfw2/Makefile
+++ b/graphics/glfw2/Makefile
@@ -12,9 +12,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Portable framework for OpenGL development
LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
USES= gl tar:bzip2 xorg
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= compile.sh
ALL_TARGET= x11
INSTALL_TARGET= x11-install
@@ -28,36 +29,18 @@ PLIST_FILES= include/GL/glfw.h lib/libglfw.a lib/libglfw.so \
lib/libglfw.so.0 libdata/pkgconfig/libglfw.pc
PORTDOCS= *
-
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
-
-DOCSRCDIR1= ${WRKSRC}
-DOC_FILES1= *.html
-
-DOCSRCDIR2= ${WRKSRC}/docs
-DOCSDIR2= ${DOCSDIR}/docs
-DOC_FILES2= *.pdf *.sty *.tex *.txt
-
PORTEXAMPLES= *
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
-EXAMPLESSRCDIR1= ${WRKSRC}/examples
-EXAMPLES_FILES1= boing gears heightmap listmodes mipmaps mtbench \
- mthello pong3d splitview triangle wave
-
-EXAMPLESSRCDIR2= ${WRKSRC}/tests
-EXAMPLESDIR2= ${EXAMPLESDIR}/tests
-EXAMPLES_FILES2= accuracy defaults dynamic events fsaa fsinput iconify \
- joysticks peter reopen tearing version
-
OPTIONS_DEFINE= DOCS EXAMPLES
# Restrict to stable (even) versions, indicated by the second component.
PORTSCOUT= limit:^2\..*
post-extract:
- @${CHMOD} ${BINMODE} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${CHMOD} +x ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|; \
@@ -68,21 +51,24 @@ post-patch:
${WRKSRC}/lib/x11/Makefile.x11.in
post-install:
- ${INSTALL_DATA} ${WRKSRC}/lib/x11/libglfw.so \
- ${STAGEDIR}${PREFIX}/lib/libglfw.so.0
- ${LN} -sf ${PREFIX}/lib/libglfw.so.0 ${STAGEDIR}${PREFIX}/lib/libglfw.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libglfw.so.0
+ ${INSTALL_LIB} ${WRKSRC}/lib/x11/libglfw.so ${STAGEDIR}${PREFIX}/lib/libglfw.so.0
+ ${LN} -sf libglfw.so.0 ${STAGEDIR}${PREFIX}/lib/libglfw.so
- @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DOCSDIR2}
- ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.html ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} *.pdf *.sty *.tex *.txt ${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR1}/|} \
- ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${EXAMPLESSRCDIR1}/*.tga ${STAGEDIR}${EXAMPLESDIR}
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR2}
- ${INSTALL_PROGRAM} ${EXAMPLES_FILES2:S|^|${EXAMPLESSRCDIR2}/|} \
- ${STAGEDIR}${EXAMPLESDIR2}
+.for f in boing gears heightmap listmodes mipmaps mtbench mthello pong3d splitview triangle wave
+ ${INSTALL_PROGRAM} ${WRKSRC}/examples/${f} ${STAGEDIR}${EXAMPLESDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.tga ${STAGEDIR}${EXAMPLESDIR}
+
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/tests
+.for f in accuracy defaults dynamic events fsaa fsinput iconify joysticks peter reopen tearing version
+ ${INSTALL_PROGRAM} ${WRKSRC}/tests/${f} ${STAGEDIR}${EXAMPLESDIR}/tests
+.endfor
.include <bsd.port.mk>
diff --git a/graphics/glfw2/pkg-descr b/graphics/glfw2/pkg-descr
index a411cc447c5e..b055a68db326 100644
--- a/graphics/glfw2/pkg-descr
+++ b/graphics/glfw2/pkg-descr
@@ -3,4 +3,4 @@ development that provides a powerful API for handling operating system specific
tasks such as opening an OpenGL window, reading keyboard, mouse, joystick and
time input, creating threads, and more.
-WWW: http://www.glfw.org/
+WWW: https://www.glfw.org/