aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2019-08-13 18:08:40 +0000
committerJason Helfman <jgh@FreeBSD.org>2019-08-13 18:08:40 +0000
commita42a7aa225afa3c0d0c970fa0f52f079888e1e61 (patch)
tree1f7d805702c619b5951cef005c96bd79f9bb8f08 /graphics/glfw
parent1ccea1b797c2a0e8b87cbebb8bb67a9aee4d6cea (diff)
downloadports-a42a7aa225afa3c0d0c970fa0f52f079888e1e61.tar.gz
ports-a42a7aa225afa3c0d0c970fa0f52f079888e1e61.zip
- address WAYLAND build
PR: 238085 Submitted by: list1@gjunka.com Approved by: neel@neelc.org (maintainer)
Notes
Notes: svn path=/head/; revision=508841
Diffstat (limited to 'graphics/glfw')
-rw-r--r--graphics/glfw/Makefile1
-rw-r--r--graphics/glfw/files/patch-src-wl_init.c26
2 files changed, 27 insertions, 0 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 828fb53e5c8c..17c517d5978b 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= glfw
PORTVERSION= 3.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
diff --git a/graphics/glfw/files/patch-src-wl_init.c b/graphics/glfw/files/patch-src-wl_init.c
new file mode 100644
index 000000000000..a4fe12bbdd0a
--- /dev/null
+++ b/graphics/glfw/files/patch-src-wl_init.c
@@ -0,0 +1,26 @@
+--- src/wl_init.c.orig 2019-08-03 17:40:05 UTC
++++ src/wl_init.c
+@@ -29,7 +29,6 @@
+ #include <assert.h>
+ #include <errno.h>
+ #include <limits.h>
+-#include <linux/input.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -37,6 +36,15 @@
+ #include <sys/timerfd.h>
+ #include <unistd.h>
+ #include <wayland-client.h>
++#ifdef __has_include
++#if __has_include(<linux/input.h>)
++#include <linux/input.h>
++#elif __has_include(<dev/evdev/input.h>)
++#include <dev/evdev/input.h>
++#endif
++#else
++#include <linux/input.h>
++#endif
+
+
+ static inline int min(int n1, int n2)