aboutsummaryrefslogtreecommitdiff
path: root/graphics/glide3
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-18 15:51:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-01-18 15:51:41 +0000
commit3f8734a1b8f4f949e9a6f0f94670baa0a0d45723 (patch)
tree1ae808959105014c9bcf0d6cffcf950e06c829a7 /graphics/glide3
parenta306f64971833bdabd84eeabcd9995cf27820aed (diff)
downloadports-3f8734a1b8f4f949e9a6f0f94670baa0a0d45723.tar.gz
ports-3f8734a1b8f4f949e9a6f0f94670baa0a0d45723.zip
Unbreak the build with latest GCC.
Notes
Notes: svn path=/head/; revision=126721
Diffstat (limited to 'graphics/glide3')
-rw-r--r--graphics/glide3/Makefile4
-rw-r--r--graphics/glide3/files/patch-h3-minihwc-linhwc_c_dri10
-rw-r--r--graphics/glide3/files/patch-h3-src-makefile2
-rw-r--r--graphics/glide3/files/patch-h5-src-makefile2
4 files changed, 12 insertions, 6 deletions
diff --git a/graphics/glide3/Makefile b/graphics/glide3/Makefile
index d97d92e51571..68d8cdcb4e12 100644
--- a/graphics/glide3/Makefile
+++ b/graphics/glide3/Makefile
@@ -40,10 +40,6 @@ OPTIONS= VOODOO3 "Enable this if you have a Voodoo3 or Banshee card" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
.if defined(WITH_VOODOO3)
PKGNAMESUFFIX= -v3
CONFIGURE_ARGS+= --enable-fx-glide-hw=h3
diff --git a/graphics/glide3/files/patch-h3-minihwc-linhwc_c_dri b/graphics/glide3/files/patch-h3-minihwc-linhwc_c_dri
new file mode 100644
index 000000000000..5d0447bfdf6a
--- /dev/null
+++ b/graphics/glide3/files/patch-h3-minihwc-linhwc_c_dri
@@ -0,0 +1,10 @@
+--- h3/minihwc/linhwc.c.dri.orig Tue Jan 18 21:29:49 2005
++++ h3/minihwc/linhwc.c.dri Tue Jan 18 21:30:23 2005
+@@ -91,6 +91,7 @@
+ static FxU32 calcBufferSize(FxU32 xres, FxU32 yres, FxBool tiled);
+ static FxU32 calcBufferSizeInTiles(FxU32 xres, FxU32 yres);
+ static FxU32 calcBufferHeightInTiles(FxU32 yres);
++static FxU32 hwcBufferLfbAddr(const hwcBoardInfo *bInfo, FxU32 physAddress);
+
+ typedef struct envitem_t {
+ char *env;
diff --git a/graphics/glide3/files/patch-h3-src-makefile b/graphics/glide3/files/patch-h3-src-makefile
index ddfb8ef632ba..64ea6835edc0 100644
--- a/graphics/glide3/files/patch-h3-src-makefile
+++ b/graphics/glide3/files/patch-h3-src-makefile
@@ -16,7 +16,7 @@
-PREPROCESSOR=/lib/cpp -$$ -I.
-xdraw2.o : xdraw2.S xdraw2.inc.S fxgasm.h
- $(CC) $(AFLAGS) -c -o $@ xdraw2.S
-+PREPROCESSOR=/usr/libexec/cpp0 -$$ -I.
++PREPROCESSOR=$(CPP) -$$ -I.
+xdraw2.lo : xdraw2.S xdraw2.inc.S fxgasm.h
+ libtool --mode=compile $(CC) $(AFLAGS) -c -o $@ xdraw2.S
diff --git a/graphics/glide3/files/patch-h5-src-makefile b/graphics/glide3/files/patch-h5-src-makefile
index 29e4c66344a5..07a35c8bbd20 100644
--- a/graphics/glide3/files/patch-h5-src-makefile
+++ b/graphics/glide3/files/patch-h5-src-makefile
@@ -5,7 +5,7 @@
# Special rules for assembly files.
#
-PREPROCESSOR=/lib/cpp -$$ -I.
-+PREPROCESSOR=/usr/libexec/cpp0 -$$ -I.
++PREPROCESSOR=$(CPP) -$$ -I.
xdraw2_def.o xdraw2_def.lo: xdraw2.s xdraw2.inc.s fxgasm.h
$(PREPROCESSOR) $< > $*.tmp.s
- $(CC) $(AFLAGS) -c -o $*.o $*.tmp.s