aboutsummaryrefslogtreecommitdiff
path: root/graphics/glpng
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
commit3037cb61c7f1ac5ae9a15cee2365daa2d4036028 (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /graphics/glpng
parent28eb882aa04c420b3fe972dd8748b80c90c5cd82 (diff)
downloadports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.tar.gz
ports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful
Notes
Notes: svn path=/head/; revision=321181
Diffstat (limited to 'graphics/glpng')
-rw-r--r--graphics/glpng/Makefile7
-rw-r--r--graphics/glpng/files/patch-glpng.c32
2 files changed, 18 insertions, 21 deletions
diff --git a/graphics/glpng/Makefile b/graphics/glpng/Makefile
index 0cf952ac6980..8535f3801565 100644
--- a/graphics/glpng/Makefile
+++ b/graphics/glpng/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: glpng
-# Date created: 06 Mar 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= glpng
PORTVERSION= 1.45
@@ -21,6 +17,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_GL= gl
USE_ZIP= yes
USE_LDCONFIG= yes
+USE_DOS2UNIX= glpng.c
AR?= /usr/bin/ar
diff --git a/graphics/glpng/files/patch-glpng.c b/graphics/glpng/files/patch-glpng.c
index 5a74cc264149..643e476a0e23 100644
--- a/graphics/glpng/files/patch-glpng.c
+++ b/graphics/glpng/files/patch-glpng.c
@@ -6,13 +6,13 @@
+#include "png.h"
#include <GL/glpng.h>
- #include <GL/gl.h>
+ #include <GL/gl.h>
#include <stdlib.h>
#include <math.h>
-#include "png/png.h"
-
- /* Used to decide if GL/gl.h supports the paletted extension */
- #ifdef GL_COLOR_INDEX1_EXT
+
+ /* Used to decide if GL/gl.h supports the paletted extension */
+ #ifdef GL_COLOR_INDEX1_EXT
@@ -269,14 +269,14 @@
if (pinfo == NULL) return 0;
@@ -24,12 +24,12 @@
info = png_create_info_struct(png);
endinfo = png_create_info_struct(png);
- // DH: added following lines
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- {
- png_destroy_read_struct(&png, &info, &endinfo);
- return 0;
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
@@ -373,14 +373,14 @@
png_uint_32 i;
@@ -41,9 +41,9 @@
info = png_create_info_struct(png);
endinfo = png_create_info_struct(png);
- // DH: added following lines
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- {
- png_destroy_read_struct(&png, &info, &endinfo);
- return 0;
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;