aboutsummaryrefslogtreecommitdiff
path: root/graphics/goocanvas2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-06-05 21:42:53 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-06-05 21:42:53 +0000
commit7214b364c8e53031f44218ad6757046a54a6e19b (patch)
tree4b4e39fc198b01df0a8902e4cd0979cefd3e6d88 /graphics/goocanvas2/Makefile
parent5d1eb87948868a0d221e6d8f6343cdb4c9120156 (diff)
downloadports-7214b364c8e53031f44218ad6757046a54a6e19b.tar.gz
ports-7214b364c8e53031f44218ad6757046a54a6e19b.zip
Add goocanvas 2.0.1.
Canvas widget for Gtk+3
Notes
Notes: svn path=/head/; revision=320026
Diffstat (limited to 'graphics/goocanvas2/Makefile')
-rw-r--r--graphics/goocanvas2/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/graphics/goocanvas2/Makefile b/graphics/goocanvas2/Makefile
new file mode 100644
index 000000000000..ac15dddbe654
--- /dev/null
+++ b/graphics/goocanvas2/Makefile
@@ -0,0 +1,48 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/graphics/goocanvas2/Makefile 17268 2013-04-01 05:13:11Z marcus $
+
+PORTNAME= goocanvas
+PORTVERSION= 2.0.1
+CATEGORIES= graphics
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 2
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Canvas widget for GTK+ 3
+
+LATEST_LINK= goocanvas2
+
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+
+USES= pathfix pkgconfig
+USE_GNOME= gtk30 ltverhack
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+USE_XZ= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/gtk-doc/html/goocanvas2
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+.if ! ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g' ${WRKSRC}/Makefile.in
+.endif
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|po||g' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>